Parker Servo Drive

Parker Servo Drive

190-011008N6 2020-12 From Release R1.10.1 | Parker Servo Drive Servo drives with Ethernet/IP – Interface Instruction Manual


Trademarks / non-warranty clause / Addresses

____________________________

Trademarks

Trademarks

Windows 10 and Windows 11 are registered trademarks of the Microsoft Corporation.

EtherCAT® and Safety over EtherCAT® are registered trademarks and patented technologies, licensed by Beckhoff Automation GmbH, Germany.

CODESYS® is a registered trademark of 3S-Smart Software Solutions GmbH.

PROFINET® is a registered trademark of Profibus and PROFINET International.

Ethernet/IP is a trademark of Open DeviceNet Vendor Association.


Non-warranty clause

Non-warranty clause

We checked the contents of this publication for compliance with the associated hardware and software. We can, however, not exclude discrepancies and do therefore not accept any liability for the exact compliance. The information in this publication is regularly checked, necessary corrections will be part of the subsequent publications.

German Master created.

Addresses

Production site:

Germany

Parker Hannifin Manufacturing Germany GmbH & Co. KG
Electric Motion & Pneumatic Division [EMPD]
Robert-Bosch-Strasse 22
77656 Offenburg (Germany)
Tel.: + 49 (0781) 509-0
Fax: + 49 (0781) 509-98176
Internet: www.parker.com/eme
E-mail: EMPD.IndControlDrivesTech@support.parker.com

Certified accrding to ISO 9001:2015

Parker Hannifin Manufacturing Germany GmbH & Co KG - Sitz: Bielefeld - Amtsgericht: Bielefeld HRA 15699

Partner liable to unlimited extent: Parker Hannifin GmbH, Sitz Bielefeld, Amtsgericht Bielefeld HRB 35489

Management of the PARKER Hannifin GmbH: Ulrich Jochem, Achim Kohler, Kirsten Stenvers, Andreas Paulsen,

Chairman of the board: Dr.-Ing. Gerd Scheffel

Italy:

Parker Hannifin Manufacturing Srl
Electric Motion & Pneumatic Division [EMPD]
Via C. Gounod, 1
20092 Cinisello Balsamo (Milano), Italy
Phone: + 39 (0)2 361081
Fax: + 39 (0)2 36108400
Internet: www.parker.com/eme
E-mail: parker.italy@parker.com

Certified according to ISO 9001:2015

Location USA:

Parker Hannifin Corporation • Electronic Motion and Controls Division
5500 Business Park Drive • Rohnert Park, CA 94928
Phone #: (800) 358-9070 • FAX #: (707) 584-3715
E-mail: CMR_help@parker.com • Internet: www.parker.com/emc


What is necessary and where to find it?

Software Tool,

Field Bus Files,

CE declaration of compliance

PSD ServoManager

Downloads under http://solutions.parker.com/psd_support


Introduction

In this chapter you can read about:

Device assignment

Scope of delivery

Type identification plate PSD1-S and PSD1-M with Safety Option Board

Type identification plate PSD1-M

Order/ type code PSD

Designated use

Packaging, transport, storage

For Safety Use

IT Security

Warranty conditions

Conditions of utilization

Before commissioning the drive, please observe the following:


Device assignment

This manual applies for the following devices:
  • PSD1-SW1200B2 (2 A)
  • PSD1-SW1300B2 (5 A)
  • PSD1-M_1300B2 (5 A)
  • PSD1-M_1400B2 (8 A)
  • PSD1-M_1600B2 (15 A)
  • PSD1-M_1800B2 (30 A)
  • PSD1-M_2220B2 (2 A + 2 A)
  • PSD1-M_2330B2 (5 A + 5 A)
  • PSD1-M_2440B2 (8 A + 8 A)
  • PSD1-M_2630B2 (15 A + 5 A)
  • PSD1-M_3222B2 (2 A + 2 A + 2 A)
  • PSD1-M_3433B2 (8 A + 5 A + 5 A)
  • PSD1-MWP010 (Mains module 10 kW)
  • PSD1-MWP020 (Mains module 20 kW)

and configured Ethernet/IP fieldbus.


Scope of delivery

Included in delivery are mating connectors for:

PSD1-S | X17 (Push-in) X51, X52, X63 Cable clamps for the motor cable in sizes D=7,9/9.5/11.1/12.7 mm
PSD1-M: | X17 / X21 (Push-in) X45, X46, X48 Tin angle with screw terminals for motor and feedback cable
PSD1-M_P: | X4 (Push-in) X9, X40, X41


Type identification plate PSD1-S and PSD1-M with Safety Option Board

The present device type is defined by the type specification plate (on the housing):

PSD1-S

1 | Order code of the device
2 | Input voltage
3 | Input Current
4 | Serial Number
5 | Output voltage
6 | Output current
7 | Output frequency
8 | UL certification (corresponding to the existing logo)
9 | Type of safety certification


Type identification plate PSD1-M

The present device type is defined by the type specification plate (on the housing):

1 | Order code of the device
2 | Serial Number
3 | Input voltage
4 | Input Current
5 | UL certification
6 | Output voltage
7 | Output current
8 | Output frequency
9 | IP Rating


Order/ type code PSD

 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11
Order example | PSD1 | M | W | 3 | 433 | B | 1 | 1 | 0 | 0 | 000

1

Drive family

PSD1

Parker Servo Drive

2

Device type

S

Stand-Alone 230 VAC

M

Multi-axis 400 VAC

3

Mounting type

W

Wall mounted

4

Equipment Type

1

1 performance level

2

2 performance levels

3

3 performance levels

P

Mains modules

5

Equipment Type

PSD1SW1 Stand-Alone

200

2 A

300

5 A

PSD1MW1: 1 performance level

300

5 A

400

8 A

600

15 A

800

30 A

PSD1MW2: 2 performance levels

220

2 + 2 A

330

5 + 5 A

440

8 + 8 A

PSD1MW3: 3 performance levels

222

2 + 2 + 2 A

433

8 + 5 + 5 A

PSD1MWP

010

10 kVA

020

20 kVA

6

Technology

B

Cover

C

Programmable in accordance with IEC61131-3 with PLCopen function modules

7

Interface

1

EtherCAT

(standard, also for technology C applications "without fieldbus")

2

Multi field bus

Field bus configurable (for the device):1)

PROFINET

EtherCAT

Ethernet/IP

8

Feedback

1

Hiperface DSL®

2

Multi feedback

Feedback configurable (for the device):1)

Generally available 2) | Conditionally available 3)
*Hiperface DSL® *Resolver | * Encoder (1 Vss) * Encoder A/B (TTL (RS422)) * Analog Hall (1 Vss)

in future/planned 3)

* EnDat 2.2 (purely digital) 4)

* BISS_C 4)

9

Option 1

0

No option

1

Functional safety via EtherCAT

(only possible for ...B11... devices)

...B11...:

Technology B: Cover

Interface 1: EtherCAT

Feedback 1: Hiperface DSL®

2

IO Optionboard Slot1, only available in combination with Slot2 option

10

Option 2

0

No option

2

IO Optionboard Slot2

11

Customized

000

Not customer-specific

1) Configurable in the PSD ServoManager

2) For PSD1MW2 and PSD1MW3 all axes must be configured to the same feedback system

3) in the 1st setup level only for PSD1-S and PSD1MW11 (multi-axis devices with only one possible axis)

4) in development


Designated use

The device is designed for operation in electric power drive systems (EN 50178). Motion sequences can be automated with this device. Several motion sequences can be can combined by interconnecting several of these devices. Mutual interlocking functions must be incorporated for this purpose.

Please respect the technical data!

Exceeding / not respecting its intended use or its limits may cause danger.

  • Motion sequence may not be carried out correctly which can cause personal injuries or material damages.
  • The device might be destroyed what could result in fire.
  • The device corresponds to EN 61800-3, i.e. it is subject to limited sale. The device can emit disturbances in certain local environments. In this case, the user is liable to take suitable measures.


Packaging, transport, storage

Packaging material and transport

Caution!

The packaging material is inflammable, if it is disposed of improperly by burning, lethal fumes may develop.

The packaging material must be kept and reused in the case of a return shipment. Improper or faulty packaging may lead to transport damages.

Make sure to transport the drive always in a safe manner and with the aid of suitable lifting equipment (Weight). Do never use the electric connections for lifting. Before the transport, a clean, level surface should be prepared to place the device on. The electric connections may not be damaged when placing the device.

First device checkup
  • Check the device for signs of transport damages.
  • Please verify, if the indications on the Type identification plate correspond to your requirements.
  • Check if the consignment is complete.
Disposal

This product contains materials that fall under the special disposal regulation from 2010, which corresponds to the EC directory 2008/98/EC for dangerous disposal material. We recommend to dispose of the respective materials in accordance with the respectively valid environmental laws. The following table states the materials suitable for recycling and the materials which have to be disposed of separately.

Material | suitable for recycling | Disposal
metal | yes | no
Plastics | yes | no
Circuit boards | no | yes

Please dispose of the circuit boards according to one of the following methods:

  • Burning at high temperatures (at least 1200°C) in an incineration plant licensed in accordance with part A or B of the environmental protection act.
  • Disposal via a technical waste dump which is allowed to take on electrolytic aluminium condensers. Do under no circumstances dump the circuit boards at a place near a normal waste dump.
Storage

If you do not wish to mount and install the device immediately, make sure to store it in a dry and clean environment. Make sure that the device is not stored near strong heat sources and that no metal chippings can get into the device.

Please note in the event of storage >1 year:
Forming the capacitors

Forming the capacitors only required with 400 VAC axis controllers and mains module PSD1-M_P

If the device was stored longer than one year, the intermediate capacitors must be re-formed!

Forming sequence:

  • Remove all electric connections
  • Supply the device with 230VAC single phase for 30 minutes
    • via the L1 and L2 terminals on the device or
    • with multi axis devices via L1 and L2 on the mains module PSD1-M_P.


For Safety Use

In this chapter you can read about:

Explanation of the safety instructions

Working safely / qualification

General hazards

Special dangers

Cautionary Markings

Responsibility


Explanation of the safety instructions

Indicates a potential risk that may result in death or severe injury.

Indicates a potential medium risk with that may result in death or severe injury.

Indicates a potential low risk with that may result in minor or moderate injury.

Alerts you to situations that may damage this product or other products.


Working safely / qualification

This device may be operated only by qualified personnel.

Qualified personnel in the sense of these operating instructions consists of:

  • Persons who, by virtue to their training, experience and instruction, and their knowledge of pertinent norms, specifications, accident prevention regulations and operational relationships, have been authorized by the officer responsible for the safety of the system to perform the required task and in the process are capable of recognizing potential hazards and avoiding them (definition of technical personnel according to VDE105 or IEC364),
  • who have a knowledge of first-aid techniques and the local emergency rescue services,
  • who have read and will observe the safety instructions,
  • who have read and observe the manual or help (or the sections pertinent to the work to be carried out).

This applies to all work relating to setting up, commissioning, configuring, programming, modifying the conditions of utilization and operating modes, and to maintenance work.

This manual and the help information must be available close to the device during the performance of all tasks.


General hazards

General Hazards on Non-Compliance with the Safety Instructions

The device described in this manual is designed in accordance with the latest technology and is safe in operation. Nevertheless, the device can entail certain hazards if used improperly or for purposes other than those explicitly intended.

Electronic, moving and rotating components can

  • constitute a hazard for body and life of the user, and
  • cause material damage


Special dangers

Danger!

Due to movable machine parts and high voltages, the device can pose a lethal danger. Danger of electric shock in the case of non-respect of the following instructions. The device corresponds to DIN EN 61800-3, i.e. it is subject to limited sale. The device can emit disturbances in certain local environments. In this case, the user is liable to take suitable measures.
  • Check that all live terminals are secured against contact. Dangerous voltages up to 850V occur.
  • Do not short-circuit the DC power voltage.
CAUTION: Risk of electric shock
Caution - Risk of electric shock!

Before wiring or loosening electrical connections please observe the following:

  • Risk of electric shock, disconnect power before removing cover resp. disconnect the devices from the mains supply.
  • Caution! Dangerous electrical voltage even after turning off the intermediate capacitors:
    Up to 3 minutes with PSD1-S and 10 minutes with PSD1-M after switching off mains supply, dangerous voltages may still be present.
    Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- of PSD1-S: X63/3 & X63/5 and with PSD1-M: Bus HV DC - 3 & 5. rail.

  • The device must be permanently grounded due to high earth leakage currents. The leakage current is greater than 3.5 mA.
  • The drive motor must be grounded with a suitable protective lead.
  • The devices are equipped with high voltage DC capacitor. Before removing the protective cover, the discharging time must be awaited. After switching off the supply voltage, it may take up to 3 minutes with PSD1-S and 10 minutes with PSD1-M (up to 30 minutes with additional capacitor modules) to discharge the capacitors.
    Danger of electric shock in case of non respect.

  • Do never perform resistance tests with elevated voltages (over 690V) on the wiring without separating the circuit to be tested from the drive.
  • Please exchange devices only in currentless state and, in an axis system, only in a defined original state.
  • If the axis controller is replaced, it is absolutely necessary to transfer the configuration determining the correct operation of the drive to the device before the device is put into operation. Depending on the operation mode, a machine zero run will be necessary.
  • The device contains electrostatically sensitive components. Please observe the electrostatic protection measures while working at/with the device as well as during installation and maintenance.


Cautionary Markings

Ignoring of the following instructions will result in personal injury or material damage.

  • The heat disispator can reach very high temperatures (>70°C)
  • Do never perform resistance tests with elevated voltages (over 690V) on the wiring without separating the circuit to be tested from the drive.
  • Please exchange devices only in currentless state and, in an axis system, only in a defined original state.
  • If the axis controller is replaced, it is absolutely necessary to transfer the configuration determining the correct operation of the drive to the device before the device is put into operation. Depending on the operation mode, a machine zero run will be necessary.
  • The device contains electrostatically sensitive components. Please heed the electrostatic protection measures while working at/with the device as well as during installation and maintenance.
  • Never carry out high voltage resistance tests at lines without disconnecting the drive from the power supply you need to check.
  • Provide protection and/or additional safety systems in order to prevent personal injury and material damage. Always care for sufficient ventilation.
  • All control and signal terminals guaranty safe extra-low voltages (SELV), i.e. they are protected by a double isolation. Make sure the complete external wiring is approved for the highest system voltage.
  • The user is responsible for protective covers and/or additional safety measures in order to prevent damages to persons and electric accidents.


Responsibility

Fitters and operators of any machine or systems are responsible for ensuring that, in case of failure of a device or component, the drive and therefore the machine or system is rendered safe. In doing so, people must not be endangered.

The here-in described technical data, processes and circuits are merely a general guidance and may not be suitable for the user's specified application. We cannot guaranty the suitability for certain applications of the device described in this manual.


IT Security

Parker PSD is designed for operation within closed industrial networks.

If the industrial networks are publicy accessible, e.g. through freely accessible network interfaces, or publicy accessible, e.g. through data connections via public data traffic (Internet), then suitable organisational and technical security measures must be taken by the integrator and operator to protect the internal network and ensure IT security.

Note

Information for the secure operation of plants, systems, machines and networks can be found, among others, in the BSI information publications and IEC 62243.


Warranty conditions

  • The device must not be opened.
  • No changes may be made to the device; except for the changes described in the manual.
  • Make connections to the inputs, outputs and interfaces only in the manner described in the manual.
  • Fix the devices according to the mounting instructions.
    We cannot provide any guarantee for other mounting methods.

Note on exchange of options

Device options must be exchanged in the factory to ensure hardware and software compatibility.

  • When installing the device, make sure the heat dissipators of the device receive sufficient air and respect the recommended mounting distances of the devices with integrated ventilator fans in order to ensure free circulation of the cooling air.
  • Make sure that the mounting plate is not exposed to external temperature influences.


Conditions of utilization

In this chapter you can read about:

Conditions of utilization for CE-conform operation

CE declaration of conformity PSD1-M

CE declaration of conformity PSD1-S

Conditions of utilization for the cUL certification of PSD1-S

Conditions of utilization for the cUL certification of PSD1-M

Current on the mains PE (leakage current)

Supply networks


Conditions of utilization for CE-conform operation

- Industry and trade -

- Industry and trade -

The EC guidelines for electromagnetic compatibility 2014/30/EU and for electrical operating devices for utilization within certain voltage limits 2014/35/EU are fulfilled when the following boundary conditions are observed:

Operation of devices only in the state in which they are delivered.

Contact protection mating plug

In order to ensure contact protection, all mating plugs must be present on the device connections even if they are not wired.

Instructions for this manual

Please respect the specifications of the manual resp. of the help function, especially the technical characteristics (mains connection, circuit breakers, output data, ambient conditions,...).


Mains filter for use in industrial areas

The mains supply line requires a mains filter for the PSD1-M in general and for the PSD1-S from a specific motor cable length. Filtering can be provided plant specifically or separately for each device respectively for each axis combination.

Use of the devices in the industrial area (limit values class C3 in accordance with EN 61800-3)

The following mains filters are available for self-sufficient utilization:

Device: | Limit value class | Axis system with motor cable / Single-axis | Mains filter Order No.:
PSD1-M_P010 | C3 | < 6 x 10 m | ECP-0003-01
PSD1-M_P010 | C3 | < 6 x 50 m | ECP-0003-02
PSD1-M_P020 | C3 | < 6 x 50 m | ECP-0003-03
PSD1-S | C3 | < 10 m | no mains filter
PSD1-S (single phase supply) | C3 | > 10 m | ECP-0001-01
PSD1-S (3-phase supply) | C3 | > 10 m | ECP-0002-01

Connection length in-between mains filters & device

In general, the connection mains filter - device shall be as short as possible.

unshielded: | < 0.5 m
shielded: | < 5 m (screen must be connected to ground - e.g. ground - control cabinet)


Motor and feedback cable requirements

  • Operation of the devices only with motor and feedback cables containing a flat shielding.
  • Maintain the shielding as close as possible to the cable-end (max distance 8 cm).
  • Ground empty wires in the cable on both sides.
  • Please note the connector descriptions (X52: Motor connection (PSD1-S), X51: Motor holding brake and HIPERFACE DSL® Connection, X45: Motor Connection (PSD1-M), X43: Motor Connection (PSD1M_1800), X48: HIPERFACE DSL® & motor temperature sensor (PSD1-M))

Request for motor cable PSD

<100 m per axis (the cable must not be rolled up!).

The entire length of the motor cable per axis combination may not exceed 300 m.

PSD1-M

For motor cables >20 m a motor output choke is required for PSD1-M devices:

  • ECM-0004-01 (max. 6.3 A nominal motor current)
  • ECM-0001-01 (max. 16 A nominal motor current)
  • ECM-0002-01 (max. 30 A nominal motor current)
PSD1-S

For motor cables >50 m a motor output choke is required for PSD1-S devices:

  • ECM-0005-01 (max. 7 A motor nominal current)

Shielding connection of the PSD motor cable

Shielding connection of the motor cable

The external shield of the motor cable must be properly (=over a large area!) connected to the PE both on the drive side (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)) (on the device housing or on the rear wall of the control cabinet) as well as on the motor side (motor housing e.g. via the motor cable plug connector).

The outer and any existing additional inner shielding for the DSL or motor holding brake must not be interrupted.

Cable installation:

  • Signal lines and power lines should be installed as far apart as possible; cross points 90°.
  • Signal lines should never pass close to excessive sources of interference (motors, transformers, contactors etc.).
  • Do not place mains filter output cable parallel to the load cable.
  • Lines must lead along conductive, grounded metal surfaces as closely as possible.


Motors

Operation with standard motors.

Connecting protective earth

Additionally to the ground connection at the power mains connection, establish a ground connection via the grounding screw (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)) on the device bottom by means of a copper cable with the same section.

In case there is not earth connection at the mains connection, the wire used must have a minimum diameter of 10 mm2.

The connection to the central earth rail should be as short as possible. The minimum required width of the central earth rail depends on the length of the grounding cable:

Length [m] | Width [mm] | Strength [mm]
0.5 | 20 | 6
1 | 40 | 6
1.5 | 50 | 6
  • Pay close attention to the overall grounding of the complete system.
  • With several mounting plates: Ground connection by copper rails or copper strip.
  • Ensure ground connection between the control cabinet and machine.
  • Earth control transformer thoroughly (for 24 VDC). Use a transformer with tin angles and make conductive contact with the mounting plate.

Grounding request

Connect the filter housing and the device to the cabinet frame, making sure that the contact area is adequate and that the connection has low resistance and low inductance by using an 3 mm steel plate (galvanized).

Never mount the filter housing and the device on paint-coated surfaces!


Control requirements

Use only with aligned controller (to avoid control loop oscillation).

Accessories

Make sure to use only the accessories recommended by Parker.

Notes on the use in domestic environments

This is restricted operation category product according to EN 61800-3. This product can cause high-frequency disturbance in domestic areas. Users are asked to take suitable action if this proves to be the case.


CE declaration of conformity PSD1-M

CE declaration of conformity PSD1-M


CE declaration of conformity PSD1-S

CE declaration of conformity PSD1-S


Conditions of utilization for the cUL certification of PSD1-S

In this chapter you can read about:

UL certification

Installations- & Environmental Characteristics PSD1-S

Tightening torque of the wiring terminals

Auxiliary connection – electrical ratings

Data of integrated dynamic brake unit

In- / Output Ratings


UL certification

Category | Specifications
Certified | E-File_No.: E142140 The UL certification is only valid if the type plate of the device shows the "UL" -sign.

PSD1-S:

UL61800-5-1 1st Edition, issued June, 8th, 2012

C22.2 No.274-13, 1st Edition, issued March, 2013


Installations- & Environmental Characteristics PSD1-S

Risk of Electric Shock, wait at least 3 minutes with PSD1-S and 10 minutes with PSD1-M before removing cover

  • Use in Pollution degree 2 Environment.
  • Maximum Surrounding Air Temperature 40 °C.
  • The devices must be appropriately protected (e.g. by a switching cabinet). - Open type equipment.
  • Use 60/75°C wires only
    Use Copper Conductors Only
    Do only use the Parker cables available under Accessories or assemble the cables according to the specified regulations.
  • Control voltage supply (24 VDC) only permissible with "class 2" power supply.
  • Grounding Terminals - the screw terminals are suitable for Field Wiring Connection only when the wire is provided with Eyelet Tube Terminal.
  • Overvoltage category III.
  • Short circuit ratings SCCR = 5000 Arms
  • The drive modules are equipped with a current limit. Values for maximum device current and maximum motor current can be set via PSD ServoManager (Chapter resp. Menu Limit values & Motor Characteristics).
  • The drive does not support an internal motor overload protection as specified in UL508C, chapter 20.1.10.
  • The overload protection must be implemented externally in the application, if required.
  • The drive does not support an internal motor over temperature protection as specified in UL508C, chapter 20.1.10.
  • Integral solid state short circuit protection does not provide branch circuit protection. Branch circuit protection must be provided in accordance with the Manufacturer Instructions, National Electrical Code and any additional local codes
  • Suitable for use on a circuit capable of delivering not more than 5000 rms Symmetrical Amperes, 240 Vac maximum. When protected by Listed – Cartridge Fuses, Non-Renewable (JDDZ), Time-Delay Class-CC Fuses, rated 600 Vac, 3 A or 8A (for model No. PSD1SW1200) / 6 A or 12A (for model No. PSD1SW1300). See table below for the manufacturers, model number and electrical ratings.

External Branch Circuit Protection

Device | Spezification
 | Time-Delay "Class-CC" Fuses Listed – Cartridge Fuses, Non-Renewable manufactured by Cooper Bussmann LLC (E4273) (200 kARMS Symmetrical A.I.C.)
 | Model No. | Current [Arms] | Voltage [VAC] | Quantity Phase
PSD1-S_1200 | LP-CC-8 | 8 | 600 | 1 phase
 | LP-CC-3 | 3 | 600 | 3 phases
PSD1-S_1300 | LP-CC-12 | 12 | 600 | 1 phase
 | LP-CC-6 | 6 | 600 | 3 phases
Alternate External Branch Circuit Protection

Device | Spezification
 | Time-Delay "Class-CC" Fuses Listed – Cartridge Fuses, Non-Renewable manufactured by Mersen USA Newburyport-MA LLC (E2137) (200 kARMS Symmetrical A.I.C.)
 | Model No. | Current [Arms] | Voltage [VAC] | Quantity Phase
PSD1-S_1200 | ATDR8 | 8 | 600 | 1 phase
 | ATDR3 | 3 | 600 | 3 phases
PSD1-S_1300 | ATDR12 | 12 | 600 | 1 phase
 | ATDR6 | 6 | 600 | 3 phases
For use in Canada:
  • External Surge Protection devices (required in the end use instalation) - According to the Canadian Standard C22.2-No.274-13.
  • R/C Surge-Protective Device (VZCA2/8) and CSA-Certified transient surge suppression shall be installed on the line side of this equipment and shall be rated minimum 240 V (phase to ground), suitable for “Overvoltage Category III”, and shall provide protection for a rated Impulse withstand Voltage peak of 4 kV.


Tightening torque of the wiring terminals

Connector |  | Torque | mm2 | AWG
X17 | Digital I/Os | Push-In | 0,2 ... 1,5* | 24-16
X51 | DSL® feedback / motor brake | Push-In | 0,2 ... 1,5* | 24-16
X52 | Motor | Push-In | 0,2 ... 2,5** | 26-12
X63 | Mains supply / DC power | Push-In | 0,2 ... 2,5** | 26-12

* | max 0,75mm2 ferrule with plastic sleeve
** | max 1,5mm2 ferrule with plastic sleeve


Auxiliary connection – electrical ratings

DC Bus Input / Output – X63

400 VDC / D.C. / 7 A

Auxiliary Input Supply – X17

Control Supply - Max 24 VDC ?10% / max 0.5 ADC

Signal I/O’s Ports (PELV circuit) – X51

Signal I/O’s / Communication Ports - max 24 VDC / max 100 mA


Data of integrated dynamic brake unit

Internal DBU Ratings
Servo‑Drive Model Nos. | Max Current - Amps |  | Max Duty Cycle - per cent | Internal D.B.U. Resistor Ratings
 | Peak | rms |  | (Ohm)
PSD1SW1200 PSD1SW1300 | 7.84 A | 0.1 A | 1.27 % (@60s) | 51 W (40 W)
External DBU Ratings
Servo‑Drive Model Nos. | Max Current - Amps |  | Max Duty Cycle - per cent | Min Resistance D.B.U. Resistor
 | Peak | rms |  | (Ohm)
PSD1SW1200 | 7.84 A | 0.15 A | 1.91 % (@60s) | 51 W (60 W)
PSD1SW1300 | 7.84 A | 0.45 A | 5.73 % (@60s) | 51 W (180 W)


In- / Output Ratings

Input Ratings
Servo‑Drive Model Nos. | Input Voltage V AC | Frequency Phase | Maximum Input Current A rms
PSD1SW1200 | 3AC230 VAC ±10 % | 50/60 Hz | 1.7
PSD1SW1300 |  |  | 4.2
PSD1SW1200 | 1AC230 VAC ±10 % | 50/60 Hz | 6.8
PSD1SW1300 |  |  | 11.0
Output ratings
Device | Range of Output Voltage VAC | Range of Frequency / Phase | Output Current |  | Max. Continuous Output Power kW
 |  |  | Nominal A rms (Continuous) | Maximum A rms (Duty Cycle)*
PSD1SW1200 | 0‑230 VAC | 0‑400 Hz / Three‑Phase | 2 | 6 | 0.64
PSD1SW1300 |  |  | 5 | 15 | 1.6

Note:

* "Duty Cycle": 20% @10 s (ON=2.0 s - OFF=8.0 s)


Conditions of utilization for the cUL certification of PSD1-M

In this chapter you can read about:

UL certification

Installations- & Environmental Characteristics PSD1-M

PSD1-M Installations- & Environmental Characteristics

Conditions of utilization for CSA certification


UL certification

Category | Specifications
Certified | E-File_No.: E142140 The UL certification is only valid if the type plate of the device shows the "UL" -sign.

PSD1-M:

UL508C, 3rd Edition, power supply load revision November 9th, 2010.

C22.2 No.274-13, 1st Edition, issued March, 2013


Installations- & Environmental Characteristics PSD1-M

  • The devices are only to be installed in a pollution degree 2 environment (maximum).
  • Maximum Surrounding Air Temperature 40 °C.
  • The devices must be appropriately protected (e.g. by a switching cabinet). - Open type equipment.
  • Temperature rating of field installed conductors shall be at least 60°C. Do only use copper lines.
    Do only use the Parker cables available under Accessories or assemble the cables according to the specified regulations.
  • Control voltage supply (24 VDC) only permissible with "class 2" power supply.
  • The devices are internally protected against overvoltage in compliance with UL508C.
  • The drive modules are equipped with a current limit. Values for maximum device current and maximum motor current can be set via PSD ServoManager (Chapter resp. Menu Limit values & Motor Characteristics).
  • The drive does not support an internal motor overload protection as specified in UL508C, chapter 20.1.10.
  • The overload protection must be implemented externally in the application, if required.
  • The drive does not support an internal motor over temperature protection as specified in UL508C, chapter 20.1.10
  • Integral solid state short circuit protection does not provide branch circuit protection. Branch circuit protection must be provided in accordance with the Manufacturer Instructions, National Electrical Code and any additional local codes
  • Protective earth of the motor must be connected to protective earth of the device.
    Please observe that ground on PSD1 - motor connector is, according to NEC NFPA 70, a functional earth and not a protective earth.


PSD1-M Installations- & Environmental Characteristics

  • Please observe that the operation of the PSD1-M axis modules is only permitted via the Parker Power Module PSD1-M_P. Furthermore Power Modules PSD1-M_P must only be used with PSD1-M axis modules.
    The UL certification does not cover individual devices but only the axis system of the PSD1-M_P and PSD1-M_P mains module.
  • Dynamic braking unit
Data of the integrated dynamic brake module PSD1-M_P
Category | Specifications
Mains module | Maximum current |  | Max. Duty Cycle | Minimum resistance value
 | Peak | Duration
PSD1-M_P010 | 28.8 A | 4.27 A (500 W) | 2.2 % (@60 s) | 27 W
 |  | 7.5 A (1500 W) | 6.7 % (@60 s)
PSD1-M_P020 | 78.0 A | 7.06 A (500 W) | 0.82 % (@60 s) | 10 W
 |  | 22.3 A (5000 W) | 8.2 % (@60 s)
  • Suitable for use on a circuit capable of delivering not more than 5000 rms Symmetrical Amperes, 480 V ac +10 % maximum, when protected by Listed
    • DIVQ Circuit Breakers manufactured by ABB, Stotz-Kontakt GmbH, Mod. No. S203UP-K / 480 Vac, 25 A for PSD1-M_P010
      or
    • R/C (JFHR2/8) Semiconductor Fuse type manufactured by Cooper Bussmann LLC, Mod. No. 170M1366 oder 170M1566D, 690 VAC, 80 A, 200 kA RMS Sym for PSD1-M_P020..
  • Power supply units PSD1-M_P need a fusing on the main site (branch circuit protection) as stated below.
PSD1-M_P010

Maximum fuse rating per device

Measure for line and device protection:

UL listing (DIVQ) automatic circuit breaker

Manufacturer: ABB, Stotz-Kontakt GmbH (E212323)

Model No.: S203UP-K, 1 automatic circuit breaker

480 VAC, 3-phase, 25 A, Operating temperature 55 °C
PSD1-M_P020

Maximum fuse rating per device

2 fuses in line are required

Measure for line protection:

MCB (K characteristic) with a rating of 50A / 4xxVAC (depending on the input voltage)Recommendation:
Recommendation: (ABB) S203U-K50 (440VAC)

Measure for device protection:

Fuses 80A / 700VAC per supply leg in accordance with UL category JFHR2:
Essential: Bussmann 170M1366 or 170M1566D


Tightening torque of the wiring terminals

Risk of Electric Shock, wait at least 10 minutes before removing cover.

The field wiring terminals should be tightened with the torques mentioned below.

Only the supplied mating connectors must be used.

PSD1-M

2 A ... 15 A

X45 Motor

UL

up to AWG10

CE

up up 4 mm2

Tightening torque

0.8 Nm
7 Lb.in

X46 motor brake

UL

up up AWG14

CE

up up 1.5 mm2

Tightening torque

0.22 ... 0.25 Nm
1.95 ... 2.21 Lb.in

PSD1M_1800

2 A ... 30 A

X43 Motor

UL

up up AWG20-8

CE

up up 6 mm2

Tightening torque

1.1 ... 1.7 Nm
11 ... 15 Lb.in

X44 motor brake

UL

up up AWG30-14

CE

up up 1.5 mm2*

Tightening torque

0.22 ... 0.25 Nm
1.95 ... 2.21 Lb.in

Mains module

X40: Ballast resistor

UL

up up AWG10

CE

up up 6 mm2

Tightening torque

0.46 ... 0.57 Nm (M3)
4 ... 5 Lb.in

X41: Mains connector

PSD1-M_P010

UL

up up AWG10

CE

up up 6 mm2

Tightening torque

1,1 ... 1.7 Nm
11 ... 15 Lb.in

X41: Mains connector

PSD1-M_P020

UL

up up AWG6

CE

up up 16 mm2

Tightening torque

1.7 Nm
15 Lb.in

X9: 24 VDC control voltage

UL

up up AWG10

CE

up up 6 mm2

Tightening torque

1.1 ... 1.7 Nm
11 ... 15 Lb.in

DC Bus

UL

-

CE

-

Tightening torque

0.8 Nm
7 Lb.in

*

max 0.5mm2 ferrule with plastic sleeve


Conditions of utilization for CSA certification

External Overvoltage Protection

External overvoltage protection in accordance with Canadian Standards C22.2-No.274-13 with over-voltage protection device (VZCA2) CSA-certified.

Note the following table:

Mains module | Manufacturer | Model No (Quantity 1) | Maximum Continuous Operating Voltage (Vac) | Voltage Protection Rating (VPR)(Vpk) | Category / Nominal earth leakage current
PSD1-M_P010 PSD1-M_P020 | ABB Frankreich (E322885) | OVR T2 3N 40-440 P(TS)U | L-GND 420 Veff Max L-L 840 Veff Max | L-GND 1500 V Max L-L 3000 V Max | 1 / 10 kA
 | Cooper Bussmann LLC (E340782) | BSPM 4480 WY NGR | L-GND 660 Veff Max L-L 770 Veff Max | L-GND 2500 V Max L-L 2500 V Max | 1 / 20 kA
 | DEHN + SOEHNE GmbH + Co. KG. (E319777) | 904 346

Ground rail not sufficient

For CSA approval, earth rail must be replaced by a direct earth connection.

Risk of Electric Shock, wait at least 10 minutes before removing cover.

Removing the earth rail (4) (Right):

1 | 24 VDC
2 | GND 24 VDC
3 | DC power supply bus -
4 | Protective earth
5 | DC power supply bus +

Connecting protective earth

Connect protective earth via a copper wire of minimum 10 mm2 by means of the provided screws at the bottom of the PSD1M (axis controller) and of the mains module PSD1-M_P:


Current on the mains PE (leakage current)

This product can cause a direct current in the protective lead. If a residual current device (RCD) is used for protection in the event of direct or indirect contact, only a type B (all current sensitive) RCD is permitted on the current supply side of this product . Otherwise, a different protective measure must be taken, such as separation from the environment by doubled or enforced insulation or separation from the mains power supply by means of a transformer. Respect the supplier's instructions.

Mains filters do have high leakage currents due to their internal capacity. An internal mains filter is usually integrated into the servo controllers. Additional discharge currents are caused by the capacities of the motor cable and the motor winding. Due to the high clock frequency of the power output stage, the leakage currents do have high-frequency components. Please check if the FI protection switch is suitable for the individual application.

If an external mains filter is used, an additional leakage current will be produced.

The figure of the leakage current depends on the following factors:

  • Length and properties of the motor cable
  • Switching frequency
  • Operation with or without external mains filter
  • Motor cable with or without shield network
  • Motor housing grounding (how and where)

Remark:

  • The leakage current is important with respect to the handling and usage safety of the device.
  • A pulsing leakage current occurs if the supply voltage is switched on.
Please note:

The device must be operated with effective grounding connection, which must comply with the local regulations for high leakage currents (>3.5 mA).

Due to the high leakage currents it is not advisable to operate the servo drive with an earth leakage circuit breaker.


Supply networks

This product is designed for fixed connection to TN networks (TN-C, TN-C-S or TN-S). Please note that the line-earth voltage may not exceed 300VAC.

  • When grounding the neutral conductor, mains voltages of up to 480VAC are permitted.

TN-Mittelpunkt geerdet

  • When grounding an external conductor (delta mains, two-phase mains), mains voltages (external conductor voltages) of up to 240VAC are permitted.

TN-Außenleiter geerdet

Devices which are to be connected to an IT network must be provided with a separating transformer. Then the devices are operated locally as in a TN network. The secondary sided center of the separating transformer must be grounded and connected to the PE connector of the device.


Before commissioning the drive, please observe the following:

  • Read the safety instructions.
  • Make sure that all local electrical regulations are adhered to.
  • Inspect the device for any damages.
  • Inspect the device within the drive and system for loose ends, blends, grinding- or drilling chips, etc.
  • Check all external power circuits of the system: Power supply, control, motor and ground connections.
  • Make sure no damages or injuries may occur by a rotating motor. Uncouple the load from the motor shaft.
  • Check the condition of the motor thermistor- and brake resistance connections. Make sure that all external set speeds are zero.
  • Make sure nobody works with another part of the system which may affect switch-on.
  • Make sure that switch-on does not negatively influence other devices.
  • Verify if the motor connections are correctly wired.
  • Ensure that the STO function is not activated.


Parker Servo Drive

Vorige Seite

Nächste Seite

PSD: PSD -Parker Servo Drive - Overview


Installation PSD1-S (Single-axis drive)

In this chapter you can read about:

Before commissioning the drive, please observe the following:

Mounting and dimensions

Plug and device overview PSD1-S

P14: Status LED (PSD1-S)

X17: Control voltage 24V, STO, digital inputs/outputs (PSD1-S)

X51, X18 Motor Feedback

X52: Motor connection (PSD1-S)

X60...X62 Communication interfaces

Signal interfaces IO Optionboard

X63: AC Mains Supply, DC voltage supply & Connection of braking resistor (PSD1-S)

Technical data


Before commissioning the drive, please observe the following:

CAUTION: Risk of electric shock
Caution - Risk of electric shock!

Before wiring or loosening electrical connections please observe the following:

  • Risk of electric shock, disconnect power before removing cover resp. disconnect the devices from the mains supply.
  • Caution! Dangerous electrical voltage even after turning off the intermediate capacitors:
    Up to 3 minutes with PSD1-S and 10 minutes with PSD1-M after switching off mains supply, dangerous voltages may still be present.
    Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- of PSD1-S: X63/3 & X63/5 and with PSD1-M: Bus HV DC - 3 & 5. rail.

Only qualified electrician may commission the drive.

Accident prevention measures must be observed.

Please make sure that no small parts (screws, cable remnants, ..) enter the devices.

Feedback system can be destroyed if configured incorrectly!

If you connect a PSD that has already been configured for a specific feedback system to another feedback system, it can be destroyed by too high a voltage.

Procedure when changing the feedback system.


Mounting and dimensions

Ventilation:

  • During operation, the device radiates heat (heat dissipation). Please provide for a sufficient mounting distance below and above the device (at least 100 mm) in order to ensure free circulation of the cooling air.
  • Please do also respect the recommended distances of other devices.
  • Make sure that the mounting plate is not exhibited to other temperature influences than that of the devices mounted on this very plate.
  • The devices must be mounted vertically on a level surface. Make sure that all devices are sufficiently fixed.


Mounting and dimensions PSD1-S

Mounting:

2 socket head screws M6

Lateral distance of fixing of mounting holes: 50.5 mm

Required mounting distance for heat regulation at the top and below: At least 100mm

Please check regularly the firmness of the screw connection!


Plug and device overview PSD1-S

In this chapter you can read about:

Front view (PSD1-S)

View from below (PSD1-S)

View from above (PSD1-S)


Front view (PSD1-S)

CAUTION: Risk of electric shock
Caution - Risk of electric shock!

Before wiring or loosening electrical connections please observe the following:

  • Risk of electric shock, disconnect power before removing cover resp. disconnect the devices from the mains supply.
  • Caution! Dangerous electrical voltage even after turning off the intermediate capacitors:
    Up to 3 minutes with PSD1-S and 10 minutes with PSD1-M after switching off mains supply, dangerous voltages may still be present.
    Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- of PSD1-S: X63/3 & X63/5 and with PSD1-M: Bus HV DC - 3 & 5. rail.

View from above
P10 (P10:Meaning of the Bus LEDs, P10a: Status display of the device, P10b: Status display of the network) | Status LEDs for the fieldbus
X30 | Digital Inputs / Outputs IO Optionboard2
X31 | Analogue Inputs and Encoderinput IO Optionboard2
C11 | Slot for SD card (Clone device data on SD card, Copy SD card to target device) (SD card not included in delivery)
S12 | Device address higher value half-byte (accept with power ON)
S13 | Device address low value half-byte (accept with power ON)
P14 | Status LED device
X17 | Digital inputs/outputs
X18 * | Feedback device Male Connector (Resolver, Encoder/Hall)
S33 | For safety option
S34 | For safety option
View from below
*

Before connecting a feedback cable, check that the correct feedback system is configured in the device.

Otherwise, destruction of the feedback system is threatened by overvoltage!


View from below (PSD1-S)

View from above

Central ground connection

Connect ground via ring cable lug with a 10 mm2 copper cable to central ground

X51

To the motor

  • HIPERFACE DSL® Motor feedback
  • Motor holding brake

and 24VDC feeding for the brake

Motor ground connection

Connecting screw for motor earth/ the shielding of the motor cable (see image bellow)

X52

Connection of motor

Front view

Shows pin 1 of the connector
Wiring
Explanation
1 | DSL connection
2 | Connection of motor brake
3 | Connect ground via ring cable lug with a 10 mm2 copper cable to central ground
4 | Mounting the shield clamp 1) with flat connection to the motor cable shielding
5 | Motor Connection
 | 1) The shield clamp is supplied with the Parker motor cables. An accessory set with several clamps for various possible cable diameters is optionally available for in-house manufactured motor cables.

Alternatively, the earth connection of the motor shielding is also possible via the rear wall of the control cabinet or a PE bus bar:


View from above (PSD1-S)

Front view

X60

PC interface to configure and program the servo axes

X61

Fieldbus interface output

X62

Fieldbus interface input

X63

Connections

  • AC Mains Supply
  • DC power supply
  • Connection of braking resistor
    or
    Bridge to activate the internal braking resistor

View from below

Shows pin 1 of the connector


P14: Status LED (PSD1-S)

Status

No.

Status of axis

Left LED a
(green) (ready)

Right LED b
(red) (error)

0

No voltage

off

off

1

Booting of axis, firmware is missing

alternate quick flashing
(LEDa green, LEDb rot)

2

Axis not ready:

  • Booting of axis
  • No feedback detected.
  • IEC61131-3 program not compatible with firmware.
  • no IEC61131-3 program
  • Hall signals invalid.

off

flashes quickly (5 HZ)

3

Axis de-energized

flashes slowly

off

4

Axis energized; commutation calibration running

flashes quickly

off

5

Axis energized

on

off

6

Axis in error state / error present / axis energized (error reaction 1)

on

flashes quickly (5 HZ)

7

Axis in error state / error present / axis de-energized (error reaction 2)

off

on

8

Axis faulty: Please contact us

on

on

9

STO active

off

flashes slowly (1 HZ)

10

reserved

flashes quickly

flashes quickly (5 HZ)

11

SD Card detected or
restoring from SD card successfully terminated

alternate quick flashing
(LEDa green, LEDb green)

12

SD card not detected or restoring from SD card interrupted

alternate quick flashing
(LEDa red, LEDb red)

13

Axis de-energized

off

Single flash

14

Axis energized

on

Single flash

15

Axis de-energized
HEDA3 slave not ready

off

Double flash

16

Axis energized
HEDA3 Slave not ready

on

Double flash

17

Axis de-energized
HEDA3 Master not ready

off

Triple flash

18

Axis energized
HEDA3 Master not ready

on

Triple flash

19

Axis de-energized

off

Jitter (10 HZ)

20

Axis energized

on

Jitter (10 HZ)

Error response 1: Ramping with slow ramp; then deactivate control loops.

Error response 2: Ramping with "Stop" ramp, then deactivate control loops.

For the meaning of individuals errors please go to Error list.

Single flash | 1fach blinken
Double flash | 1fach blinken
Triple flash | 1fach blinken

Caution - Risk of electric shock!

High voltage supply may be present even with missing voltage supply (both LEDs off)!


X17: Control voltage 24V, STO, digital inputs/outputs (PSD1-S)

Pin X17 | Input/output |
1 | Power Input | +24 VDC devices - control voltage
2 | Power Input | GND24V
3 | Power Input | +24 VDC for digital outputs
4 | I0 | Input 0
5 | I1 | Input 1
6 | I2 | Input 2
7 | I3 | Input 3
8 | GND24V |
9 | O0 | Power Output 0
10 | GND24V |
11 | O1 | Power Output 1
12 | STOA/ | STO Channel A input
13 | reserved |
14 | STOGND | STO Common
15 | reserved |
16 | STOB/ | STO Channel B input

Loading of the outputs: Maximum 200 mA

In case of overload / over-temperature the output is deactivated and reactivated automatically after cooling.

All inputs and outputs do have 24 V level.

Input level:

"0" (low) = Rated Input Voltage £ 12.5 V

"1" (high= Rated Input Voltage ³ 13.5 V

The digital outputs are free for writing via object 0x2079.0x01 or 0x60FE.0x01 via fieldbus.

The status of digital inputs can be read via object 0x2070.0x00 or 0x60FD.0x00 .


Control Voltage 24 VDC PSD1-S

Category | Specifications
Voltage operating range | 21.6 - 27.0 VDC (24 VDC -10% +12.5%)
Ripple | 0.5 Vpp
Requirement according to safe extra low voltage (PELV) | yes (class 2 mains module)
Electric current drain | 0.5 A + Output current of digital output currents (fed via connectors X17/2, 3) + Output current of motor brakes (fed via connectors X51/1 & 2)) + Current requirements of optional boards


Wiring of the digital inputs and outputs

Wiring of digital inputs

Wiring of digital outputs


X51, X18 Motor Feedback

In this chapter you can read about:

X51: Motor holding brake and HIPERFACE DSL® Connection

X18: Connector assignment with configured resolver feedback

X18: Assignment with configured incremental encoder or analog Hall

Feedback system can be destroyed if configured incorrectly!

If you connect a PSD that has already been configured for a specific feedback system to another feedback system, it can be destroyed by too high a voltage.

Procedure when changing the feedback system.


X51: Motor holding brake and HIPERFACE DSL® Connection

Pin | Designation | Description
1 | DC 24 V | Input power supply brake 24 VDC
2 | GND24V | Input power supply brake GND24V
3 | Br + | Motor holding brake output + (max 1.0 A)
4 | Br - | Motor holding brake output - (connected with GND24V)
5 | DSL+ | Feedback
6 | DSL- | Feedback

Electrical connection on device (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S))

Operation with Parker HIPERFACE DSL® cable recommended!
Observe the following if no Parker PSD DSL motor cable is being used:

The internal shielding of the twisted Hiperface DSL® signal line must be connected (braided or soldered) to the outer motor cable shielding (and thus to PE) on the motor side (View from below (PSD1-M), View from below (PSD1-S)). From this connection point, the inner shield of the Hiperface DSL® cables (with the wire pair still twisted in it) must be routed up to the PSD servo amplifier Hiperface DSL® connection terminal.

The same applies to the motor side when connecting the Hiperface DSL® lines in a motor terminal box. Here, too, the Hiperface DSL® cable screening must be connected with the outer cable screening and the Hiperface DSL® cable pair from there on must be further routed twisted and screened to its connection terminal.

Please observe the following if you want to use an additional plug to interrupt the DSL lines:

  • No other lines may ever be routed between DSL+ and DSL-.
  • The DSL lines must be twisted and separately shielded.
  • A full surface shielding must be ensured across the plug connection (recommendation: Harting Han-Modular plug with "Han Quintax" or "Han MegaBit" module).
  • The shield of the DSL lines must be connected to PE / ground at the drive unit with low impedance. In the simplest way, this can be done by connecting the DSL shield to the outer shield of the cable at the cable end (on the controller side).


X18: Connector assignment with configured resolver feedback

Assignment with multi feedback option with configured resolver

Pin | Feedback High Density /Sub D
1 | reserved
2 | reserved
3 | reserved
4 | REF-Resolver+ (8 kHz / max. 9.5 Vpp)
5 | +3.3 V (for temperature sensor)
6 | reserved
7 | SIN- (max. 4.7 Vpp differential)
8 | SIN+ (max. 4.7 Vpp differential)
9 | reserved
10 | Tmot*
11 | COS- (max. 4.7 Vpp differential)
12 | COS+ (max. 4.7 Vpp differential)
13 | reserved
14 | reserved
15 | REF-Resolver-

* Pin10 Tmot may not be simultaneously connected to the axis of the associated temperature sensor entry of X48 (PSD1-M).

Category

Specifications

Resolution of the motor position
  • Position resolution: 16.6 Bits (= 0.005°)
  • Absolute accuracy: ±0.167°

Resolver supported
  • LTN: RE-21-1-A05, RE-15-1-B04
  • Tamagawa: TS2610N171E64, TS2620N21E11, TS2640N321E64, TS2660N31E64
  • Tyco (AMP): V23401-T2009-B202

Resolver data supported
  • Transformation ratio: 0.25... 1 (typical 0.5)
  • Excitation frequency 8 Hz
  • Amplitude of the excitation signal: max. 9.5 Vpp.
    (The resolver must be approved for at least this value).

Accuracy

The precision of the position signal is above all determined by the exactitude of the feedback system used.


X18: Assignment with configured incremental encoder or analog Hall

Incremental encoder/ analog & digital Hall sensor with analog sin/cos signals with 1Vpp
Pin | Feedback option / high density /D sub
 | Encoder 1 Vpp | Encoder A/B | Analog Hall sensor
1 | Sense -*
2 | Sense +*
3 | Hall 1 (digital) |  | reserved
4 | Vcc (+5 V) max. 350 mA load
5 | +3.3V (for temperature sensors)
6 | Hall 2 (digital) |  | reserved
7 | Sine - | A- | Sine -
8 | Sine + | A+ | Sine +
9 | Hall 3 (digital) |  | reserved
10 | Tmot**
11 | Cosine - | B- | Cosine -
12 | Cosine + | B+ | Cosine +
13 | N+, Z+, Ref + (encoder refer. mark or index pulse +) |  | reserved
14 | N+, Z+, Ref + (encoder reference mark or index pulse -) |  | reserved
15 | GND (Vcc)

*+5V (Pin 4) is measured and controlled directly at the end of the line via Sense+ and Sense-.

Maximum cable length: 100 m at 0.5 mm2.

** Pin10 Tmot may not be simultaneously connected to the axis of the associated temperature sensor entry of X48 (PSD1-M).

Category

Specification

Incremental encoder *
(Sine / Cosine or A/B square wave - signal)
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Supported signals:
    • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
      (an existing reference mark (Ref signal) is evaluated (with appropriately set machine zero mode) during machine zero run)

      Position resolution: 14 bit per sine/cosine period (at 1Vpp)

      -> with rotary encoder, unit incr./rev:
      encoder_line_count[periods/rev]*16384[incr./period]

      -> with linear encoder, unit e.g. incr./mm:
      16384[incr./period]*1000[um/mm]/Encoder_Periodlength[um]

      or
    • A/B - pulses: Physically RS422 (differential), A/B 90° phase shifted, max. 5 MHz
      (an existing reference mark (Z-track) is evaluated (with appropriate set machine zero mode) at machine zero run).

with the following commutation options:

  • Auto commutation

    or
  • U, V, W or R, S, T commutation signals (NPN open collector) e.g., digital hall sensors**, incremental encoders with commutation track (e.g., Hengstler F series with electrical ordering variant 6)

Analog Hall Sensor *
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
  • Position resolution: 14 bits (at 1Vpp) per sine/cosine period (= 14 bits per motor magnet period).

    -> for rotary motor, unit incr./rev:
    number_motor_pole_pairs [1/rev]*16384 incr.

    -> with linear motor: 16384[incr./pitch]
    with unit e.g. Incr./mm: 16384[incr.] / motor_pitch_length[mm].

* in the 1st development stage only for PSD1-S and PSD1MW1...: Multi axis devices with one power stage.

** the digital hall sensors are to be supplied via the encoder supply pin Vcc (5V nominal, higher voltage possible in case of connected encoder supply sense lines).


X52: Motor connection (PSD1-S)

Pin | Description | Motor cable lead designation*
1 | U | U / L1 | 1 | U1
2 | V | V / L2 | 2 | U2
3 | W | W / L3 | 3 | U3
4 | FE & PE | YE / GN

* Depending on cable type.

FE: Functional ground

PE: Protective earth

Shielding connection of the motor cable

The external shield of the motor cable must be properly (=over a large area!) connected to the PE both on the drive side (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)) (on the device housing or on the rear wall of the control cabinet) as well as on the motor side (motor housing e.g. via the motor cable plug connector).

The outer and any existing additional inner shielding for the DSL or motor holding brake must not be interrupted.

Also observe the tips on connecting a Hiperface DSL encoder (via hybrid cable).

Explanation
1 | DSL connection
2 | Connection of motor brake
3 | Connect ground via ring cable lug with a 10 mm2 copper cable to central ground
4 | Mounting the shield clamp 1) with flat connection to the motor cable shielding
5 | Motor Connection
 | 1) The shield clamp is supplied with the Parker motor cables. An accessory set with several clamps for various possible cable diameters is optionally available for in-house manufactured motor cables

Please observe the notes in chapter “Operating conditions for CE-conform operation“.


Motor connection with self-made motor cable

Please consider the specialty of the DSL motor connection with:

  • EX motors,
  • EY motors,
  • NK motors,
  • NV motors and
  • NX motors!

With these motors with DSL feedback, the outputs V & W are swapped in the PSD via the motor configuration (this has no effect on the wiring with Parker motor cables)!

You have connect the self-made cable as shown in the table below:

For EX motors, EY motors, NK motors, NV motors and NX motors:

Pin | Designation | Motor cable lead designation* |  |  | Motor side: EX, EY, NK, NV, NX (according to motor datasheet)
1 | U | U / L1 | 1 | U1 | U
2 | V | V / L2 | 2 | U2 | W
3 | W | W / L3 | 3 | U3 | V
4 | FE & PE | YE / GN |  |  | Ground

* Depending on cable type.

FE: Functional ground

PE: Protective earth


X60...X62 Communication interfaces

In this chapter you can read about:

X60: PC-/Diagnostic interface

X61, X62 Connection of field buses (Ethernet)

Reference to the meaning of LEDs X60, X61, X62


X60: PC-/Diagnostic interface

Wiring with Ethernet Crossover cable Cat5e; for this, we offer our CBD000C0-T00-T0 interface cable.

Standard Ethernet Address of the PSD:192.168.10.x

The final position (x) is set via the address adder S12 (higher value byte) & S13 (low value byte) and accepted by Power On.

Address_setting

Setting:

S12: Device address higher value half-byte (accept with power ON)
S13: Device address low value half-byte (accept with power ON)
The address 1 ... 240 (0x01 ... 0xF0) is possible; the range 241 ... 255 (0xF1 ... 0xFF) is reserved for special functions!

Example: S12=2, S13=1
Address= 0x21: S12*16 + S13 = 2*16 + 1 = 33

After switching on PSD the IP address value

  • "192.168.10.S12_S13" (X60 PC interface) e.g. "192.168.10.33"

resp.

  • "192.168.100.S12_S13" (X61/X62 field bus interface) e.g. "192.168.100.33"

is set.

In addition, the set address becomes part of the host name. The address set via S12_S13 is appended to the prefix "PSD1-" as a string with 3 digits:

  • Hostname= "PSD1-" followed by "S12_S13_3digit_String"

In the example:

  • Hostname=PSD1-033

If the IP address has been modified and is no longer known, the address can be reset to the default setting with S12_S13 = 249 (0xF9):

  • IP address = 192.168.10.2 (X60 PC) resp. 192.168.100.2 (X61/X62 field bus)
  • SubNetmask = 255.255.0.0
  • Gateway_IP = 192.168.10.254 (X60 PC) resp. 192.168.100.254 (X61/X62 field bus)
  • Hostname = PSD1-002

After that or in general the complete IP - address (not only the last part) can be redefined as follows:

  • At X60 via the objects 0x2500.0x04 & 0x2500.0x01 (Bit 12)
  • At X61/X62 via the objects 0x2605.0x04 & 0x2605.0x01 (Bit 12)

Addresses 0 and 241 ... 255 are not possible.

Connection is configured in PSD ServoManager.


X61, X62 Connection of field buses (Ethernet)

RJ45-Socket: Assignment

Pin | Wire pair No. | RJ45 (X61) | RJ45 (X62)
 |  | out | in
1 | 2 | Tx + | Tx +
2 | 2 | Tx - | Tx -
3 | 3 | Rx + | Rx +
4 | 1 | - | reserved
5 | 1 | - | reserved
6 | 3 | Rx - | Rx -
7 | 4 | - | reserved
8 | 4 | - | reserved

Wiring with Ethernet Crossover cable Cat5e (from X61 to X62 of the next device without termination); for this, we offer our CBD000C0-T00-T0 interface cable.

Please use shielded cables:

  • SF/UTP: Cable fully shielded or
  • S/STP, S/FTP: additional shielding around the 4 pairs of wires.

Place the shield flat on the plug!

Reference to the meaning of LEDs X60, X61, X62

Meaning of LEDs


Signal interfaces IO Optionboard

In this chapter you can read about:

X30, X37 Digital inputs/outputs

X31, X38 Analogue inputs / Encoder


X30, X37 Digital inputs/outputs

Pin X30 / X37 |  |
1 | +24VDC external | 24V for digital outputs
2 | GND | GND24V
3 | Digital I/O0 | combined inputs/outputs. When the outputs is set, the High signal is read also at the input. The outputs are short circuit proof and can be load with 70mA.
4 | Digital I/O1
5 | Digital I/O2
6 | Digital I/O3
7 | Digital I/O4
8 | Digital I/O5
9 | Digital I/O6
10 | Digital I/O7

Please note that in order to operate the digital inputs/outputs, the 24V supply voltage must be fed in externally.

Technical data X30, X37


X31, X38 Analogue inputs / Encoder

Reference 1 (X38) Reference 2 (X31) |  |
 |  | Description
Pin | Signal | A/B Encoder | Step/Dir Encoder
1 | Vcc +24V | Output Power Supply (for Encoder) max. 70mA
2 | Vin 1- | Vin1-: diff. analog Input +/-10V
3 | Iin0 | Iin0: analog Input: 0..20mA
4 | Iin 1 | Iin1: analog Input: 0..20mA
5 | Vcc +5V | Output Power Supply (for Encoder) max. 150mA
6 | RS422 (A-) | A- Encoder (In/Out) | Step- Encoder (In/Out)
7 | RS422 (A+) | A+ Encoder (In/Out) | Step+ Encoder (In/Out)
8 | RS422 (B+) | B+ Encoder (In/Out) | Dir+ Encoder (In/Out)
9 | Vin 0+ | Vin0+: diff. analog Input +/-10V
10 | Vin 1+ | Vin1+: diff. analog Input +/-10V
11 | Vin 0- | Vin0-: diff. analog Input +/-10V
12 | RS422 (B-) | B- Encoder (In/Out) | Dir- Encoder (In/Out)
13 | RS422 (N-) | N- Encoder (In/Out)
14 | RS422 (N+) | N+ Encoder (In/Out)
15 | GND | GND

The encoder signals are used as for encoder input and for the encoder simulation.

Technical data X31, X38


X63: AC Mains Supply, DC voltage supply & Connection of braking resistor (PSD1-S)

Pin | Description | Description
1 | Rin | Internal braking resistor 1)
2 | -R | Output for braking resistor connection -
3 | +R | Output for braking resistor connection +
4 | DC+ | Direct current output + 2)
5 | DC- | Direct current output - 2)
6 | L3 | Phase 3 (mains supply) | reserved
7 | L2 | Phase 2 (Mains Supply) | N (Single Phase)
8 | L1 | Phase 1 (Mains Supply) | L (Single Phase)
9 | PE | Earth conductor

1) The internal braking resistor is connected via bridge X63/1 and X63/2:

Device protection

By cyclically switching on and off the power voltage, the input current limitation can be overloaded, which may cause damage to the device.

Wait at least one minute between two switching on processes!

Please note:

If neither a braking resistor nor a bridge are connected, the intermediate circuit voltage is 0.

2) Connecting the supply voltage of 2 PSDs

In order to improve the conditions during brake operation, the DC power voltage of 2 servo axes may be connected.

The capacity as well as the storable energy are increased; furthermore the braking energy of one servo axis may be utilized by a second servo axis, depending on the application.

Please connect as follows:

  • PSD 1 X63/4 with PSD 2 X63/4
  • PSD 1 X63/5 with PSD 2 X63/5

Only devices with the same power supply may be connected to one another.

  • 3-phase supplied PSD only with 3-phase supplied PSD in the same network
  • 1-phase supplied PSD only with 1-phase supplied PSD in the same phase


Technical data

In this chapter you can read about:

Network connection PSD1-S

Braking operation PSD1-S

Output data PSD1-S 1/3*230 VAC


Network connection PSD1-S

Category | Specification
PSD1-S | PSD1-S_1200 | PSD1-S_1300
Supply voltage | AC single phase (1AC) or AC three phase (3AC) Technically permissible voltage range: 30 ... 253 VAC / 50-60 Hz Voltages previously supported in the servomanager: 1* or 3* 230 VAC ±10% 1* or 3* 208 VAC ±10% 1* or 3* 110/115 VAC ±10% (Operating on DC direct voltage may be possible after checking the technical details with Parker support)
Input current | 1AC230V: 6.8 Arms 3AC230V: 1.7 Arms | 1AC230V: 11 Arms 3AC230V: 4.2 Arms
Maximum fuse rating per device* | Single phase units: 8 A Device Protection: Fuse 8A gS (gRL), Time-delay Line Protection: S202U-K8 (ABB) / 5SJ4208-8HG42 (SIEMENS) | Single phase units: 12 A Device Protection: Fuse 12A gS (gRL), Time-delay Line Protection: S202U-K16 (ABB) / 5SJ4216-8HG42 (SIEMENS)
 | Three phase units: 3 A Device Protection: Fuse 3A gS (gRL), Time-delay Line Protection: S202U-K4 (ABB) / 5SJ4304-8HG42 (SIEMENS) | Three phase units: 6 A Device Protection: Fuse 6A gS (gRL), Time-delay Line Protection: S202U-K10 (ABB) / 5SJ4308-8HG42 (SIEMENS)
Earth leakage current | Current on the mains PE (>3,5 mA)
Supply networks | Possible supply networks: TN

*

Circuit breakers for operating in accordance with CE.
Circuit breakers for UL and CSA in the UL chapter (Conditions of utilization for the cUL certification of PSD1-M, Conditions of utilization for the cUL certification of PSD1-S).

Please observe the notes in chapter “Operating conditions for CE-conform operation“.


Braking operation PSD1-S

Category | Specification
Controller type | PSD1-S_1200 (2 A) | PSD1-S_1300 (5 A)
Capacitance / storable energy | 760 mF / 15 Ws | 1140 mF / 23 Ws
Minimum ballast resistance | 51 W | 51 W
Maximum current | 7.84 A | 7.84 A

Data of the integrated braking resistor PSD1-S

Category | Specification
Device | Maximum current |  | Max. duty cycle | Resistance value, Nominal power
 | Peak | Duration
PSD1-SW1200 PSD1-SW1300 | 7.84 A | 0.1 A | 1.27% @ 60 s | 51 W, 40 W
External load resistors from Parker.


Output data PSD1-S 1/3*230 VAC

Category |  | Specifications
Device type |  | PSD1-S_1200 (2 A) | PSD1-S_1300 (5 A)
Output voltage |  | 3 x 0 ... 230 V ±10 %
Output current*: |  |  |
INominal [Arms] | 4 kHz | 2 | 5
Ipeak (2 s) [Arms] | 4 kHz | 6 | 15
INominal [Arms] | 8kHz | 2 | 5
Ipeak (2 s) [Arms] | 8kHz | 6 | 15
INominal [Arms] | 16 kHz | 1.332 | 3.33
Ipeak (2 s) [Arms] | 16 kHz | 3.996 | 9.99
Power at continuous operation |  | 0.64kW (3-phases mains supply) 0.64 kW (1-phase mains supply) | 1.6 kW (3-phases mains supply) 1.6 kW (1-phase mains supply)
Switching frequency of the motor current |  | 8 kHz | 8 kHz
Heat dissipation for In |  | 13 W | 35 W

* Output current bei verschiedenen switching frequency. The default settings of the currents und switching frequencies are grayed out & in bold..


Installation PSD1-M (multi-axis system)

The PSD1 multi-axis system consist of a mains module (PSD1-M_P) and the axis modules (PSD1-M_x).

The axis module drives 1 to 3 motors, depending on the type (x=1, 2 or 3).

Please observe that the operation of the axis modules is only permitted via the Parker mains Module PSD1-M_P.

In this chapter you can read about:

Before commissioning the drive, please observe the following:

Mounting and dimensions

Plug and device overview PSD1-M

P14 ... P16: Status LEDs of the individual axes (PSD1-M)

X17, X21 STO, digital inputs/outputs PSD1-M

X43, X45 motor connection

X44, X46 Connecting the motor brake PSD1-M

X48, X18...X20 Motor Feedback

X60...X62 Communication interfaces

Signal interfaces IO Optionboard

Output data servo modules PSD1-M (3*400 VAC)

Detailed output data Servo module PSD1-M

Mains module PSD1-M_P


Mounting and dimensions PSD1-M size 1

The devices are force-ventilated via a ventilator fan fixed to the lower part of the heat dissipator!

Mounting spacing: At the top and below: at least 100mm

Information on

PSD1-M Size 1

  • Multi axes servo drives and
  • Mains Module PSD1-M_P010

Mounting:

2 socket head screws M6

Lateral distance of fixing of mounting holes: 50.5 mm

Required mounting distance for heat regulation at the top and below: At least 100mm

Please check regularly the firmness of the screw connection!

Tolerances: DIN ISO 2768-f


Mounting distances PSD1-M size 1

1 | Additional mounting distance corresponding to the minimum bending radius of the cables
2 | At least 100mm distance for free circulation of cooling air.


Mounting and dimensions PSD1-M size 2

Information on | PSD1-M Size 2 Multi axis Servo Drives (30 A) and Mains Module PSD1-M_P020

Required mounting distance for heat regulation at the top and below: At least 100mm

Mounting:

4 socket head screws M5

Tolerances: DIN ISO 2768-f


Plug and device overview PSD1-M

In this chapter you can read about:

Front view (PSD1-M)

View from below (PSD1-M)

View from above (PSD1-M)


Front view (PSD1-M)

CAUTION: Risk of electric shock
Caution - Risk of electric shock!

Before wiring or loosening electrical connections please observe the following:

  • Risk of electric shock, disconnect power before removing cover resp. disconnect the devices from the mains supply.
  • Caution! Dangerous electrical voltage even after turning off the intermediate capacitors:
    Up to 3 minutes with PSD1-S and 10 minutes with PSD1-M after switching off mains supply, dangerous voltages may still be present.
    Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- of PSD1-S: X63/3 & X63/5 and with PSD1-M: Bus HV DC - 3 & 5. rail.

View from above

P10 (P10:Meaning of the Bus LEDs, P10a: Status display of the device, P10b: Status display of the network)

Status of LEDs for the fieldbus

C11

Slot for SD card (Clone device data on SD card, Copy SD card to target device)

(SD card not included in delivery)

X30

Digital Inputs / Outputs IO Optionboard2

X31

Analogue Inputs and Encoderinput IO Optionboard2

S12

Device address higher value half-byte (accept with power ON)

S13

Device address low value half-byte (accept with power ON)

P14

Status LED axis 1

P15

Status LED axis 2

P16

Status LED axis 3

X17

Digital inputs/outputs axis 1 & 3

X18 *

Feedback sensor Axis 1: Resolver, Encoder/Hall

X19 *

Feedback sensor Axis 2: Resolver, Encoder/Hall

X20 *

Feedback sensor Axis 3: Resolver, Encoder/Hall

S33

For security option

S34

For security option

X37

Digital Inputs / Outputs IO Optionboard1

X38

Analogue Inputs and Encoderinput IO Optionboard1

X21

Digital inputs/outputs axis 2 & 3

24 VDC & DC Power

Behind the yellow protective covers you can find the rails for the supply voltage connection to the mains module PSD1-M_P.

  • 24 VDC power supply
  • DC power voltage supply

View from below

*

Before connecting a feedback cable, check that the correct feedback system is configured in the device.

Otherwise, destruction of the feedback system is threatened by overvoltage!


View from below (PSD1-M)

View from above
X45 X43 for PSD1M_1800 | Motor connections: Axis 1 ... 3 (depending on the device)
X46 X44 for PSD1M_1800 | Motor brake connections: Axis 1 ... 3 (depending on the device)
X48 | Connection of HIPERFACE DSL® motor feedback systems and motor temperature sensor Axis 1 ... 3 (depending on the device)
Front view
Shows pin 1 of the connector

Earthing PSD1M_1800:

Explanation
1 | DSL connection
2 | Connection of motor brake
3 | Connect ground via ring cable lug with a 10 mm2 copper cable to central ground
4 | Mounting the shield clamp 1) with flat connection to the motor cable shielding
5 | Motor Connection
 | 1) The shield clamp is supplied with the Parker motor cables. An accessory set with several clamps for various possible cable diameters is optionally available for in-house manufactured motor cables.

Earthing of all other PSD1M devices:

The earth connection of the motor (and feedback) cable(s) is carried out using the supplied tin angles:

Mounting:

  • Fix cables with clamp collars on the corresponding tin bar (3)
  • Connect plug
  • Screw on tin angle

remarks

1

Fixing screw for tin angle (included with delivery)

2

Tin angle for cable guiding with earthing screw

3

Mounting of cable, and flat shielding

4

Central ground connection

Tin angles and clamp collars are all included.

Alternatively, the earth connection of the motor shielding is also possible via the rear wall of the control cabinet or a PE bus bar:


View from above (PSD1-M)

Front view
X60 | PC Interface to configure and program servo axes
X61 | Fieldbus Interface output
X62 | Fieldbus Interface input
View from below


P14 ... P16: Status LEDs of the individual axes (PSD1-M)

  • P14: Status Axis 1
  • LEDs P15: Status Axis 2
  • LEDs P16: Status Axis 3

Status

No.

Status of axis

Left LED a
(green) (ready)

Right LED b
(red) (error)

0

No voltage

off

off

1

Booting of axis, firmware is missing

alternate quick flashing
(LEDa green, LEDb rot)

2

Axis not ready:

  • Booting of axis
  • No feedback detected.
  • IEC61131-3 program not compatible with firmware.
  • no IEC61131-3 program
  • Hall signals invalid.

off

flashes quickly (5 HZ)

3

Axis de-energized

flashes slowly

off

4

Axis energized; commutation calibration running

flashes quickly

off

5

Axis energized

on

off

6

Axis in error state / error present / axis energized (error reaction 1)

on

flashes quickly (5 HZ)

7

Axis in error state / error present / axis de-energized (error reaction 2)

off

on

8

Axis faulty: Please contact us

on

on

9

STO active

off

flashes slowly (1 HZ)

10

reserved

flashes quickly

flashes quickly (5 HZ)

11

SD Card detected or
restoring from SD card successfully terminated

alternate quick flashing
(LEDa green, LEDb green)

12

SD card not detected or restoring from SD card interrupted

alternate quick flashing
(LEDa red, LEDb red)

13

Axis de-energized

off

Single flash

14

Axis energized

on

Single flash

15

Axis de-energized
HEDA3 slave not ready

off

Double flash

16

Axis energized
HEDA3 Slave not ready

on

Double flash

17

Axis de-energized
HEDA3 Master not ready

off

Triple flash

18

Axis energized
HEDA3 Master not ready

on

Triple flash

19

Axis de-energized

off

Jitter (10 HZ)

20

Axis energized

on

Jitter (10 HZ)

Error response 1: Ramping with slow ramp; then deactivate control loops.

Error response 2: Ramping with "Stop" ramp, then deactivate control loops.

For the meaning of individuals errors please go to Error list.

Single flash | 1fach blinken
Double flash | 1fach blinken
Triple flash | 1fach blinken

Caution - Risk of electric shock!

High voltage supply may be present even with missing voltage supply (both LEDs off)!


X17, X21 STO, digital inputs/outputs PSD1-M

In this chapter you can read about:

X17: Digital Inputs / outputs Axis 1 & 3 (PSD1-M)

X21: Digital Inputs / outputs Axis 2 & 3 (PSD1-M)

Wiring of the digital inputs and outputs


X17: Digital Inputs / outputs Axis 1 & 3 (PSD1-M)

Pin X17 | Input / Output | Axis |
1 | Output | 1 ... 3 | +24 VDC
2 | Output | 1 ... 3 | GND24V
3 | Input | 1 ... 3 | +24 VDC Power supply for digital outputs
4 | I0_1 | 1 | Input 0 Axis 1
5 | I1_1 | 1 | Input 1 Axis 1
6 | I2_1 | 1 | Input 2 Axis 1
7 | I3_1 | 1 | Input 3 Axis 1
8 | GND24V | 1 ... 3 |
9 | O0_1 | 1 | Output 0 Axis 1
10 | GND24V | 1 ... 3 |
11 | O1_1 | 1 | Ouptu 1 Axis 1
12 | STOA1/ | 1 | STO input A Axis 1
13 | I0_3 | 3 | Input 0 Axis 3
14 | STOGND1 | 1 | STO Ground
15 | I1_3 | 3 | Input 1 Axis 3
16 | STOB1/ | 1 | STO input B Axis 1

Loading of the outputs: Maximum 350 mA

In case of overload / over-temperature of an output, all outputs are deactivated and reactivated automatically after cooling.

All inputs and outputs do have 24 V level.

Input level:

"0" (low) = Rated Input Voltage £ 12.5 V

"1" (high= Rated Input Voltage ³ 13.5 V

The digital outputs are free for writing via object 0x2079.0x01 or 0x60FE.0x01 via fieldbus.

The status of digital inputs can be read via object 0x2070.0x00 or 0x60FD.0x00 .


X21: Digital Inputs / outputs Axis 2 & 3 (PSD1-M)

Pin X21 | Input / Output | Axis |
1 | I2_3 | 3 | Input 2 Axis 3
2 | GND24V | 1...3 |
3 | I3_3 | 3 | Input 3 Axis 3
4 | I0_2 | 2 | Input 0 Axis 2
5 | I1_2 | 2 | Input 1 Axis 2
6 | I2_2 | 2 | Input 2 Axis 2
7 | I3_2 | 2 | Input 3 Axis 2
8 | GND24V | 1...3 |
9 | O0_2 | 2 | Output 0 Axis 2
10 | GND24V | 1...3 |
11 | O1_2 | 2 | Output 1 Axis 2
12 | STOA2/ |  | STO input A Axis 2/3
13 | O0_3 | 3 | Ouput 0 Axis 3
14 | STOGND2 | 1...3 | STO Ground
15 | O1_3 | 3 | Output 1 Axis 3
16 | STOB2/ |  | STO Input B axis 2/3

Loading of the outputs: Maximum 350 mA

In case of overload / over-temperature of an output, all outputs are deactivated and reactivated automatically after cooling.

All inputs and outputs do have 24 V level.

Input level:

"0" (low) = Rated Input Voltage £ 12.5 V

"1" (high= Rated Input Voltage ³ 13.5 V

The digital outputs are free for writing via object 0x2079.0x01 or 0x60FE.0x01 via fieldbus.

The status of digital inputs can be read via object 0x2070.0x00 or 0x60FD.0x00 .


X43, X45 motor connection

In this chapter you can read about:

X43: Motor Connection (PSD1M_1800)

X45: Motor Connection (PSD1-M)


X43: Motor Connection (PSD1M_1800)

Motor connection for PSD1M_1800 (30 A)

Description | Axis | Motor cable lead designation*
U | 1 | U / L1 | 1 | U1
V | 1 | V / L2 | 2 | U2
W | 1 | W / L3 | 3 | U3
FE & PE | 1 | YE / GN

* Depending on cable type.

FE: Functional ground

PE: Protective earth

Shielding connection of the motor cable

The external shield of the motor cable must be properly (=over a large area!) connected to the PE both on the drive side (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)) (on the device housing or on the rear wall of the control cabinet) as well as on the motor side (motor housing e.g. via the motor cable plug connector).

The outer and any existing additional inner shielding for the DSL or motor holding brake must not be interrupted.

Also observe the tips on connecting a Hiperface DSL encoder (via hybrid cable).

The PSD1M_1800 is wired differently to the other PSD1M devices:

Explanation
1 | DSL connection
2 | Connection of motor brake
3 | Connect ground via ring cable lug with a 10 mm2 copper cable to central ground
4 | Mounting the shield clamp 1) with flat connection to the motor cable shielding
5 | Motor Connection
 | 1) The shield clamp is supplied with the Parker motor cables. An accessory set with several clamps for various possible cable diameters is optionally available for in-house manufactured motor cables.

Please observe the notes in chapter “Operating conditions for CE-conform operation“.


Motor connection with self-made motor cable

Please consider the specialty of the DSL motor connection with:

  • EX motors,
  • EY motors,
  • NK motors,
  • NV motors and
  • NX motors!

With these motors with DSL feedback, the outputs V & W are swapped in the PSD via the motor configuration (this has no effect on the wiring with Parker motor cables)!

You have connect the self-made cable as shown in the table below:

For EX motors, EY motors, NK motors, NV motors and NX motors:

Axis | Description | Motor cable lead designation* |  |  | Motor side: EX, EY, NK, NV, NX (according to motor datasheet)
1 | U | U / L1 | 1 | U1 | U
 | V | V / L2 | 2 | U2 | W
 | W | W / L3 | 3 | U3 | V
 | FE & PE | YE / GN |  |  | Ground

* Depending on cable type.

FE: Functional ground

PE: Protective earth


X45: Motor Connection (PSD1-M)

Motor connection for 3 axes

The respective pins are not assigned with 1- or 2-axis devices!

Description | Axis | Motor cable lead designation*
CU | 3 | U / L1 | 1 | U1
CV | 3 | V / L2 | 2 | U2
CW | 3 | W / L3 | 3 | U3
FE & PE | 3 | YE / GN
BU | 2 | U / L1 | 1 | U1
BV | 2 | V / L2 | 2 | U2
BW | 2 | W / L3 | 3 | U3
FE & PE | 2 | YE / GN
AU | 1 | U / L1 | 1 | U1
AV | 1 | V / L2 | 2 | U2
AW | 1 | W / L3 | 3 | U3
FE & PE | 1 | YE / GN

* Depending on cable type.
FE: Functional ground

PE: Protective earth

Shielding connection of the motor cable

The external shield of the motor cable must be properly (=over a large area!) connected to the PE both on the drive side (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)) (on the device housing or on the rear wall of the control cabinet) as well as on the motor side (motor housing e.g. via the motor cable plug connector).

The outer and any existing additional inner shielding for the DSL or motor holding brake must not be interrupted.

Also observe the tips on connecting a Hiperface DSL encoder (via hybrid cable).

Mounting:

  • Fix cables with clamp collars on the corresponding tin bar (3)
  • Connect plug
  • Screw on tin angle

remarks

1

Fixing screw for tin angle (included with delivery)

2

Tin angle for cable guiding with earthing screw

3

Mounting of cable, flat shielding

4

Central ground connection

Tin angles and clamp collars are all included.

Please observe the notes in chapter “Operating conditions for CE-conform operation“.


Motor connection with self-made motor cable

Motor connection with self-made motor cable PSD-M

Please consider the specialty of the DSL motor connection with:

  • EX motors,
  • EY motors,
  • NK motors,
  • NV motors and
  • NX motors!

With these motors with DSL feedback, the outputs V & W are swapped in the PSD via the motor configuration (this has no effect on the wiring with Parker motor cables)!

You have connect the self-made cable as shown in the table below:

For EX motors, EY motors, NK motors, NV motors and NX motors:

Axis | Description | Motor cable lead designation* |  |  | Motor side: EX, EY, NK, NV, NX (according to motor datasheet)
3 | CU | U / L1 | 1 | U1 | U
 | CV | V / L2 | 2 | U2 | W
 | CW | W / L3 | 3 | U3 | V
 | FE & PE | YE / GN |  |  | Ground
2 | BU | U / L1 | 1 | U1 | U
 | BV | V / L2 | 2 | U2 | W
 | BW | W / L3 | 3 | U3 | V
 | FE & PE | YE / GN |  |  | Ground
1 | AU | U / L1 | 1 | U1 | U
 | AV | V / L2 | 2 | U2 | W
 | AW | W / L3 | 3 | U3 | V
 | FE & PE | YE / GN |  |  | Ground

* Depending on cable type.

FE: Functional ground

PE: Protective earth


X44, X46 Connecting the motor brake PSD1-M

In this chapter you can read about:

X44: Connection of motor brake (PSD1M_1800)

X46: Connection of motor brake (PSD1-M)


X44: Connection of motor brake (PSD1M_1800)

Pin |  | Designation | Motor cable lead designation*
1 | O1 | Motor holding brake +** | WH | 4 | Br1
2 | O1 | Motor holding brake -** | BK | 5 | Br2
3 | + | Input power supply brake 24 VDC |  |  |
4 | - | GND24 VDC |  |  |

* Depending on cable type.

**1.6 A max.


X46: Connection of motor brake (PSD1-M)

Connection for 3 axes

The respective pins are not assigned with 1- or 2-axis devices!

Pin |  | Designation | Axis | Motor cable lead designation*
1 | A3 | Motor holding brake +** | 3 | WH | 4 | Br1
2 | A3 | Motor holding brake -** | 3 | BK | 5 | Br2
3 | O2 | Motor holding brake +** | 2 | WH | 4 | Br1
4 | O2 | Motor holding brake -** | 2 | BK | 5 | Br2
5 | O1 | Motor holding brake +** | 1 | WH | 4 | Br1
6 | O1 | Motor holding brake -** | 1 | BK | 5 | Br2
7 | + | Input power supply brake 24 VDC | 1 ... 3 |  |  |
8 | - | GND24 VDC | 1 ... 3 |  |  |

* Depending on cable type.

**1.6 A max.


X48, X18...X20 Motor Feedback

In this chapter you can read about:

X48: HIPERFACE DSL® & motor temperature sensor (PSD1-M)

X18, X19, X20 Connector assignment with configured resolver

X18, X19, X20: Assignment with configured incremental encoder or analogue Hall

Feedback system can be destroyed if configured incorrectly!

If you connect a PSD that has already been configured for a specific feedback system to another feedback system, it can be destroyed by too high a voltage.

Procedure when changing the feedback system.


X48: HIPERFACE DSL® & motor temperature sensor (PSD1-M)

HIPERFACE DSL® feedback and motor temperature sensor connection for 3 axes

The respective pins are not assigned with 1- or 2-axis devices!

Pin | Designation | Axis |
1 | PTC+ | 1 | Temperature sensor + motor 1
2 | PTC- | 1 | Temperature sensor - motor 1
3 | PTC+ | 2 | Temperature sensor + motor 2
4 | PTC- | 2 | Temperature sensor - motor 2
5 | PTC+ | 3 | Temperature sensor + motor 3
6 | PTC- | 3 | Temperature sensor - motor 3
7 | DSL+ | 1 |
8 | DSL- | 1 |
9 | DSL+ | 2 |
10 | DSL- | 2 |
11 | DSL+ | 3 |
12 | DSL- | 3 |

Connection on the device (View from below (PSD1-M), View from below (PSD1-M_P mains module), View from below (PSD1-S)).

Operation with Parker HIPERFACE DSL® cable recommended!
Observe the following if no Parker PSD DSL motor cable is being used:

The internal shielding of the twisted Hiperface DSL® signal line must be connected (braided or soldered) to the outer motor cable shielding (and thus to PE) on the motor side (View from below (PSD1-M), View from below (PSD1-S)). From this connection point, the inner shield of the Hiperface DSL® cables (with the wire pair still twisted in it) must be routed up to the PSD servo amplifier Hiperface DSL® connection terminal.

The same applies to the motor side when connecting the Hiperface DSL® lines in a motor terminal box. Here, too, the Hiperface DSL® cable screening must be connected with the outer cable screening and the Hiperface DSL® cable pair from there on must be further routed twisted and screened to its connection terminal.

Please observe the following if you want to use an additional plug to interrupt the DSL lines:

  • No other lines may ever be routed between DSL+ and DSL-.
  • The DSL lines must be twisted and separately shielded.
  • A full surface shielding must be ensured across the plug connection (recommendation: Harting Han-Modular plug with "Han Quintax" or "Han MegaBit" module).
  • The shield of the DSL lines must be connected to PE / ground at the drive unit with low impedance. In the simplest way, this can be done by connecting the DSL shield to the outer shield of the cable at the cable end (on the controller side).


X18, X19, X20 Connector assignment with configured resolver

Assignment with multi feedback option with configured resolver

Pin | Feedback High Density /Sub D
1 | reserved
2 | reserved
3 | reserved
4 | REF-Resolver+ (8 kHz / max. 9.5 Vpp)
5 | +3.3 V (for temperature sensor)
6 | reserved
7 | SIN- (max. 4.7 Vpp differential)
8 | SIN+ (max. 4.7 Vpp differential)
9 | reserved
10 | Tmot*
11 | COS- (max. 4.7 Vpp differential)
12 | COS+ (max. 4.7 Vpp differential)
13 | reserved
14 | reserved
15 | REF-Resolver-

* Pin10 Tmot may not be simultaneously connected to the axis of the associated temperature sensor entry of X48 (PSD1-M).

Category

Specifications

Resolution of the motor position
  • Position resolution: 16.6 Bits (= 0.005°)
  • Absolute accuracy: ±0.167°

Resolver supported
  • LTN: RE-21-1-A05, RE-15-1-B04
  • Tamagawa: TS2610N171E64, TS2620N21E11, TS2640N321E64, TS2660N31E64
  • Tyco (AMP): V23401-T2009-B202

Resolver data supported
  • Transformation ratio: 0.25... 1 (typical 0.5)
  • Excitation frequency 8 Hz
  • Amplitude of the excitation signal: max. 9.5 Vpp.
    (The resolver must be approved for at least this value).

Accuracy

The precision of the position signal is above all determined by the exactitude of the feedback system used.


X18, X19, X20: Assignment with configured incremental encoder or analogue Hall

X18: Axis 1/ single axis devices

X19: Axis 2: not implemented

X20: Axis 3: not implemented

Incremental encoder/ analog & digital Hall sensor with analog sin/cos signals with 1Vpp
Pin | Feedback option / high density /D sub
 | Encoder 1 Vpp | Encoder A/B | Analog Hall sensor
1 | Sense -*
2 | Sense +*
3 | Hall 1 (digital) |  | reserved
4 | Vcc (+5 V) max. 350 mA load
5 | +3.3V (for temperature sensors)
6 | Hall 2 (digital) |  | reserved
7 | Sine - | A- | Sine -
8 | Sine + | A+ | Sine +
9 | Hall 3 (digital) |  | reserved
10 | Tmot**
11 | Cosine - | B- | Cosine -
12 | Cosine + | B+ | Cosine +
13 | N+, Z+, Ref + (encoder refer. mark or index pulse +) |  | reserved
14 | N+, Z+, Ref + (encoder reference mark or index pulse -) |  | reserved
15 | GND (Vcc)

*+5V (Pin 4) is measured and controlled directly at the end of the line via Sense+ and Sense-.

Maximum cable length: 100 m at 0.5 mm2.

** Pin10 Tmot may not be simultaneously connected to the axis of the associated temperature sensor entry of X48 (PSD1-M).

Category

Specification

Incremental encoder *
(Sine / Cosine or A/B square wave - signal)
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Supported signals:
    • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
      (an existing reference mark (Ref signal) is evaluated (with appropriately set machine zero mode) during machine zero run)

      Position resolution: 14 bit per sine/cosine period (at 1Vpp)

      -> with rotary encoder, unit incr./rev:
      encoder_line_count[periods/rev]*16384[incr./period]

      -> with linear encoder, unit e.g. incr./mm:
      16384[incr./period]*1000[um/mm]/Encoder_Periodlength[um]

      or
    • A/B - pulses: Physically RS422 (differential), A/B 90° phase shifted, max. 5 MHz
      (an existing reference mark (Z-track) is evaluated (with appropriate set machine zero mode) at machine zero run).

with the following commutation options:

  • Auto commutation

    or
  • U, V, W or R, S, T commutation signals (NPN open collector) e.g., digital hall sensors**, incremental encoders with commutation track (e.g., Hengstler F series with electrical ordering variant 6)

Analog Hall Sensor *
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
  • Position resolution: 14 bits (at 1Vpp) per sine/cosine period (= 14 bits per motor magnet period).

    -> for rotary motor, unit incr./rev:
    number_motor_pole_pairs [1/rev]*16384 incr.

    -> with linear motor: 16384[incr./pitch]
    with unit e.g. Incr./mm: 16384[incr.] / motor_pitch_length[mm].

* in the 1st development stage only for PSD1-S and PSD1MW1...: Multi axis devices with one power stage.

** the digital hall sensors are to be supplied via the encoder supply pin Vcc (5V nominal, higher voltage possible in case of connected encoder supply sense lines).


X60...X62 Communication interfaces

In this chapter you can read about:

X60: PC-/Diagnostic interface

X61, X62 Connection of field buses (Ethernet)


Output data servo modules PSD1-M (3*400 VAC)

Category | Specification 1)
Controller type | Number of power output stage | Nominal output current [Aeff] | Impulse current for 2 s [Aeff]
PSD1-M_1300 | 1 | 5 | 10
PSD1-M_1400 | 1 | 8 | 16
PSD1-M_1600 | 1 | 15 | 30 2)
PSD1-M_1800 | 1 | 30 | 60 2)
PSD1-M_2220 | 2 | 2 + 2 | 4 + 4
PSD1-M_2330 | 2 | 5 + 5 | 10 + 10
PSD1-M_2440 | 2 | 8 + 8 | 16 + 16
PSD1-M_2630 | 2 | 15 + 5 3) | 30 2) + 10
PSD1-M_3222 | 3 | 2 + 2 + 2 | 4 + 4 + 4
PSD1-M_3433 | 3 | 8 + 5 + 5 3) | 16 + 10 + 10

1) | For standard setting of the switching frequency.
2) | Minimum rotating field frequency for peak current at 15 A & 30 A output stages: f > 3 Hz; with a rotating field frequency of f <3 Hz the maximum peak current duration is 100 ms
3) | Maximum total output current per device: 16 A.


Detailed output data Servo module PSD1-M

Category |  | Specification
Power output stage |  | 2 A |  | 5 A | 8 A | 15 A 2) | 30 A 2)
Input Voltage |  | 300 ... 750 VDC
Voltage Output |  | 3x 0-400 V (0...450 Hz)
Performance during continuous operation1) |  | 1,2 kVA |  | 3 kVA | 4,8 kVA | 9 kVA | 18 kVA
Power loss 1) |  | 20 W |  | 45 W | 75 W | 105 W | 220 W
Output current 3) |  |  | With 400 VAC at the mains module
Inominal [Aeff] | 4 kHz | 2 |  | 5 | 8 | 15 | 30
Ipeak (2 s) [Aeff] | 4 kHz | 4 |  | 10 | 16 | 30 | 60
Inominal [Aeff] | 8 kHz | 2 |  | 5 | 8 | 10 | 20
Ipeak (2 s) [Aeff] | 8 kHz | 4 |  | 10 | 16 | 20 | 40
Inominal [Aeff] | 16 kHz | 1.33 |  | 3.33 | 5.33 | 5 | 11
Ipeak (2 s) [Aeff] | 16 kHz | 2.67 |  | 6.66 | 10.66 | 10 | 22
Output current 3) |  |  | With 480 VAC at the mains module
Inominal [Aeff] | 4 kHz | 2 |  | 5 | 8 | 12.5 | 25
Ipeak (2 s) [Aeff] | 4 kHz | 4 |  | 10 | 16 | 25 | 50
Inominal [Aeff] | 8 kHz | 1.8 |  | 4.5 | 7.2 | 8 | 15
Ipeak (2 s) [Aeff] | 8 kHz | 3.6 |  | 10 | 14.4 | 16 | 30
Inominal [Aeff] | 16 kHz | 1.07 |  | 2.67 | 4.27 | 4 | 8.5
Ipeak (2 s) [Aeff] | 16 kHz | 2.13 |  | 5.33 | 8.53 | 8 | 17

1) | For continuous operation with a mains supply of 400 VAC at the mains module.
2) | Minimum rotating field frequency for peak current at 15 A & 30 A output stages: f > 3 Hz; with a rotating field frequency of f <3 Hz the maximum peak current duration is 100 ms
3) | Output current bei verschiedenen switching frequency. The default settings of the currents und switching frequencies are grayed out & in bold.


Mains module PSD1-M_P

In this chapter you can read about:

Plug and device overview PSD1-M_P (mains module)

P1: Status - LEDs - Meaning (Mains module)

S2: Modes switch (Power module)

S3: Voltage switch (Power Module)

Connections of the axis system

X4: Inputs / Outputs of the mains module

X9: Control voltage 24 VDC mains module

X40: Braking resistor / Temperature switch PSD1-M_P (Power supply)

X41 Mains supply (mains module PSD1-M_P)


Plug and device overview PSD1-M_P (mains module)

In this chapter you can read about:

Front view (PSD1-M_P Mains Module)

View from below (PSD1-M_P mains module)


Front view (PSD1-M_P Mains Module)

CAUTION: Risk of electric shock
Caution - Risk of electric shock!

Before wiring or loosening electrical connections please observe the following:

  • Risk of electric shock, disconnect power before removing cover resp. disconnect the devices from the mains supply.
  • Caution! Dangerous electrical voltage even after turning off the intermediate capacitors:
    Up to 3 minutes with PSD1-S and 10 minutes with PSD1-M after switching off mains supply, dangerous voltages may still be present.
    Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- of PSD1-S: X63/3 & X63/5 and with PSD1-M: Bus HV DC - 3 & 5. rail.

P1 (P10:Meaning of the Bus LEDs, P10a: Status display of the device, P10b: Status display of the network)

Status LEDs

S2

Modes switch

S3

Power supply requirements setting

X4

Digital Inputs / Outputs

X9

Control Voltage 24 VDC

24 VDC & DC power

Behind the yellow protective covers you can find the rails for the supply voltage connection.

  • 24 VDC-Power supply
  • DC Power Voltage Supply

View from below


View from below (PSD1-M_P mains module)

Front view
X40 | Ballast resistor
X41 | Power supply
Central ground connection | Connect ground via ring cable lug with a 10 mm2 copper cable to central ground


P1: Status - LEDs - Meaning (Mains module)

Mains module status |  | P1 green LED: a (left) | P1 red LED b (right) | Status of digital outputs (Clamps X4)
Switched off 24 VDC control voltage is missing or out of range |  | off | off | All Outputs = Low
Pre-Charge * The indirect inverter is charged or it is maintained on the AC power supply (control voltage OK, no error) |  | flashes quickly | off | Ready A0 = Low Warning A1 = High
Device Ready | Still no enable from input E0 = High ("Enable" X4 Pin 5) | flashes slowly | off | Ready A0 = Input E0 ("Enable" X4 Pin 5) = Low Warning A1 = High
 | Enable granted (no warning, no error, E0 = High) | on | off | Ready A0 = Input E0 ("Enable" X4 Pin 5) = High Warning A1 = High
 | Advance warning active and enable granted (Device still ready, warning present, still no error, E0 = High) | on | flashes slowly | Ready A0 = Input E0 ("Enable" X4 Pin 5) Warning A1 = Low
Device in error ** | with over-temperature or overload | off | flashes slowly | Ready A0 = Low Warning A1 = Low
 | with "Error digital outputs" | off | flashes quickly | Ready A0 = Low Warning A1 = High
 | One or more other errors 1) with error number indicator after 5s*** 1) other errors = not over-temperature, not overload, not "error digital outputs" | off | on (5s) *** | Ready A0 = Low Warning A1 = High
Device in “bootloader" status |  | flashes slowly | flashes slowly | All Outputs = Low

See also X4: Inputs / Outputs of the mains module

* Low voltage error/switch on AC voltage

A low voltage error will be issued at the earliest 8s after switching on the 24VDC (control voltage 24VDC PSD1-M_P (mains module) X9).

If there is a (significant) delay (after the 24 VDC) in switching on the AC voltage, the device will enter an error state after 8s.

After switching on the AC power supply, this low voltage error must first be acknowledged in order to switch to the normal operating state.

To avoid another error, a waiting time must be implemented between switching on the AC voltage and the "Quit" ** (approx. 5s). Alternatively, the "Quit" (new rising edge) for the set input 0 "Enable" (X4 Pin 5) can be re-triggered until the device reports it is ready via the digital output 0 X4 Pin 9.

** Acknowledgment of errors

The error cancellation is carried out via a rising edge (Low -> High) on the E1 input ("Quit" X4 Pin 6)

***Display of error numbers by flash sequence

Green LED: Tens

1 flash =10; 2 flashes =20; 3 flashes =30; ...

Red LED: Single figure

1 flash = 1; 2 flahes = 2; 3 flashes = 3; ...

Adding both values results in the error number.

Display sequence:

  • Green LED = OFF, red LED on for 5 s
  • Green LED 1 … 9 flashes, depending on the error number.
  • Red LED 1 … 9 flashes, depending on the error number.
  • Green LED off and red LED off for 1 s

This sequence repeats until the error is reset.

Meaning of the error numbers

11 | Phase error
12 | Voltage DC bus too low *
13 | Voltage DC bus too high
21 | Temperature in the rectifier too high
22 | Braking circuit overloaded
23 | Temperature in the braking resistor too high
24 | Short-circuit in the braking circuit
25 | Rectifier overloaded
31 | Current DC bus too high
32 | Current offset DC bus too high
41 | Overcurrent at digital output
51 | None or wrong EEPROM - Data

Caution - Risk of electric shock!

High voltage supply may be present even with missing voltage supply (both LEDs off)!


S2: Modes switch (Power module)

Switch position | Operating mode
0 | standard
1 | Increased performance by line choke mode Warning! Operating without line choke can destroy the device.
2 ... F | Not defined

Acceptance of the switch position when switching on 24 VDC Control voltage.


S3: Voltage switch (Power Module)

Switch position | Supply‑ voltage | Load Circuit |  | Umax
 |  | Turn-on threshold [VDC] | Turn-off threshold [VDC] | [VDC]
0 | 3AC400V | 780 | 770 | 810
1 | 3AC110V | 780 | 770 | 810
2 | 3AC230V | 780 | 770 | 810
3 | 3AC380V | 780 | 770 | 810
4 | 3AC480V | 780 | 770 | 810
5 | 3AC230V | 390 | 380 | 410
6 | 3AC110V | 390 | 380 | 410
7 | 1AC230V* | 390 | 380 | 410
8 | 1AC110V* | 390 | 380 | 410
9 ..F | factory use

Acceptance of the switch position when switching on 24 VDC Control voltage

Operation with switch positions 9 ... F can destroy the device

* Switch positions 7 and 8 are intended solely for commissioning!

Continuous mode in this switch position is not allowed.


Connections of the axis system

The axis controllers are connected to the supply voltages via rails.

  • Supply voltage 24VDC
  • DC power voltage supply

The rails can be found behind the yellow protective covers. In order to connect the rails of the devices, you may have to remove the yellow plastic device inserted at the side.

Caution - Risk of electric shock!

Always switch off devices before wiring them!

Dangerous voltages are still present until 10min. after switching off the power supply.

Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- (X63/4 & X63/5).

1 | 24VDC
2 | GND24V
3 | -HV DC
4 | PE
5 | +HV DC

Protective seals

Caution - Risk of electric shock!

In order to secure the contact protection against the alive rails, it is absolutely necessary to respect the following:

  • Insert the yellow plastic comb at the left and right of the rails.
    Make sure that the yellow plastic combs are placed at the left of the first device and at the right of the last device in the system and have not been removed.
  • Setup of the devices only with closed protective covers.

External components may not be connected to the rail system.

Protective seals

Caution!

The user is responsible for protective covers and/or additional safety measures in order to prevent damages to persons and electric accidents.


X4: Inputs / Outputs of the mains module

Pin | Name | Function
1 | 24 VDC (Output) | +24 VDC Output (max. 340 mA)
2 | GND24V | GND24V
3 | 24 VDC Dout (Input) | 24 VDC Supply for the outputs 0 ... 3
4 | Nc | -
5 | Input 0 | Enable (High=Enable, Low=Disable)
6 | Input 1 | Quit (positive edge) *, **
7 | Input 2 | Not defined
8 | Input 3 | Not defined
9 | Power Output 0 | Ready (High=ready , Low=not ready ) *, ** Note: The output can be seen as the logical AND link of the internal "device ready" status with digital input 0 "Enable" (X4 Pin 5) - see also Status LEDs PSD1-M power module
10 | Power Output 1 | Warning (High = no warning , low = warning) ***
11 | Power Output 2 | Not defined
12 | Power Output 3 | Not defined
13 | reserved | -
14 | reserved | -

* Low voltage error/switch on AC voltage

A low voltage error will be issued at the earliest 8s after switching on the 24VDC (control voltage 24VDC PSD1-M_P (mains module) X9).

If there is a (significant) delay (after the 24 VDC) in switching on the AC voltage, the device will enter an error state after 8s.

After switching on the AC power supply, this low voltage error must first be acknowledged in order to switch to the normal operating state.

To avoid another error, a waiting time must be implemented between switching on the AC voltage and the "Quit" ** (approx. 5s). Alternatively, the "Quit" (new rising edge) for the set input 0 "Enable" (X4 Pin 5) can be re-triggered until the device reports it is ready via the digital output 0 X4 Pin 9.

** Acknowledgment of errors

The error cancellation is carried out via a rising edge (Low -> High) on the E1 input ("Quit" X4 Pin 6)

*** Warning

To set the output 1 "Warning", there are the following two conditions:

  • Capacity utilization warning: Capacity utilization of DC Bus >= 90%

or

  • Temperature alarm: Rectifier <=5°K before the shut-off threshold

Connected axes must only be energized if Output 0 = ready = high!

Otherwise, the mains module may be damaged.


X9: Control voltage 24 VDC mains module

Connector X9

Pin | Designation | Line cross sections: minimum: 0.5mm2 with conductor sleeve maximum: 6mm2 with conductor sleeve (AWG: 20 ... 10)
1 | +24V
2 | GND24V

Category | Specification
Voltage range | 21.6 - 27.0 VDC (24 VDC -10 % +12.5 %)
Ripple | 0.5 Vpp
Requirement according to safe extra low voltage (PELV) | Yes
Electric current drain | PSD1-M_P010: 0.2 A PSD1-M_P020: 0.3 A ea. PSD1-M Axis: 1.0 A + Output current of digital outputs (fed via connectors X17/2, 3) + Output current of motor brakes (fed via connectors X46/7 & 8; PSD1M_1800 X44/3 & 4) + Current requirements of optional boards


X40: Braking resistor / Temperature switch PSD1-M_P (Power supply)

The energy generated during braking operation must be dissipated via a braking resistor.

Pin | Description
+R | + Braking resistor | short circuit proof!
-R | - Braking resistor
PE | PE
T1R | Temperature switch
T2R | Temperature switch

Device type | PSD1-M_P010 | PSD1-M_P020
Capacity/ storable energy | 550 µF/ 92 Ws at 400 V 53 Ws at 480 V | 1175 µF/ 197 Ws at 400 V 114 Ws at 480 V
Minimum braking resistance | 27 W | 10 W
Recommended nominal power rating | 500 ... 1500 W | 500...5000 W
Pulse power for 1s | 22 kW | 60 kW
Maximum permissible continuous current | 13 A | 25 A
Maximum capacity in the axis system:
  • PSD1-M_P010: 2400 µF
  • PSD1-M_P020: 5000 µF
Reference value for the required capacity in an axis system

100 µF per kW of the temporal medium value of the total power (transmissions + power dissipation) in the axis system.

Example: PSD1-M_P020 (1175 µF) with one axis controller (440 µF)

Total power 15 kW, 100 µF/kW => 1500 µF required in the axis system.

Axis system: 1615 µF are sufficient.

Connection of a braking resistor on PSD1-M_P (mains module)

Minimum line cross section: | 1.5 mm2
Maximum line length: | 2 m
Maximum intermediate circuit voltage: | Depending on the position of the switches on the power module
Switch-on threshold:
Hysteresis:


Temperature switch mains module X40

Connector X40 Pin T1R, T2R

Temperature monitoring:

The temperature switch (normally closed contact) must be connected, unless an error message will be issued.

Temperature switch/relay

No galvanic separation, the temperature sensor (normally closed contact) must comply with the safe separation according to EN 60664.

If there is no temperature monitoring due to the connected braking resistor, the T1R and T2R connections must be connected by a jumper.

Caution!

Without temperature monitoring, the braking resistor might be destroyed.


X41 Mains supply (mains module PSD1-M_P)

Device protection

By cyclically switching on and off the power voltage, the input current limitation can be overloaded, which may cause damage to the device.

Wait at least one minute between two switching on processes!


X41 Mains supply PSD1-M_P connector assignment

Pin | Designation
PE | Earth conductor
L3 | Phase 3
L2 | Phase 2
L1 | Phase 1

Only three-phase operation of the PSD1-M_P devices is permitted!

Please observe the notes in chapter “Operating conditions for CE-conform operation“.

Caution - Risk of electric shock!

Always switch off devices before wiring them!

Dangerous voltages are still present until 10min. after switching off the power supply.

Please check that no voltages are present (<50 V) at the output terminals DC+ and DC- (X63/4 & X63/5).


Mains Connection Power module PSD1-M_P010 without line choke

Category | Specifications
PSD1-M_P010 | 230 V | 400 V | 480 V
Mains voltage | 230 VAC ±10 % 50-60 Hz | 400 VAC ±10 % 50-60 Hz | 480VAC ±10% 50-60Hz
Rated voltage | 3 AC 230 V | 3 AC 400 V | 3 AC 480 V
Input Current | 22 Arms | 22 Arms | 18 Arms
Output voltage | 325 VDC ±10 % | 565 VDC ±10 % | 680 VDC ±10 %
Output power | 6 kW | 10 kW | 10 kW
Pulse power (<5 s) | 12 kW | 20 kW | 20 kW
Power dissipation | 60 W | 60 W | 60 W

Maximum fuse rating per device

Measure for line and device protection:

UL listing (DIVQ) automatic circuit breaker

Manufacturer: ABB, Stotz-Kontakt GmbH (E212323)

Model No.: S203UP-K, 1 automatic circuit breaker

480 VAC, 3-phase, 25 A, Operating temperature 55 °C


Mains connection Power module PSD1-M_P010 with line choke

Increased power by means of a line choke
Category | Specifications
PSD1-M_P010 with line choke | 230 V | 400 V | 480 V
Mains voltage | 230 VAC ±10 % 50-60 Hz | 400 VAC ±10 % 50-60 Hz | 480VAC ±10% 50-60Hz
Rated voltage | 3 AC 230 V | 3 AC 400 V | 3 AC 480 V
Input Current | 24.5 A | 24.5 A | 20.4 A
Output voltage | 325 VDC ±10 % | 565 VDC ±10 % | 680 VDC ±10 %
Output power | 9 kW | 15 kW | 15 kW
Pulse power (<5 s) | 18 kW | 30 kW | 30 kW
Power dissipation | 70 W | 70 W | 70 W

Maximum fuse rating per device | Measure for line and device protection: UL listing (DIVQ) automatic circuit breaker Manufacturer: ABB, Stotz-Kontakt GmbH (E212323) Model No.: S203UP-K, 1 automatic circuit breaker 480 VAC, 3-phase, 25 A, Operating temperature 55 °C
Earth leakage current | Current on the mains PE (>3,5 mA)
Supply networks | Possible supply networks: TN

The specified performance data are only valid in connection with line choke IND-0001-02.


Mains Connection Power module PSD1-M_P020 without line choke

Category | Specifications
PSD1-M_P020 | 230 V | 400 V | 480 V
Mains voltage | 230 VAC ±10 % 50-60 Hz | 400 VAC ±10 % 50-60 Hz | 480VAC ±10% 50-60Hz
Rated voltage | 3 AC 230 V | 3 AC 400 V | 3 AC 480 V
Input Current | 44 Arms | 44 Arms | 35 Arms
Output voltage | 325 VDC ±10 % | 565 VDC ±10 % | 680 VDC ±10 %
Output power | 12 kW | 20 kW | 20 kW
Pulse power (<5 s) | 24 kW | 40 kW | 40 kW
Power dissipation | 120 W | 120 W | 120 W

Maximum fuse rating per device

2 fuses in line are required

Measure for line protection:

MCB (K characteristic) with a rating of 50A / 4xxVAC (depending on the input voltage)Recommendation:
Recommendation: (ABB) S203U-K50 (440VAC)

Measure for device protection:

Fuses 80A / 700VAC per supply leg in accordance with UL category JFHR2:
Essential: Bussmann 170M1366 or 170M1566D


Mains connection Power module PSD1-M_P020 with line choke

Increased power by means of a line choke
Category | Specifications
PSD1-M_P020 with line choke | 230 V | 400 V | 480 V
Mains voltage | 230 VAC ±10 % 50-60 Hz | 400 VAC ±10 % 50-60 Hz | 480VAC ±10% 50-60Hz
Rated voltage | 3 AC 230 V | 3 AC 400 V | 3 AC 480 V
Input Current [rms] | 44 A | 44 A | 40 A
Output voltage | 325 VDC ±10 % | 565 VDC ±10 % | 680 VDC ±10 %
Output power | 15.5 kW | 27 kW | 30 kW
Pulse power (<5 s) | 31 kW | 54 kW | 60 kW
Power dissipation | 140 W | 140 W | 140 W

Maximum fuse rating per device

2 fuses in line are required

Measure for line protection:

MCB (K characteristic) with a rating of 50A / 4xxVAC (depending on the input voltage)Recommendation:
Recommendation: (ABB) S203U-K50 (440VAC)

Measure for device protection:

Fuses 80A / 700VAC per supply leg in accordance with UL category JFHR2:
Essential: Bussmann 170M1366 or 170M1566D

Earth leakage current

Current on the mains PE (>3,5 mA)

Supply networks

Possible supply networks: TN

The specified performance data are only valid in connection with line choke IND-0002-01 or IND-0002-02 (UL).


Safe Torque Off (STO) with PSD1

In this chapter you can read about:

General Description

STO Operating Principle

Notes on the STO function

Conditions of utilization for the STO function

STO delay times

STO Application examples

STO function test

Technical data STO


General Description

In this chapter you can read about:

Important Technical Terms and Explanations

Applications in accordance with the regulations

Qualified Personnel

Advantages of using the "safe torque off" safety function" STO

The following documentation is meant to provide the basic information concerning our drive controller and an understanding about the advanced, safety oriented machine construction. References to standards or other regulations are made in a general overview manner. The specific standards or regulations for your installation will vary depending upon the equipment employed and the specifics of your application.

For complementary information, we recommend the respective technical literature.


Important Technical Terms and Explanations

Term

Explanation

Safety category 3 in accordance with EN ISO 13849-1

Definition according to standard:

Circuit with built-in protective functions for individual fault conditions.

Some, but not all faults will be recognized.

The frequent occurrence of fault conditions can lead to a loss of the safety functions.

The remainder of the risk must be understood and accepted.

The determination for the application of the appropriate safety category requirements, (risk analysis), lies with the installer and operator of the equipment.

It can take place according to the method described in EN ISO 13849-1, appendix A.

"Safe torque off"

or abbreviated:

STO=Safe torque off

With the "safe torque off", the energy supply of the drive is safely interrupted according to EN 14118, paragraph 4.1.

The drive is not to be able to produce a torque and thus dangerous movements (see EN 14118, paragraph 5.3.1.3).

The standstill position must not be monitored.
If an external force effect, e.g. a drop of hanging loads, is possible with the "safe torque off", additional measures to safely prevent those must be provided (e.g. additional mechanical brakes).

The following measures are appropriate for a "safe torque off":

Contactor between mains and drive system (mains contactor)

Contactor between power section and motor (motor contactor)

Safe blocking of the power semiconductor control (start inhibitor)

Start-Up Lockout

Safe blocking of the power semiconductor control.

With the aid of this function, you can obtain a "safe torque off".
Stop categories according to EN60204-1 (9.2.2)
Stop- Category | Safety function | Requirement | System Behaviour | Remark
0 | Safe Torque Off (STO) | Stopping by immediately switching off the energy supply of the machine drive elements | Uncontrolled stop | Uncontrolled stop is the stopping of a machine movement by switching off the energy of the machine drive elements. Available brakes and/or other mechanical stopping components are applied.
1 | Safe stop 1 (SS1) | Stop where the energy of the machine drive elements is maintained in order to reach a stop. The energy supply is only interrupted, if the standstill is attained. | Controlled stop | Controlled stop is the stopping of a machine movement by for instance resetting the electrical command signal to zero, as soon as the stop signal has been detected by the controller, the electrical energy for the machine drive elements remains however during the stopping procedure.
2 | Safe stop 2 (SS2) | Stop where the energy to the machine drive elements is maintained. | Controlled stop | This category is not covered.


Applications in accordance with the regulations

The Servo Drive PSD supports the "safe torque off" (STO) safety function, with protection against unexpected startup according to the requirements of EN ISO 13849-1, category 3 to PLe and EN 14118.

Together with the external safety control device, the "safe stop 1" (SS1) safety function according to the requirements of DIN EN 61800-5-2:2008 category 3 can be used. As the function is however realized with the aid of an individually settable time delay on the safety control, it must be taken into account that, due to an error in the drive system during the active braking phase, the motor coasts uncontrolled or may even accelerate actively in the worst case until the expiry of the preset switch-off time.

A risk evaluation which must be carried out according to the machine standard 2006/42/EG resp. EN ISO 12100 and EN ISO 13849-1, the machine manufacturer must project the safety system for the entire machine including all integrated components. This does also include the electrical drives.


Qualified Personnel

Planning, installation and initial system commissioning require a detailed understanding of this description.

Standards and accident prevention regulation associated with the application must be known and respected as well as risks, protective and emergency measures.

The implementation of the safety functions as well as maintenance and service can only be carried out by suitably qualified personnel with many years of experience in the field of machine safety with drives.

We assume that these specialists have a good knowledge of English.

In the case of deviating regulations (in particular work by persons who do not speak English), the machine manufacturer must provide these persons with the necessary information in the national language.


Advantages of using the "safe torque off" safety function" STO

Safety category 3 in accordance with EN ISO 13849-1

Requirements performance features

Use of the safe torque off function

Conventional solution: Use of external switching elements

Reduced switching overhead

Simple wiring, certified application examples

Grouping of drive controllers on a mains contactor is possible.

Two safety-oriented power contactors in series connection are required.

Use in the production process

High operating cycles, high reliability, low wear

Extremely high operating cycles thanks to almost wear-free technology (low-voltage relay and electronic switch). The "safe torque off" status is attained due to the use of wear-free electronic switches (IGBTs).

This performance feature cannot be reached with conventional technology.

Use in the production process

High reaction speed, fast restart

Drive controller remains performance- and control-oriented in connected state.

No significant waiting times due to restart.

When using power contactors in the supply, a long waiting time for the energy discharge of the DC link circuit is required.

When using two power contactors on the motor side, the reaction times may increase, you must however take into consideration other disadvantages:

a) Securing that switching takes only place in powerless state (Direct current! Constant electric arcs must be prevented).

b) Increased overhead for EMC conform wiring.

Emergency-stop function

Allowed

Allowed


STO Operating Principle

In this chapter you can read about:

STO principle with PSD1-S

STO principle of PSD1-S with one axis module

STO principle of PSD1-M with two axis modules

STO principle of PSD1-M with three axis modules

Principle

The current flow in the motor windings is controlled by a power semiconductor bridge (6-fold IGBT).

A rotating field is created via the processor by means of the power output stage. Between control logic and power module, optocouplers are used for potential separation.

The STO input are on the front panel. 2 optocouplers are controlled via 2 STO channels (STOA/ & STOB/). At a STO via external safety control both auxiliary power supplies of the power output stage are switched off via 2 channels. Due to this fact the power semiconductor bridge is blocked and there is no motor current.

The reset procedure of the Safe Torque Off depends on the configurated settings of the object STO_Setup.

At standard settings STO_Setup=0 the motor may be powered as soon as STOA/ and STOB/ inputs are reset to high level.

At settings STO_Setup=1 the generated error 0x5492 needs be acknowledged before the motor can be powered again.

Detection of hardware failure

An internal Hardware monitoring recognizes the failure of the optocoupler by continuously comparing both channels. If the monitoring system recognizes a discrepancy for a defined time (approx. 10 s) the fault is stored in the hardware. This is reported via the error code 0x5493 ?.

The error can only be reset by a hardware reset (switching off and on the servo drive). But before the error must be found and solved by the user.


STO principle with PSD1-S

With the single axis drive PSD1-S STO is activated via 2 channels (STOA/ and STOB/).

Pin

Name

Description

X17.12

STOA/*

Input

STOA/ = 0 V | Motor deactivated
STOB/ = 0 V | Motor deactivated
STOA/ = 24 VDC and STOB/ = 24 VDC | Motor released

X17.16

STOB/*

Input

X17.14

STOGND*

Input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

* The inputs are optically isolated.


STO principle of PSD1-S with one axis module

At the PSD1-M with one axis module, STO is activated via 2 channels (STOA1/ und STOB1/).

Pin

Name

Description

X17.12

STOA1/*

Input

STOA1/ = 0 V | Motor deactivated
STOB1/ = 0 V | Motor deactivated
STOA1/ = 24 VDC and STOB1/ = 24 VDC | Motor released

X17.16

STOB1/*

Input

X17.14

STOGND1*

input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

* The inputs are optically isolated.


STO principle of PSD1-M with two axis modules

At the PSD1-M drive with two axis modules, STO is activated via 2 channels for each motor (STOA1/ and STOB1/ for motor 1 and STOA2/ and STOB2/ for motor 2).

Pin

Name

Description

X17.12

STOA1/*

Input

STOA1/ = 0 V | Motor 1 deactivated
STOB1/ = 0 V | Motor 1 deactivated
STOA1/ = 24 VDC and STOB1/ = 24 VDC | Motor 1 released

X17.16

STOB1/*

Input

X17.14

STOGND1*

Input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

X21.12

STOA2/*

Input

STOA2/ = 0 V | Motor 2 deactivated
STOB2/ = 0 V | Motor 2 deactivated
STOA2/ = 24 VDC and STOB2/ = 24 VDC | Motor 2 released

X21.16

STOB2/*

Input

X21.14

STOGND2*

input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

* The inputs are optically isolated.


STO principle of PSD1-M with three axis modules

At the PSD1-M drive with three axis modules, STO for motor 1 is activated via 2 channels (STOA1/ and STOB1/ and for the motors 2 & 3 via two further channels (STOA2/ & STOB2/).

Pin

Name

Description

X17.12

STOA1/*

Input

STOA1/ = 0 V | Motor 1 deactivated
STOB1/ = 0 V | Motor 1 deactivated
STOA1/ = 24 VDC and STOB1/ = 24 VDC | Motor 1 released

X17.16

STOB1/*

Input

X17.14

STOGND1*

Input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

X21.12

STOA2/*

Input

STOA2/ = 0 V | Motor 2 & 3 deactivated
STOB2/ = 0 V | Motor 2 & 3 deactivated
STOA2/ = 24 VDC and STOB2/ = 24 VDC | Motor 2 & 3 released

X21.16

STOB2/*

Input

X21.14

STOGND2*

Input

STO Ground.
Ground of the external 24 VDC must be connected to the central ground connection (bottom of the device).

* The inputs are optically isolated.


Notes on the STO function
  • It should be noted in connection with the STO application examples illustrated here that after the Emergency stop switch has been activated, no galvanic isolation in accordance with EN 60204-1 Section 5.5 is guaranteed. This means that the entire system must be disconnected from the mains power supply with an additional main switch or mains power contactor for repair jobs. Please note in this context, that even after the power is disconnected, dangerous electrical voltages may still be present in the drive for about 10 minutes.
  • During the active braking phase of Stop category 1 (controlled bringing to a stop with safely monitored delay time according to EN60204-1) or safe stop 1, faulty function must be expected. If an error in the drive system occurs during the active braking phase, the axis may trundle to an unguided stop or might even actively accelerate until the expiry of the defined switch-off time.
  • As soon as Setup-mode is activated in the PSD ServoManager, the Fieldbus - Interface is deactivated. Then it is not possible to set a braking ramp via fieldbus.

Maintenance

  • When using STO a recorded STO - function test must be carried out:
    • After commissioning and
    • in defined maintenance intervals.


Conditions of utilization for the STO function

  • The STO safety function must be tested and protocoled as described. The safety function must be requested at least once a week. In safety door applications, the weekly testing interval must not be observed, as you can assume that the safety doors will be opened several times during the operation of the machine.
  • The PSD1 with integrated STO safety function as well as the utilized safety switching devices must be mounted protected (IP54 control cabinet).
  • Basically there is only a maximum cable lenght of 30 m of STO inputs (X17, X21) alllowed. It's not permitted to route the cables outside.
  • Only qualified staff members are permitted to install the STO function and place it in service.
  • The X9/2 (GND24V) terminal on the PSD1-M_P mains module respectively the X17.12 (GND24V) terminal on the PSD1-S single device must be connected to the PE protective lead. This is the only way to ensure protection against incorrect operation through earth faults (EN60204-1 Section 9.4.3)!
  • When using an external safety control with adjustable delay time, (as illustrated in the STO application example), it must be ensured that the delay time cannot be adjusted by persons not authorized to do so (for example by applying a lead seal). With the UE410-MU safety control, this is not necessary, if the anti manipulation measures are respected.
  • The adjustable delay time on the safety control must be set to a value greater than the duration of the braking ramp controlled by the PSD1 with maximum load and maximum speed.
    Otherwise fault 0x5495 may occur.
  • All conditions necessary for CE-conform operation must be observed.
  • When external forces are applied to the drive axes, additional measures (e.g. additional brakes) are to be taken. Please note in particular the effects of gravity on suspended loads! This must be respected above all for vertical axes without self-locking mechanical devices or weight balance.
  • When using synchronous motors, a short movement over a small angle is possible, if two errors occur simultaneously in the power section. This depends on the number of pole pairs of the motor (rotary types: 2 poles = 180°, 4 poles = 90°, 6 poles = 60°, 8 poles = 45 °, Linear motors: 180 ° electric).


STO delay times

*

Complies with the Quick-Stop-Ramp (0x6085.0x00); in PSD ServoManager under [image] axis1: Ramps.
With DS402, QuickStopOptionCode (0x605A.0x00) should be set to standard value 2 so that the motor can be disconnected from the power supply.

1 | = MinSlowDown (0x3428.0x00)
2 | = QuickStopDecel (0x6085.0x00)


Parker Servo Drive

Vorige Seite

Nächste Seite

STO Application examples


STO and SS1 function with external safety control

In this chapter you can read about:

Circuit Diagram

Description

Functional description

Design Features

Calculation of the total failure probability


Parker Servo Drive

Vorige Seite

Nächste Seite

Circuit Diagram


Description

The application example demonstrate how a 3-axis PSD1-M servo drive cooperates with the safety control UE410-MU of Sick and with a PLC.

The STO circuit of the 3-axis PSD1-M must support a safe stop 1 of the control with emergency stop (category 3 - PL e). The application example described here corresponds to Stop Category 1 as defined by EN60204-1.

Together with the external safety switching device, the "Safe Stop 1”(SS1) safety function can also be implemented.

A Stop Category 0 in accordance with EN 60204-1 can be implemented, for example by setting the delay time on the safety switching device to 0. The motor torque will then be turned off immediately in 2 channels and will not be able to generate any more torque. Please take into consideration that the motor will not brake and a coasting down of the motor (trundling) may result in hazards. Additionally the motor fixing brake can be damaged at braking. If this is the case, the STO function in stop category 0 is not permitted.


Functional description

  • Shut-down of the motor is initiated by:
    • Activating emergency-stop or
    • Opening the safety door
  • The safety control UE410-MU requires a stop from PLC via output Q3.
  • Via fieldbus the PLC sends a braking ramp/ stop command to the PSD1-M for all 3 motors.
  • After a delay time set in the safety control UE410-MU, STO (channel 1 & 2) is released via output Q4.
  • Thus all 3 motors are placed in a moment-free condition (STO). Please take care that object STO_Setup=0 (standard settings) in order to prevent that STO is recognized as fault.
  • In the Fieldbus, Status Word Bit 15 STO status is displayed as slowly flashing LED.
  • The delay time in the safety control must increased in such a way that, as soon as STO is released, the motors stand still by the braking ramp configured in the drive.
  • The acknowledgement (start button) via the safety control UE410-MU is only necessary, if after the disabling of the STO function, a danger to any person or to the machine could arise due to automatic start-up.


Design Features

  • The contacts of the emergency stop buttons and the safety door need to be designed mechanically in accordance with EN 60947-5-1 appendix K.
  • Concerning the delayed STO procedure, the risk must be considered by the machine designer.
  • Drive and safety control must be wired in the same control cabinet. Wiring must be in accordance with EN 60204-1.
  • The operating instructions of the UE410-MU3T5 safety control must be observed.
  • We recommend to use a filter > 3 ms for the signal Q3 in the PLC (stop input) as the safety control UET410-MU regularly modulates test signals on the outputs Q3 and Q4.
  • Other safety controls may be used if they fulfill all requirements for category 3 PL=e and dispose of a high-quality error detection with dynamic test pulse. The max. test pulse must be <1 ms / actively low.


Calculation of the total failure probability

The failure probability of each of the two STO circuits of the servo drive is 1.0E-09 per hour. Thus the probability of a failure of the entire 3-axis servo drive is 2.0E-09 per hour.

The safety control UE410.MU is a certified component. Its failure probability is 6.0E-09 per hour.

At this calculation only the probability of a failure of the emergency stop is considered, not the contact of the safety door. With a B10d value of 100.000 cycles at 240 working days, 16 working hours and at a cycle time of 1 hour, the result for nop is 3840 cycles per year and 260 years for MTTFd. As the safety control disposes of a high-quality error detection with dynamic test pulse for the input signal, a high diagnostic coverage DC for the switches can be set.

According to Sistema the total failure probability is 3.27E-8 per hour (PL=e).


STO function without external safety control

In this chapter you can read about:

Circuit Diagram

Functional description

Design Features

Calculation of the total failure probability


Circuit Diagram

In this example we show how the contacts of the safety door can be wired to the 1-axis PSD1 without the use of a safety control.

A double-channel safety door monitoring or a double-channel emergency stop can be directly wired to the PSD1.

We do not recommend this type of wiring for vertical axes without self-locking mechanics as it may be damaged at braking with the motor holding brake by motor coasting. If this is the case we recommend to use the previous wiring type with safety control.


Functional description

  • When opening the safety door, the motor is immediately switched to double-channel, moment-free mode; this complies with Stop Category 0 In accordance with EN 60204-1. In case the motor axis is still energized or moving during the triggering of the STO, error 0x5495 is triggered simultaneously. If not, no error is triggered; unless error 0x5492 is triggered at setting STO_Setup=1.
    Basically STO status is displayed in the Fieldbus Status Word Bit 15 and as slowly flashing LED.
  • During trundling of the motor the motor brakes of the Parker motor must not be activated as otherwise they can be damaged.
  • In case error 0x5492 or 0x5495 are triggered then error must be acknowledged in order to reactivate the drive. The acknowledgement is only permissible with category B. It shouldn't been used if there is a possibility to enter the dangerous area. In this case an external acknowledgement device must be used.


Design Features

  • The contacts of the emergency stop buttons and the safety door need to be designed mechanically in accordance with EN 60947-5-1 appendix K.
  • PSD must be located in a protected area (IP54 control cabinet). Outside this protected area, the line guiding to the external switches must be separated channelwise or must be especially protected.


Calculation of the total failure probability

The failure probability of each of the two STO circuits of the servo drive is 1.0E-09 per hour. When calculation the overall failure probability further components of the complete machine such as contacts of the safety door must be considered.

Due to the hardware monitoring in the PSD servo drive, only a medium level of diagnostic coverage DC for the external contacts can be set.


STO function test

The STO function must be checked in the event of:

  • Commissioning
  • After each exchange of any equipment within the system
  • After each intervention into the system wiring
  • In defined maintenance intervals (at least once per week) and after a longer standstill of the machine
    If the STO function was triggered by opening a protective door and if this door is opened several times a week, the weekly testing interval is not required.

The check must be made by qualified personnel adhering to all necessary safety precautions.

The following testing steps must be performed:
STO Test | Action, activity | Expected reaction and effect
1 | 24 VDC voltage on Connect terminal X17.12* and X17.16* Apply 0 VDC voltage to terminal X17.14* |
2 | Switch on supply power and 24 VDC supply voltage | No error must be present
3 | Configuring the device | No error must be present
4 | Testing active STO on terminal X17.12 and X17.16: Simultaneous removing of 24 VDC on terminal X17.12 and X17.16* | Active STO must be displayed via LED or fieldbus.** No error must be present if object STO_Setup=0. Error message 0x5492 if object STO-Setup=1.
5 | Apply again 24 VDC voltage to terminal X17.12 and X17.16 and acknowledge STO afterwards* | No error must be present; torque at the motor should be present.
6 | Then switch off and on again 24 VDC voltage supply. | No error must be present

* The same test with terminals X21.12 & X21.16 & X21.14 is necessary for two or three axis controllers.

** With two or three axis controllers STO status for all motors should apply.

A manual check of the torqueless drive is here also sufficient.

The triggering of the STO can also be made by actuating the emergency stop switch. During the automated test, the STO can also be triggered via the contacts of an external relay

Following the test steps

Once all of the relevant safety test steps have been accomplished, the actions taken must be documented. A protocol specimen can be found in the following section.

Depending on the machine version, additional or other test steps may be required.


STO test protocol specimen

Project/machine:
Name of the tester:
Servo axis:
Settings STO_Setup:
STO function test: |
STO function test steps 1-6: | o successfully tested
Safe stop 1: | o successfully tested o is not used
Initial acceptance on: | Repeat check on:
Signature of the tester | Signature of the tester


Technical data STO

Category

Specifications

STO

Certificate

According to EN ISO13849

Device certified if “STO certified” is stated in type plate (below the CE sign)

Nominal voltage of the inputs

24 VDC

Required isolation of the 24V control voltage

Grounded protective extra low voltage, PELV

Fuse protection

Protection of the STO control voltage: 1 A

Number of inputs

Signal inputs via optocoupler

2

Low = 0 ... 5 V DC or open

High = 15 ... 26.4 VDC

Iin at 24 VDC: 9 mA +/-1 mA

STO Input A, Level

Low or open = STO activated

High = STO deactivated

Reaction time max. 5 ms

STO Input B, Level

Low or open = STO activated

High = STO deactivated

Reaction time max. 5 ms

Switch-off time

Switch-off time with unequal input statuses: 10 s (max. error response time)

During the inequality, it is ensured within 5 ms that the motor torque is switched off single-channel.

Maximum tolerable test pulse time

Maximum tolerable test pulse time (low active) for external safety control:

1 ms

Grouping of safety level
  • Category 3
  • PL=e
  • SIL 3
  • PFHd=1.00E-9 per STO circuit
  • Mission time: 20 years
  • MTTFd = 800 years (when using EN ISO 13849-1 the MTTFd value must be limited to 100 years)


PSD Servomanager quick start

In this chapter you can read about:

Installation

Quick start - move idle motor with test profile

Select functions

Data exchange PSD - ServoManager - Overview


Installation

Supported operating systems:

  • MS Windows 10
  • MS Windows 11

MS.NET 4.8 (32 bit) is necessary for each program.

Installing the PSD ServoManager is not required

  • Copy the contents of the file “PSD_ServoManager.zip” to any desired file (not in the file “programs”) of your local PC drive.
  • Start the PSD ServoManager by running the “PSD ServoManager.exe” file.


Quick start - move idle motor with test profile

In this chapter you can read about:

Animation - Network address setting on PC

Scan network connection and select PSD

Animation - minimum configuration

Animation - move idle motor with test profile

A further video can be found on the Internet. "How to setup the Parker Servo Drive PSD".


Animation - Network address setting on PC

Bellow you will see how to set up the PC network card for the communication with PSD.

When working in a network you will need an additional network connection (e.g. USB-Ethernet adapter)

Please observe that the IP address of the network card is configurated here and that it must distinguish from the addresses of the connected PSD.


Scan network connection and select PSD

Scan and select PSD device

1 | Activate network scan via the configured network interface.
2 | Select the appropriate device. Various devices may appear if they are connected to the PC via a network switch, for example.
3 | Activate the appropriate device.

There will be a query [image] if you desire an upload:

Behavior at:

Yes | An upload of PSD with the device data and configuration data is carried out.
No | ServoManager sets the IP address of the selected device. Device data are not uploaded.

Another device connected via a 2. network card (e.g. PAC & PSD) is only found if it is located in another network range (both devices must not have the address 192.168.10.x).


Animation - minimum configuration

First establish the Ethernet connection between PSD ServoManager (PC) and PSD.


Animation - move idle motor with test profile


Parker Servo Drive

Vorige Seite

Nächste Seite

Select functions


Data exchange PSD - ServoManager - Overview

Funkcion | Data | Direction
Load Device information "Do PSD online device identification" under "Device Identification" | Drive Configuration for information purposes only; data are not imported to the project if they are new and untreated. | PC <== PSD
Selection of devices "Use connected PSD device" "Device Selection" | Drive Configuration Drive data are not imported to the project. | PC <== PSD
Scan network connection and select PSD | Dialogue with 2 possibilities: If "No" Only IP device address is imported; device is not connected with ServoManager. If "Yes" Complete upload: Device and configuration data are downloaded from PSD to the actual project | PC <== PSD
Upload from PSD | Complete upload: Device and configuration data are downloaded from PSD to the actual project | PC <== PSD
Download to PSD | Complete - download: Actual project (device and configurations data are downloaded to the connected PSD. | PC ==> PSD


Device configuration

In this chapter you can read about:

Connection to the device

Port settings

Device information

Selection of device

Devices - Settings

Configure fieldbus

Configure feedback

Devices - functions

Select "Device" for basic adjustments:


Connection to the device

In this chapter you can read about:

Animation - Network address setting on PC

Scan network connection and select PSD

Ethernet connection to the device is made under "Device Connection" in the navigator:

To activate the function please click on the link underlined in blue!

Functions

1 | Change net adapter settings The PC Ethernet interface for PSD connection is configured via this function. To do so, the appropriate function in Windows system control is called (system control\network and Internet\network connections).
2.3 | Scan and select PSD device After an Ethernet interface to the PSD has been configured (see point 1) and the PSD (X60) has been connected to a network cable, PSD ServoManager scans the interface for connected PSD devices. Set the address of the connected PSD to a defined value.
4 | Change TCP/IP target address Here you can name the IP address of the PSD. You can store multiple IP addresses with names in a list to simplify address selection.
5 | Here you find the address and port of the actually connected and active PSD.


Port settings

The default IP address, SubNetMask, and Gateway IP addresses of the PSD configuration port (X60) [1] and the FBI Ethernet port (X61 / X62) [2] can be changed:

In addition, the changed IP address can be used as the IP address range (the last part of the IP address is selected by the address switches).

The default application port 44821 can also be changed to another value.


Device information

Here you can read the device data (no configuration data) of the connected and selected device. These data serve for information; they are only imported into the actual project if no entries were made so far.

The function "Device Selection" loads the device data into the actual project.


Selection of device

For the selection of the devices two possibilities exist:

1

Selection of the device by means of a Wizard.

All ratings of the device are queried.

Will be applied if for example no PSD is connected however you want to create a project.

2

Selection of the connected device.

  • Make sure it is connected.

The device date are used for the actual project.

Configuration data ( [image] Axis tree) remain.

Contrary to the function "Device information", at which the device date are for information purposes and which do not change the actual project.


Devices - Settings

Here you will find the basic settings of the device.

Preferences:

  • mains supply
  • the desired reaction of the STO and
  • SafeStopMode (only for PSD with FSoE)

For PSD1-S, the braking resistor can be configured here:

  • Select the external braking resistor from the PSD accessories or
  • under "User Defined", configuration of any braking resistor taking into account the limit values for braking mode with the following information:
    • Resistor [Ohm]: Resistance value
    • Rated power [W]: Nominal power
    • Max Power Ratio [%]: peak power ratio / nominal output

PSD PLC programmability

  • Disable programmability: "True" turns the programmable "C" device into "B" device; "false" switches back to a "C" device.
  • PLC Cycle Time Jitter: Maximum deviation of the cycle time (in % of program cycle time).


Configure fieldbus

The fieldbus can be configured in ServoManager via Interface option "2".

Select the desired fieldbus:

Settings are valid after a configuration download and well as after power off/on (24 VDC).


Configure feedback

The feedback option "2" (Multi-Feedback) can be used to configure the feedback system in the ServoManger.

For multi-axis devices, all connected motors must be equipped with the same feedback.

If the feedback system is not known, you can first set "NoFeedBack" and select the motor in the axis configuration (axis 1 for multi-axis devices) under motor.

The feedback will then be set accordingly.

Select the desired configuration of the feedback here:

  • Hiperface DSL
  • Resolver
  • Incremental encoder with 1 V peak - peak sine signal 1)
    with additional commutation information from:
    • digital Hall signals (e. g. with Parker LXR Linear Motors) or
    • the automatic commutation function
  • Incremental Encoder with rectangle signal and spur A/B 1)
    with additional commutation information from:
    • digital Hall signals or
    • the automatic commutation function
  • Analog Hall encoder with 1 V peak - peak sine signal 1)

Input window:

Settings are valid after a configuration download as well as after power off/on (24 VDC).

Due to an incorrectly configured feedback system, the connected feedback system can be destroyed by overvoltage!

New multi feedback devices are always configured with "NoFeedBack”!

Procedure when changing the feedback system.
  • Switch off PSD, disconnect system
  • Switch on PSD and configure the desired feedback system.
  • Switch off PSD and connect new feedback system.
  • Switch on PSD ==> feedback system active.

1) in the 1st setup level only for PSD1-S and PSD1MW11 (multi-axis devices with only one possible axis)


Devices - functions

In this chapter you can read about:

Diagnostics functions

Fieldbus - delete mapping (delete fieldbus mapping)

Clone device data on SD card

Copy SD card to target device

Copy SD card manually


Diagnostics functions

For device diagnostics, the error history can be loaded and displayed here.


Fieldbus - delete mapping (delete fieldbus mapping)

The mapping of all axes can be deleted here.


Clone device data on SD card

With this function, the complete settings of the device can be stored on an external SD card.

It can serve as back-up or for duplicating a device configuration, e.g. when exchanging devices.

By delivering the devices with the SD card described, it is possible to simply exchange devices at a later time at customer’s site.

Copy device settings on SD card:

Before duplicating the SD card, format it.

Therefore store all data of the SD card.

Requirement:

  • Motor not energized!
  • Supported SD cards:
    • <= 32 GB.
    • SD, SDHC, SDXD (up from V01.04.01) with compliant FAT32 Formatting.
      We recommend to utilize the tool "SD Card formatter 4.0“ of the SD association.

Procedure

  • Push SD card in the SD slot C11 on the front face.
  • Connect the device with the PC via PSD ServoManager.
  • The copy procedure is started by “Device: Device Functions: Clone Drive to SD-Card”.
    • Before duplicating the SD card, format it.
    • The firmware is copied.
    • The configuration is copied.
    • The system description is copied.
    • Start-up files for copying to the target device are written on the SD card.


Copy SD card to target device

Requirement:

  • The target device must be equal to the original device with which the SD card was created (same order code).

Procedure:

  • Push SD card in the SD slot C11 on the front face of the target device.
  • Set address switch of the front plate to address 0xfd (S12=f; S13=d). (Keep in mind field address set)
  • Switch on (respectively switch off and on) control voltage 24 VDC.
    LEDs (P14 ... P16) are flashing irregularly.
  • Drive is booting from the SD card and loads files.
  • After the successful cloning LEDs (P14 ... P16) are alternately flashing in green
  • In case a problem occurred, LEDs (P14 ... P16) are alternately flashing in red.
    The drive returns to the status prior to the copying and writes a new Log file (LogFile.txt) with a problem description on the SD card.
  • Reset the address switch of the front plate to the previously set address.
  • Control voltage 24 VDC on/off.

Now, the new drive is a copy of the initial one.

In case motor feedback (e.g. device exchange) has the same serial number, reference positions are copied as well, otherwise not (axis is set to not referenced).


Copy SD card manually

SD card data can be copied manually.

A correct formatting is required.
In this case, the formatting with Windows is not sufficient (faulty).

We recommend to utilize the tool "SD Card formatter 4.0“ of the SD association.

Recommended settings under “option":

Afterwards, the SD card has a FAT32 file system compatible to the PSD.


Axis configuration

In this chapter you can read about:

Axis n: Axis information

Motor data

Reference system

User Unit Wizard page

Inertia

Limit values

Machine Zero

Travel Limit Settings

Ramps and positionining settings

Digital inputs and outputs (configuration)

Ethernet IP configuration

Selection of Axis 1; resp. if available Axis 2 or Axis 3.


Axis n: Axis information

Axis information of Axis 1.

Assign an axis name under "Axis Name".


Motor data

1

Read the motor characteristics of the electronic motor type plate (if available.
Supported are Parker motors as for example SMH(A), SME(A), MH(A), ME(A), NX, NV, EX, EY, MPP, MPJ and MPM.

Functions only possible with Hiperface DSL® Feedback!

2

Load Parker motor from the integrated motor library
The selection of Parker motors is limited to motors with configured feedback system.Please observe

that some motors do not reach rated speed when operating with PSD:

EX motor, EY motor, NK motor, NV motor, NX motor

Motors

Supply
[VAC]

nNominal motor

[rpm]

nMax PSD

[rpm]

NX310ExPxxxxx | 230 | 2300 | 2235
NX420ExPxxxxx | 230 | 2300 | 2297
NX430ExPxxxxx | 230 | 1700 | 1683
NX620ExRxxxxx | 230 | 2200 | 2177
NX630ExVxxxxx | 230 | 750 | 726
NX860WxDxxxxx | 230 | 2600 | 2321
NX860WxFxxxxx | 230 | 2000 | 1867
NX420ExVxxxxx | 400 | 2000 | 1980
NX620ExVxxxxx | 400 | 2000 | 1995
NX630ExVxxxxx | 400 | 1350 | 1321
NX860WxDxxxxx | 400 | 4400 | 4176
NX860WxFxxxxx | 400 | 3750 | 3367

Motors

Supply
[VAC]

nNominal motor

[rpm]

nMax PSD

[rpm]

NV420ExIxxxxx | 230 | 7500 | 7414
NV420ExJxxxxx | 230 | 6900 | 6858
NV430ExHxxxxx | 230 | 6320 | 6193
NV620ExJxxxxx | 230 | 6320 | 6027
NV630ExIxxxxx | 230 | 5750 | 4872
NV820ExNxxxxx | 230 | 5180 | 4894
NV840ExJxxxxx | 230 | 4600 | 3906
NV860VxCxxxxx | 230 | 5180 | 4145

Motors

Supply
[VAC]

nNominal motor

[rpm]

nMax PSD

[rpm]

NK310ExPxxxxx | 230 | 2300 | 2212
NK420ExPxxxxx | 230 | 2300 | 2297
NK420WxOxxxxx | 230 | 2300 | 2091
NK430ExPxxxxx | 230 | 1700 | 1683
NK430WxLxxxxx | 230 | 2300 | 1977
NK620ExRxxxxx | 230 | 2240 | 2178
NK630ExVxxxxx | 230 | 750 | 726
NK420ExVxxxxx | 400 | 2000 | 1980
NK420WxOxxxxx | 400 | 4000 | 3810
NK430WxLxxxxx | 400 | 4000 | 3607
NK620ExVxxxxx | 400 | 2000 | 1995
NK630ExVxxxxx | 400 | 1350 | 1321

Motors

Supply
[VAC]

nNominal motor

[rpm]

nMax PSD

[rpm]

EY310ExPxxxxx | 230 | 2300 | 2227
EY420ExPxxxxx | 230 | 2300 | 2249
EY430ExLxxxxx | 230 | 2300 | 2278
EY620ExRxxxxx | 230 | 2200 | 2195
Motors | Supply [VAC] | nNominal motor [rpm] | nMax PSD [rpm]
EX310ExPxxxxx | 230 | 2300 | 2264

3

Import motor from file

4

Export motor into file

5

Edit motor (customer motor)

6

Selection of a further operating point: e.g. for an additional ambient temperature.
This operating point is defined by the motor manufacturer

7

Specification of an application-specific operating point.

This is defined via the reference current and the reference speed and must be enabled via "Reference Point Active = True".

The reference current is limited to 1.33 * stall current of the selected operating point (5) and the reference speed to the maximum motor speed (maximum motor speed for linear motors).

8

Selection of the motor version with respect to the moment of inertia.

Some motors are offered with different moments of inertia (Standard / Medium / High).

9

Displays and information on the motor temperature sensor: Type and preset motor temperature error threshold, setting the threshold and reaction of the overtemperature warning (display only if a sensor is installed, settings for warning only for KTY83, KTY84 and PT1000 sensors).

10

configuration of the motor output choke

11

The motor parameters are displayed here.

If a further operating point (below 5) is selected, the data of this operating point are displayed (possibly lower currents at higher ambient temperatures).

12

The rated motor points defined for the motor at different supply voltages are displayed here.

13

Type of posiion sensor

14

Data of motor holding brake

Motor characteristics are necessary for various settings. They can be read directly from the electronic motor type plate.


Turning the motor holding brake on and off

The servodrive controls the holding brake of the motor and the power output stage. The time behavior can be set.

Application:

In the case of an axis which is at a standstill under torque (e.g. a z-axis), the drive can be switched on and off in such a way that the load does not move. The drive thereby remains energized during the holding brake response time. This is adjustable.

Output stage is deactivated by:
  • Error or
  • control word (xxxx xxxx 0xxx 0111)
  • the ServoManager

The motor is then decelerated to speed = 0 at the set ramp.

At speed = 0, the motor is de-energized with the delay “close brake delay time".

1 | Motor energized
2 | Motor de-energized
3 | Open brake
4 | Engage the brake
5 | Brake delay time for closing object 0x30CA.0; in the PSD ServoManager under configuration: Motor: Edit Motor

The power output stage is enabled by:
  • Quit (after an error) (control word Bit 7 edge of 0==>1) via the control word (xxxx xxxx: xxxx: 1111)
  • the ServoManager
  • Via the control word

The motor is energized immediately; a setpoint is only enabled after the brake has been fully released. Configurable via 0x30C9.0 “open brake delay time".

1 | Motor energized
2 | Motor de-energized
3 | Signal “open brake"
4 | Signal “close brake"
5 | Open brake delay time object 0x30C9.0; in the PSD ServoManager under configuration: Motor: Edit Motor After this time the setpoint is enabled which is indicated by the status word Bit 2=”1”.


Optimize automatic commutation

In this chapter you can read about:

Prerequisites for the automatic commutation

Timeout of auto commutation

Another prerequisite for a good control quality is the correct motor commutation of the motor.


Prerequisites for the automatic commutation

  • A movement of the motor must be permitted. The movement actually occurring depends greatly on the motor (friction conditions) itself, as well as on the load moved (inertia).
  • Applications requiring a motor brake, i.e. applications where active load torques are applied at the motor (e.g. vertical actuator, slope) are not permitted.
  • Due to the function principle, high static friction or load torques will deteriorate the result of automatic commutation.
  • When performing automatic commutation, a motion of at least ±180° must be electrically possible (no mechanic limitation)! The implemented automatic commutation function with motion cannot be used for applications with limit or reversal switches.
  • With the exception of missing commutation information, the controller/motor combination is configured and ready for operation (parameters correctly assigned for the drive/linear motor). Feedback direction and effective direction of the field of rotation must be identical (automatic commutation performed in the MotorManager).


Timeout of auto commutation

The auto commutation is required for incremental encoders without absolute value information in order to find the correct relation of position and motor stator field.

Activate automatic commutation [image] under axis: Motor: Edit motor, in the editing window [image] in the section “commutation":

The auto commutation is performed after power on of the power output stage.

Please observe that the motor carries out small movements (max. ±90° electrical at rotative motor resp. ±0,5 pitch with linear motor).

  • In case an error appears during auto commutation the power output stage is deactivated and an error message created.
  • Causes and measures can be found in error description.
  • Auto commutation can be optimized via [image] objects in the optimization window.

    1

    Activate window optimization objects

    2

    Edit objects (by clicking on the value)

    3

    Load optimization-objects from connected devices

    4

    Menu for administration of optimization-objects

    • Select optimization-objects
      Standard: Most important objects to optimize drive
      Advanced: Extended selection of optimization-objects
    • Save actual setting of optimization-objects
    • Load actual setting of optimization-objects

    5

    Store objects in non-volatile device memory.

    6

    Take over objects (VP)

    7

    Error acknowledgement

    8

    Command line

    9

    Auto-tuning call. Detection of the inertia of load and setting of optimization objects for position and speed control
  • The auto commutation is reported after a new power on of the unsuccessful power output stage.
  • After successful determination of the commutation angle it is not carried any longer during power on of the power output stage.
  • The determined commutation remains valid until the control voltage (24 BDC) is switched off and therefore not guaranteed any longer that the determined commutation angle is still correct after an anew switching on.

The relevant objects are described below.


Reference system

The reference system defines the resolution and scaling of the position. The feed constant determines the internal resolution of the position. It is given in field bus increments per motor revolution or field bus increments per mm for the linear motor. The user unit allows the scaling of the target and status values to be set. The programmable device is programmed in user units in the CODESYS interface.

1

Field bus increments per motor revolution or Field bus increments per mm for linear motors

This value determines the internal resolution of the position.

You can provide the resolution as a fraction with numerator (0x6092.1) and denominator (0x6092.2).

Rotation direction reversal (Invert Motor Rotation)

Reverse direction (0x607E.0) inverts the sense of rotation, i.e. the direction of movement of the motor is reversed in the case of equal setpoint.

(see also the diagram below)

2

Distance per gear revolution

The position is specified and shown in the field bus increments per default. User units can be activated in the wizard via "activate and edit UserUnits".

Entering the user units as a fraction with numerator (0x3102.1) and denominator (0x3102.2).

Within the CODESYS environment, it serves as a scaling factor for the programmable "C" device. The ServoManager allows switching between UserUnits and (field bus) increments. The internal resolution of setpoints and actual values is still running in increments.

UserUnit

Name of the user unit as text (0x3102.3)

(see also the diagram below)

3

Gear revolution per motor revolution

Entering as a fraction (transmission ratio) with numerator (0x3100.1) and denominator (0x3100.2).

Within the CODESYS environment, it serves as a scaling factor for the programmable "C" device or simply for displaying target/actual values for a "B" device.

In normal cases, it is not required for a linear motor (GearRatio = 1/1)

(see also the diagram below)

4

Drive modulo

Numerator ¹ 0 and denominator ¹ 0 switches on the "Modulo" operating mode (reset mode).

5

Edit User Units

Enable/Enter UserUnits

6

Switch Incr/UserUnits

By the switch it can be determined whether the configuration of the controller is running in UserUnits or increments

The configuration of the user unit is described in chapter User Unit Wizard page.

Scaling/unit calculation of the position actual value

Side note: The reference value for the linear motor is mm (instead of revolutions).

1

The controller either provides the position values in increments or it supports user units. The setpoint (0x607A) from the fieldbus is always in increments.

If the controller supports user units, then the correspondingly same conversion (increments <==> user units) must be performed in the controller and in the PSD.

You can use this to work continuously with user units.

Internally, the target value is always specified in increments.

2

The motor revolutions (or mm for a linear motor) determine the increments (0x6064) via the given factor (=feed constant).

3

The revolutions on the gearbox output are determined via the gear ratio (0x3100) (for the linear motor, this factor is normally 1/1)

4

The reference to the user unit is established along the distance per gear revolution (0x3102).

5

The objects (0x3103) provide conversion factors from increments to user units and vice versa.


User Unit Wizard page

To represent the position in UserUnits, the distance per gear revolution (numerator/denominator), the gear revolutions per motor revolution (numerator/denominator) and the reset distance (drive modulo in numerator/denominator) can be defined. The user units are switched off per default and can be activated in the wizard via "Edit User Units".

1

Field bus increments per motor revolution or Field bus increments per mm for linear motors

This value determines the internal resolution of the position.

You can provide the resolution as a fraction with numerator (0x6092.1) and denominator (0x6092.2).

2

Distance per gear revolution

The position is specified and shown in the field bus increments per default. User units can be activated in the wizard via "activate and edit UserUnits".

Entering the user units as a fraction with numerator (0x3102.1) and denominator (0x3102.2).

Within the CODESYS environment, it is used as a scaling factor for the programmable "C" device. The ServoManager allows switching between UserUnits and (field bus) increments. The internal resolution of setpoints and actual values is still running in increments.

UserUnit

Name of the user unit as text (0x3102.3)

3

Gear revolution per motor revolution

Entering as a fraction (gear ratio) with numerator (0x3100.1) and denominator (0x3100.2).

Within the CODESYS environment, it is used as a scaling factor for the programmable "C" device or simply for displaying target/actual values for a "B" device.

In normal cases, it is not required for a linear motor (GearRatio = 1/1)

4

Drive modulo

Numerator ¹ 0 and denominator ¹ 0 switches on the "Modulo" operating mode (reset mode).

5

Reset values to default

Reset the UserUnit scaling - set to default values (distance per gear revolution = field bus increments per motor revolution)

6

Submit values

Transfer values into the configuration

7

Define new ratio

Calculating the feed constant based on freely adjustable factor of field bus increments/UserUnit (depending on the selected scaling of the user unit)

8

Resulting (Field bus) Increments per User Unit

Conversion factor User Units / (Field bus) increments, results from feed constant (field bus increments / motor revolution) and user units (distance per gear revolution)


Inertia

External inertia

The external inertia is required for adjusting the servo controller. The more accurately the moment of inertia of the system is known, the better is the stability and the shorter is the settle-down time of the control loop.

It is important to specify the minimum (min. inertia) and maximum inertia (max. inertia) for best possible behaviour under varying load.

Have the inertial determined automatically

If you do not know the inertia enter “Inertia is unknown” = true.

Starting values are set and you can execute the “auto-tuning” in the optimization window”.

Minimum moment of inertia / minimum load

Maximum moment of inertia / maximum load

Enter minimum = maximum moment of inertia when the load does not vary.


Autotuning

In this chapter you can read about:

Autotuning settings

Auto-tuning start

Auto-tuning result

Inertia (or load mass of linear motors) as well as friction (adhesive friction & viscous friction) can be detected automatically with this function.

For identification, the system must be activated by a test move.

The identified values can be used as follows:

  • The inertia (or the load mass) for optimizing position and speed control
  • The friction for compensation via the feed forward control channel (object 3822.E & object 3822.F)

Caveat emptor (exclusion of warranty)

Due to multiple possibilities for disturbing influences of a real control path, we cannot accept any liability for consequential damage caused by incorrectly determined values. Therefore it is essential to verify all values automatically determined before loading them into the control loop.


Autotuning settings

Once you have given the inertia under "Axis: Inertia/ext. load" as unknown, safe start values are set. In the optimization window, you can now activate the autotuning in the commissioning window as follows:

Movements in operating mode "commissioning" is monitored via Watchdog. In case a communication error occurs, movement is stopped immediately.

The State machine of the field buses is stopped during operating mode "Commissioning". It is displayed in the Status word by Bit ="0".

1 | Activate operating mode Commissioning "ON = green" = operating mode Commissioning active
2 | Activate the motor "ON = green" = motor energized
3 | Start the test movement set Right-click: Open input window to define test movement
4 | Select, define and start motion profiles. Available shortly!
5 | Manual mode active when button is pressed Right-click: Input window to define manual movement
6 | During the button is pressed, manual+ is active Right-click: Input window to define manual movement
7 | Activate machine zero run
8 | Stop movement
9 | With brake motors, brake can be operated manually.
10 | Auto-tuning call. Detection of the inertia of load and setting of optimization objects for position and speed control

External inertia

The external inertia is required for adjusting the servo controller. The more accurately the moment of inertia of the system is known, the better is the stability and the shorter is the settle-down time of the control loop.

It is important to specify the minimum (min. inertia) and maximum inertia (max. inertia) for best possible behaviour under varying load.

Have the inertial determined automatically

If you do not know the inertia enter “Inertia is unknown” = true.

Starting values are set and you can execute the “auto-tuning” in the optimization window”.

Minimum moment of inertia / minimum load

Maximum moment of inertia / maximum load

Enter minimum = maximum moment of inertia when the load does not vary.

  • Open commissioning window
  • Activate axis (1)

    1

    Activate the selected axis (in this case axis: 1)

    2

    Display: Watchdog active

    3

    Display: Status of the actual axis

    4

    Display: Motor powered

    5

    Display: Motor turns

    6

    Scope

    7

    Editing area for oscilloscope settings and optimization objects

    8

    Status Indicator

    9

    Commissioning window with various functions.

    10

    Only for programmable PSD: Start/stop of the PLC program, indicator of the state of the CODESYS runtime (start, stop, in breakpoint, in error)

    11

    Switch UserUnits/increments (The switch setting determines whether the objects in UserUnits or increments are displayed in the ObjectEditor and the Status Indicator)

    12

    Only for programmable PSD: CODESYS linked to PSD

  • Activate commissioning mode (1) & energize motor (2)
  • Open autotuning monitor (9)

Autotuning can be found in the optimization window at the bottom left:

.

1

Indicates that autotuning is ready to start

2

Start button to execute autotuning procedure

3

Selection how often the procedure shall be executed:

StandardPlantIdent (standard setting)

Up to 10 measurements are executed. The excitation signal is increased with each measurement; but the specified values for the test movement are not exceeded.

In case the detected values for inertia or load change only slightly, autotuning will be successfully finished.

SingleShotPlantIdent

One-time measurement without checking the values.

4

Values of the test movement (max. values)

5

Kind of test movement:

  • Absolute TestMovenent: In a fixed position range of the given distance (+/- 0.5x distance around the start position).
  • Relative TestMovement: Always in the same direction with the given distance.


Auto-tuning start

Safeguard the travel range before energizing!

Auto-tuning starts via the start button.

With auto-tuning start, the optimization parameter of position and speed control are set to standard values.

Drive carries out test move during auto-tuning.

Under bad conditions they can be jerking.

It is any time possible to interrupt auto-tuning via the stop / reset button or power off button!


Auto-tuning result

1

Detected values:

  • Inertia / Load: determined inertia (or last load for linear motors) of the the entire paths, motor & last.
  • Coulomb Friction: Adhesive friction as current which is required to overcome this.
  • Coulomb Friction: Viscous friction as current per speed which is required to overcome this.

2

For each detected value you can indicate whether it shall be taken over and then taken as base for the controller settings.

If there is a control path with different load ratios, you can determine the minimum and maximum inertia by means of 2 measurements and assign them to the values.

3

It can be interrupted here while auto-tuning is running.

4

The determined values will be accepted by set parameters (true: accept; false: do not accept).

The optimization parameters (stiffness, damping, Kp factor, Ki factor, Km factor) are reset to standard values!


Limit values

Values are entered in the area marked with "1"; partly as values, partly as values selection.


Machine Zero

Select the desired machine reference mode and enter the travel path area for homing run.

The machine zero modes are adapted to the CANopen profile for Motion Control CiADS402.

Selection of machine reference modes of operation:

Functional description of machine reference modes of operation

The digital inputs can be configured for the selected machine reference operating mode


Machine reference - position reference point

Position reference point

Essentially, you can select between operation with or without machine reference.

The reference point for the positioning is determined via the machine reference and the machine reference offset (in the PSD ServoManager homing mode: homing offset or object 0x607C0x00).


Machine reference offset (Homing offset)

Machine reference offset

"Homing offset" (0x607C.0x00) specifies the position of the homing signals.

For all positioning, zero position is the position 0.

When exceeding the homing signals, this position is set to the “homing offset” value.

A change in “homing offset” (0x607C.0x00) does not take effect until the next machine reference run.

Configuration is carried out in ServoManager.


Machine reference run (homing)

A machine reference run is normally (without absolute encoder) required each time after turning on the system for operation with machine reference.

There are 2 operating modes for the machine reference run (homing) which are configurable in PSD ServoManager (Homing mode: positioning target after homing or via object 0x345B.0x00):

1. Move to home offset = False (object 0x345B.0)

In Homing, the drive searches for the Homing condition, sets this value the same as the "Homing Offset" (in PSD ServoManager Homing Mode: homing offset or object 0x607C.0x00) and then moves to the "Homing position" (in PSD ServoManager Homing Mode: Homing position or object 0x3458.0x00).

2. Move to home offset = True (object 0x345B.0)

In Homing, the drive searches for the Homing condition, sets this value the same as the "Homing Offset" (in PSD ServoManager Homing Mode: homing offset or object 0x607C.0x00) brakes and then returns to the "homing offset" position.

Use this operating mode when working with PAM or CODESYS and SoftMotion in operating mode “Modulo”.

Homing operating modes in the diagram

The following diagram shows how to set the reference system during homing:

Please note:

During homing run the software end limits are not monitored.


Machine reference - velocity, acceleration & jerk

With these values you can define the motion profile of the machine zero run:

  • Velocity in unit/s of measurment (object 0x6099.0x01 & 0x6099.0x02)
  • Acceleration in unit/s of measurement2 & (object 0x609A.0x00)
  • Jerk (object 0x3459.0x00)

Jerk

Value | Meaning
0 or 1 | Filter switched off
2 ... 4096 | Middle filter switched on Averaging via the named cycles. One cycle are 500 µs. Only 2n values are permitted: 2, 4, 8, 16, 32, 64, ... 4096 Intermediate values are rounded down to the next 2n value. Please observe that the average time is £ of the effective acceleration time. If not, the filter effect will change.

Configuration is carried out in ServoManager.


Absolute reference system

In this chapter you can read about:

Absolute encoder

Multiturn emulation


Absolute encoder

Using a Multiturn absolute value sensor as feedback system, the absolute position can be read in over the entire travel range when switching on the drive. This means that a machine zero run is not necessary after the switching on (feedback may not be shifted by the absolute range while switched off).

In this case the reference only needs to be established once

  • at initial commissioning time,
  • after replacing a motor / encoder
  • after a mechanical modification and
  • after an device exchange; does not apply for the "save absolute position in encoder" function.
  • after a configuration download

by carrying out a machine zero run.

The homing mode 37 "MN at the current position" is appropriate for this, because it is therewith possible to operate without proximity switch, but any other homing mode is possible too - if the hardware prerequisites are fulfilled.

When you have once re-established the reference, reset the machine zero run mode to "without machine zero run".


Save absolute position in encoder

Application: Device exchange without subsequent new referencing by homing.

Note: Function only available with Hiperface DSL encoder

After successful homing, the absolute position is stored in the encoder at the next power on (24 VDC) and later reloaded by the encoder after each power on. It is checked whether the position is within the absolute range of the encoder; if it is outside this range, the error “homing invalid" is triggered.

As a result, the absolute position is also known even after device exchange and a new referencing is not necessary.

The function is activated in the PSD ServoManager or via object 0x3122.0x1:

The writing of the absolute position to the encoder can also be triggered manually:

Object 0x3122.0x2 = 2 activates a single write process and the absolute position is stored in the encoder at the next power on (24 VDC).

Application:

With power on, the position at the last successful homing is read from the encoder; if it is outside the window, the homing position is invalid. To avoid this, the encoder position can be written manually before switching off. Alternatively, e.g. in the case of a rotary table, the application can always approach the same window before switching off.


Multiturn emulation

With the multiturn emulation, the function of a multiturn encoder can be simulated over the entire travel range. A singleturn encoder is sufficient as a feedback signal from the motor (position signal only for one revolution).

Condition:

The motor may not be moved by more than half a turn with the drive (24 VDC) switched off - otherwise the absolute position is lost.

Function

  • The Multiturn emulation offers the same function as the physical Multiturn feedback.
  • The Multiturn emulation can be activated In the PSD ServoManager under the axis: Homing Mode:
    Homing multiturn emulation = TRUE
  • You can assign the maximum permissible motor angle via the "Multiturn emulation window".
  • If the drive detects after switching on that this value has not been exceeded, then “Referenced” (0x3301.00 = “1”) is set; a homing run is not necessary.
  • In case the multiturn validity window “homing multiturn emulation window” has been exceeded after switching on, a new homing run is required (not referenced ==> 0x3301.00= “0”).

Personal damages and material damages may occur!

If the axis has been turned by more than one motor revolution with the drive switched on (24 VDC), this cannot be detected by the drive ==> the referencing to the mechanics is then not longer correct.

Please take the following security precautions:

  • Carry out new referencing after power failure.
  • Secure the danger area (e.g. by a safety fence)
  • In the event of a power failure, take precautions to ensure that the 24V DC control voltage is available until the drive stops.
  • In rotary table applications with a travel range of one revolution, the problem does not exist if you set the multiturn validity window "Homing multiturn emultion window" to 180°.


Machine zero modes overview

Selection of the machine zero modes (MN-M) (object 0x6098.0x00)
Home sensor on X17/21 (X17: Control voltage 24V, STO, digital inputs/outputs (PSD1-S), X17: Digital Inputs / outputs Axis 1 & 3 (PSD1-M), X21: Digital Inputs / outputs Axis 2 & 3 (PSD1-M)): MN-M 3 ... 14, 19 ... 30 | Without motor reference point MN-M 19 ...30 | without direction reversal switches: MN-M 19, 20, MN-M 21, 22
 |  | with direction reversal switches: MN-M 23, 24, 25, 26, MN-M 27, 28, 29, 30
 | With motor reference point MN-M 3 ... 14 (possibly an initiator adjustment is required) | without direction reversal switches: MN-M 3, 4, MN-M 5, 6
 |  | with direction reversal switches: MN-M 7, 8, 9, 10, MN-M 11,12,13, 14
Without home sensor: MN-M 1, 2, 17, 18, 33 .. 37, UserMode01 / 02 | Without motor reference point MN-M 17, 18 | MN-M 37: at current position
 |  | With limit switch as machine zero (MN): MN-M 17, 18
 |  | Only motor reference: MN-M 33, 34
 |  | With limit switch as machine zero (MN): MN-M 1, 2
 |  | while moving to block: UserMode01 / 02

Configuration of machine zero mode is carried out in ServoManager

Definition of terms / explanations:

Motor zero point:

Zero pulse of the feedback system

Motor feedback systems such as resolvers or SinCos© / EnDat give one pulse per revolution.

Some motor feedback systems of direct drives do also have a zero pulse, which is generated once or in defined intervals.

By interpreting the motor zero point (generally in connection with the machine zero initiator) the machine zero can be defined more exactly.

Home sensor:

For creating the mechanical reference

Has a defined position within or on the edge of the travel range.

Configure a diigital input as home sensor.

Direction reversal switches:

Initiators on the edge of the travel range, which are used only with a machine zero run in order to detect the end of the travel range.

During operation, the direction reversal switches are often used as limit switches.

Configure two digital inputs as direction reversal switches.

Example axis with the initiator signals

1: | Direction reversal / end switch on the negative end of the travel range (the assignment of the reversal / end switch inputs to travel range side can be changed).
2: | Home sensor (can, in this example, be released to 2 sides)
3: | Direction reversal / limit switch on the positive end of the travel range (the assignment of the direction reversal / end switch inputs to travel range side can be changed).
4: | Positive direction of movement
5: | Signals of the motor zero point (zero pulse of the motor feedback)
6: | Signal of the home sensor (without inversion of the initiator logic).
7: | Signal of the direction reversal resp. limit switch on the positive end of the travel range (without inversion of the initiator logic).
8: | Signal of the direction reversal / resp. limit switch on the negative end of the travel range (without inversion of the initiator logic).
9: | Signal of the home sensor (with inversion of the initiator logic).
10: | Signal of the direction reversal resp. limit switch on the positive end of the travel range (with inversion of the initiator logic).
11: | Signal of the direction reversal / limit switch on the negative end of the travel range (with inversion of the initiator logic).
12: | Logic state of the home sensor (independent of the inversion)
13: | Logic state of the direction reversal resp. limit switch on the positive end of the travel range (independent of the inversion)
14: | Logic state of the direction reversal resp. limit switch on the negative end of the travel range (independent of the inversion)

The following principle images of the individual machine zero modes always refer to the logic state (12, 13, 14) of the initiators.


Activate homing run (Homing)

A falling edge terminates homing.

Digital inputs can be used as

  • machine zero sensors,
  • as turning proximity switch
  • and as limit proximity switch

.

Assignement of the function is done in ServoManager.

For the individual inputs debouncing times can be assigned and logic levels can be changed.


Machine reference - Modes of Operation

In this chapter you can read about:

MN-M 1,2: Limit switch as machine zero

MN-M 3,4: MN-Initiator = 1 on the positive side

MN-M 5,6: MN Initiator = 1 on the negative side

MN-M 7...10: Direction reversal switches on the positive side

MN-M 11...14: With direction reversal switches on the negative side

MN-M 17,18: Limit switch as machine zero

MN-M 19,20: MN-Initiator = 1 on the positive side

MN-M 21,22: MN Initiator = 1 on the negative side

MN-M 23...26: Direction reversal switches on the positive side

MN-M 27...30: With direction reversal switches on the negative side

MN-M 33,34: MN at motor zero point

MN-M 35: MN at the current position

MN-M 37: HM (homing mode) at the current position with offset

User-MN-M 01/02: Current increase while moving to block

Utilize mechanical end position as limit and reversal initiator

Adjusting the machine home sensor


MN-M 1,2: Limit switch as machine zero

End switch on the negative side:

1: Motor zero point

2: Logic state of the direction reversal switch

End switch on the positive side:

1: Motor zero point

2: Logic state of the direction reversal switch


MN-M 3,4: MN-Initiator = 1 on the positive side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (left of the MN initiator) and one range with activated MN initiator (right of the MN initiator).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the positive travel direction.

With motor zero point, without direction reversal switches

MN-M 3: The 1st motor reference point with MN initiator = "0" is used as the MN.

MN-M 4: The 1st motor reference point with MN initiator = "1" is used as the MN.

1: Motor zero point

2: Logic state of the home switch


MN-M 5,6: MN Initiator = 1 on the negative side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 continuous ranges: one range with deactivated MN initiator (positive part of the travel range) and one range with activated MN initiator (negative part of the travel range).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the negative travel direction.

With motor zero point, without direction reversal switches

MN-M 5: The 1st motor reference point with MN initiator = "0" is used as the MN.

MN-M 6: The 1st motor reference point with MN initiator = "1" is used as the MN.

1: Motor zero point

2: Logic state of the home switch


MN-M 7...10: Direction reversal switches on the positive side

With motor zero point, with direction reversal switches

Machine zero modes with a home switch which is activated in the middle of the travel range and can be deactivated to both sides.

1: Motor zero point

2: Logic state of the home switch

3: Logic state of the direction reversal switch


MN-M 11...14: With direction reversal switches on the negative side

With motor zero point, with direction reversal switches

Machine zero modes with a home switch which is activated in the middle of the travel range and can be deactivated to both sides.

1: Motor zero point

2: Logic state of the home switch

3: Logic state of the direction reversal switch


MN-M 17,18: Limit switch as machine zero

1: Logic state of the direction reversal switch


MN-M 19,20: MN-Initiator = 1 on the positive side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (left of the MN initiator) and one range with activated MN initiator (right of the MN initiator).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the positive travel direction.

Without motor zero point, without direction reversal switches

MN-M 19: The negative edge of the MN proximity switch is taken directly as MN (the motor zero point remains without consideration)

MN-M 20: The positive edge of the MN proximity switch is used directly as MN (the motor zero point remains without consideration)

1: logic state


MN-M 21,22: MN Initiator = 1 on the negative side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 continuous ranges: one range with deactivated MN initiator (positive part of the travel range) and one range with activated MN initiator (negative part of the travel range).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the negative travel direction.

Without motor zero point, without direction reversal switches

MN-M 21: The negative edge of the MN proximity switch is taken directly as MN (the motor zero point remains without consideration)

MN-M 22: The positive edge of the MN proximity switch is used directly as MN (the motor zero point remains without consideration)

1: logic state


MN-M 23...26: Direction reversal switches on the positive side

Without motor zero point, with direction reversal switches

1: Logic state of the home switch

2: Logic state of the direction reversal switch


MN-M 27...30: With direction reversal switches on the negative side

Without motor zero point, with direction reversal switches

1: Logic state of the home switch

2: Logic state of the direction reversal switch


MN-M 33,34: MN at motor zero point

The motor reference point is now evaluated (no MN initiator):

Without home switch

MN-M 33: For a MN run, starting from the current position, the next motor zero point in the negative travel direction is taken as the MN.

MN-M 34: For a MN run, starting from the current position, the next motor zero point in the positive travel direction is taken as the MN.

1: Motor zero point


MN-M 35: MN at the current position

Complies with MN-Mode 37, for new applications please use mode 37.


MN-M 37: HM (homing mode) at the current position with offset

The current position when the MN run is activated is used as an MN.

Please note:

  • A homing offset is possible.
    After "Setting homing position" the following applies
    Position actual value 0x6064) = Home offset (0x607C)
  • Homing is possible under the following circumstances:
    • Operation enable
    • Switch on disable
    • Fault (Error is present)
  • Due to encoder noise it is possible that a value <> 0 is set when teaching to 0.
  • If end limits = 0, an end limit error may occur during homing run.


User-MN-M 01/02: Current increase while moving to block

Without a MN (machine zero) initiator, an end of travel range (block) is used as MN (machine zero).

The actual current is evaluated when the drive presses against the end of the travel range. If the configurable threshold “Homing current limit” (0x345C.02 in per thousand of the rated motor current) is exceeded in the PSD ServoManager under axis: Homing mode, machine zero is set. During the homing run (MN), the error reaction "following error" is deactivated.

The machine zero offset must be set so that the zero point (reference point) for positioning lies within the travel range.

User-MN-M01: Travel in the positive direction to the end of the travel range

User-MN-M02: Travel in the negative direction to the end of the travel range

Caution!

Wrong settings can cause hazard for man and machine.

It is therefore essential to respect the following:

  • Choose a low machine zero speed.
  • Set the machine zero acceleration to a high value, so that the drive changes direction quickly, the value must, however, not be so high that the limit threshold is already reached by accelerating or decelerating (without mechanical limitation).
  • The mechanical limitation as well as the load handling must be set so that they can absorb the resulting kinetic energy.
  • With a bad feedback signal or high controller gain (fast controller or high inertia or mass) the machine zero might not be detected.
    In this case it is necessary to use the control signal filter or the velocity filter.


Utilize mechanical end position as limit and reversal initiator

Driving to the end position (or limit stop) can be utilized as spare initiator for the limit and reversal initiators of the individual machine zero modes.

The actual current is evaluated when the drive presses against the end of the travel range. If the configurable threshold “Homing current limit” (0x345C.02 in per thousand of the rated motor current) is exceeded in the PSD ServoManager under axis: Homing mode, machine zero is set. During the homing run (MN), the error reaction "following error" is deactivated.

The machine zero offset must be set so that the zero point (reference point) for positioning lies within the travel range.

The function is activated in the PSD ServoManager under the configuration: "Use mechanical end stop as homing limit switch" = true.


Adjusting the machine home sensor

This is helpful in some cases with homing modes that work with the home sensor and motor reference point.

If the motor reference point happens to coincide with the position of the home sensor, there is a possibility that small movements in the motor position will cause the machine reference point to shift by one motor revolution (to the next motor reference point).

Via status value “Distance home sensor - motor zero”, (0x3304.0x00) you can check if the distance between machine home sensor and motor zero point is too short.

1: Motor zero point

2: Logic state of the home switch

A solution to this problem is to move the home switch by means of software. This is done via the value "Homing zero event position adjustment" (object 0x345A.0x00).


Travel Limit Settings

In this chapter you can read about:

Software end limits

Hardware end limits


Software end limits

The error reaction when reaching the software end limits can be set in the ServoManager:

Possible settings for the error reaction are:

  • No response
  • Downramp / stop
  • Downramp / de-energize (standard settings)

If "no reaction" was set, no software limits must be entered.

Software end limits:

The travel range is defined via the negative and positive end limits (Configuration in the ServoManager).

1: negative end limit (object 0x607D.0x01)

2: positive end limit (object 0x607D.0x02)

Software end limit in absolute operating mode

The positioning is restricted to the range between the travel limits.

A positioning order aiming at a target outside the travel range is not executed.

1: negative end limit

2: positive end limit

The reference is the position reference point that was defined with the machine reference and the machine reference offset.

Error when disregarding the software end limits

A software end limit error is triggered, if the position value exceeds an end limit.
The position setpoint is evaluated when the axis is energized and the actual position value when it is de-energized.

Hysteresis in de-energized state:

If the axis is at an end limit in the currentless state, it is possible that errors are reported again by position jitter after the end limit error has been acknowledged. To avoid this, a hysteresis surrounding the end limits was integrated (size corresponds to the size of the positioning window).
Only if the axis was more than the positioning window away from the end limits, a new end limit error is detected.

Error codes of the end limit errors:

0x73A3 | Error when disregarding the positive software end limit.
0x73A4 | Error when disregarding the negative software end limit.

Activating / deactivating the end limit error:

The error can be (de)activated in the PSD ServoManager under configuration: end limits.

Behavior after power on

After power on, the end limits are not active. Only after a homing run do the end limits refer to the position zero point.

During homing run the end limits are not monitored.

With a Multiturn encoder or with active Multiturn emulation, the limits are valid immediately after switching on.

Behavior outside the travel range

1. If the software end limit errors are deactivated, all movements are possible.

2. If the software end limit errors are activated:

After disregarding the software end limits, an error is triggered. First of all, this error must be acknowledged.

Then a directional lock is issued: Only travel commands in the direction of the travel range are executed. These do not trigger another error.

Travel commands inciting a movement in the opposite direction of the travel range are blocked and will trigger another error.

Software-Endgrenzen Verhalten außerhalb des Verfahrbereichs

1: negative end limit

2: positive end limit

Behavior outside the travel range I12

Behavior with software end limits of a referenced axis

Position within
target outside

Position outside
target outside and aiming in the opposite direction of the travel range

Position outside
target within and aiming in the direction of the travel range

JOG +/-
  • Positioning up to the end limits
  • No error
  • No positioning
  • No error
  • Positioning

Positioning Mode
  • No positioning
  • Error
  • No positioning
  • Error
  • Positioning

Velocity Mode
  • Positioning up to the end limits
  • Error
  • No positioning
  • Error
  • Positioning


Hardware end limits

The error response when reaching the hardware end limits can be set in the ServoManager:

Possible settings for the error reaction are:

  • No response
  • Downramp / stop
  • Downramp / de-energize (standard settings)

Hardware end limits are realized with the aid of limit switches.

They are connected to the respectively configured input.

After a limit switch has been detected, the drive decelerates with the ramp values set for errors (error code 0x54A0 = positive limit activated; 0x54A1 = negative limit activated) and the motor is switched to currentless.

Please make sure that after the detection of the end switch there is enough travel path left up to the limit stop.

1: negative limit switch active

2: positive limit switch active

3: Limit switch position of negative limit switch

4: Limit switch position of positive limit switch

The allocation of the limit switch is configured in the PSD ServoManager

Please note:

The limit switches must be positioned in such a way that they cannot be released towards the side to be limited.

The limit switches are not active in the ServoManager's operating mode "commissioning".

Movements in operating mode "commissioning" is monitored via Watchdog. In case a communication error occurs, movement is stopped immediately.

The State machine of the field buses is stopped during operating mode "Commissioning". It is displayed in the Status word by Bit ="0".

1 | Activate operating mode Commissioning "ON = green" = operating mode Commissioning active
2 | Activate the motor "ON = green" = motor energized
3 | Start the test movement set Right-click: Open input window to define test movement
4 | Select, define and start motion profiles. Available shortly!
5 | Manual mode active when button is pressed Right-click: Input window to define manual movement
6 | During the button is pressed, manual+ is active Right-click: Input window to define manual movement
7 | Activate machine zero run
8 | Stop movement
9 | With brake motors, brake can be operated manually.
10 | Auto-tuning call. Detection of the inertia of load and setting of optimization objects for position and speed control

Limit switch / direction reversal switch

Limit switches functioning as direction reversal switches during the machine reference run will not trigger a limit switch error.

Behavior in the case of an active limit switch

The error can be acknowledged with activated limit switch.

The drive can then be moved out of the end switch range with a normal positioning.

The direction of the movement is verified.

Blocking of the hardware direction limit is only active if the PSD is operated in the operating mode DS402 or PROFIdrive (=> e. g. not in setup mode).

Only the direction towards the travel range is allowed.

Deviation in the behavior for certain DS402 operating modes

Cyclic sync position mode

The error recurs if the field bus target position increases compared to a saved reference target position*) in the reverse direction by more than the position window when switching to an "energized state".

Cyclic sync velocity mode / Cyclic sync torque mode

The error recurs if the drive actual position increases compared to a saved reference actual position*) in the reverse direction by more than the position window when switching to an "energized state"

*) This comparison position value for the identification is saved in the "switched on" status when ending "Error Powered" or when changing the operating mode, see also state transitions in the status diagram.


Ramps and positionining settings

Stop and error ramp as well as jerk for positioning and manual mode are specified here.

1 | Stop delay
2 | Eror delay
3 | Setting the motion data: Accelerations & decelerations
4 | Setting the motion data: Jerk
5 | Optional settings for positioning reset position mode (fontinuous mode) (object 0x60F2.0x00 Bit 15) Relative position options (object 0x60F2.0x00 Bit 0&1) Rotary axis direction options (input field only available if operating mode "Modulo" is activated.


Digital inputs and outputs (configuration)

The inputs can be assigned freely or to functions:

Additionally, the inputs can individually be debounced with a mutual input debounce time:


Ethernet IP configuration

Description:

1

Setting of the Field Bus operating mode (Operating mode: Profile Position Mode (Position control), Operating mode - profile velocity mode (speed control))

2

Activate and set size of the acyclic channel

3

Set data (Telegram layout) for the cyclic data exchange (window opens by clicking on the text)

4

Set error response on fieldbus failure:

Stop_drive_disable: | Quick Stop & then deactivate power output stage
Stop_drive_energized: | Quick Stop & then activate power output stage
Throw_warning: | Issue a warning; operating continues
No_response: | No error response

5

Length of the cyclic channel, for one direction each

6

Length of the communication channel - cyclic and acyclic data

7

Current mapping (set under 3) SPS => PSD

8

Current mapping (set under 3) PSD => SPS


Optimizing control loops

For the setup and optimization of the control loops, the optimization window is available.

The PSD control functionality is divided into 2 areas, standard and advanced; whereby the advanced functionality completely contains the standard functionality. The switching can be made in the optimization window.

Switching between standard and advanced

Inertia resp. mass of the load of linear motors as well as friction (adhesive friction & viscous friction) can be detected automatically.

Basic explanations for the control technology of the servo drives can be found in the appendix.

In this chapter you can read about:

Structure of the controller

Control signal limitations

Feed Forward

Position, velocity and acceleration filter

Proceeding during controller optimization


Structure of the controller

Regelungsstruktur PSD Link to PDF

  • The object numbers are shown in hexadecimal (index & subindex).
  • The addition "-i" stands for value in increments.
  • The description of the objects can be found in the object list as well as in the ObjectEditor in which you can read and write the current objects.
  • Basic explanations for the control technology of the servo drives can be found in the appendix.

Symbols of the control structure

Icon | Meaning
Proportionalglied | Proportional term signal is multiplied with Kp
Verzögerungsglied | Delay block 1. Order (P-T1 term)
Integrierglied | Integration block (I-block)
 | PI-block
Begrenzungsblock | Limitation block (signal limitation)
Addierglied | Addition block
 | Signum and sign functions The sign of the input signal is determined.
 | Dead zone Output value = 0 within a definable absolute input value range (value approx. 0)


Standard optimization parameters

The above figure shows the objects for the standard group. With the aid of these parameters, you can optimize the standard cascade structure.


Window Advanced - optimization objects

Switch to advanced.


Control signal limitations

In this chapter you can read about:

Limitation of the setpoint velocity

Limitation of the setpoint current

Limitation of the control voltage

The cascade structure shows that a limitation block is available in the control signal sector of each controller. The limitations of the position and velocity loops are calculated from the set limitations in the configuration and the motor parameters of the selected motor.


Limitation of the setpoint velocity

Limitation of the setpoint velocity in the control signal sector of the position loop:

This limitation value is calculated from the maximum mechanical velocity of the motor and the set value in the configuration in % of the nominal velocity. The smaller of the two values is used for the limitation.

Example

maximum mechanical velocity of the motor: | nmax=3100rpm
Rated speed of the motor: | nN=2500rpm

Max. Operating velocity: | nbmax=200% of nN => 5000rpm
Velocity limitation value = MIN(nmax, nbmax*nN/100)= | 3100rpm


Limitation of the setpoint current

Limitation of the setpoint current in the control signal sector of the velocity loop:

This limitation value is calculated from the device peak current, the pulse current of the motor and the set value in the configuration in % of the nominal current. The smaller of the three values is used for the current limitation.

Example

Device

Device peak current:

IGmax=10 Arms
Motor
Rated current of the motor: | IN=5.5Arms
Pulse Current: | Iimp=300 %IN
 | => 16.5Arms

Current (Torque) Limit: | Ibmax=200% of IN
 | => 11Arms
Current limitation value = MIN(IGmax, Iimp*IN/100, Ibmax*IN/100)= | 10Arms


Limitation of the control voltage

Limitation of the control voltage in the control signal sector of the current loop:

This limitation is fixed and cannot be influenced by the user. The limitation value depends on the DC voltage of the device.

Please note!

In the event of highly dynamic motion cycles it is necessary to make sure not to enter the control signal limitation (or, if so only for a very short time) as the drive is then not in the position to follow the set dynamics due to the slow drive physics and the limited control signal range.


Feed Forward

In this chapter you can read about:

Feedforward channels

Influence of the feedforward measures


Feedforward channels

The feedforward channels are used for the specific influence of the guiding behavior of a control. The calculated and evaluated status variables are coupled into the corresponding places within the controller cascade. In practice, the feedforward control offers the following advantages:

  • Minimal following error ("following error minimization")
  • Improves the transient response
  • Gives greater dynamic range with lower maximum current

The servo controller PSD has four feed forward measures (see standard cascade structure):

  • Revolution feed forward
    Source signal: speed
  • Acceleration feed forward
    Source signal: speed
    (not required/effective for structural factor km (0x3822.06) = 100%, inactive I-term speed controller (0x3822.04) or speed observer with load torque or load power switch on.)
  • Current feed forward
    Source signal: Acceleration
  • Jerk feed forward
    Source signal: Jerk
    (only required for PI current controller (EMC observer inactive (default: activated), see object 0x3812.0x0C) and if a target value jerk signal is present)

The above order represents at the same time the effectiveness of the individual feed-forward measures. The influence of the jerk feed forward may, depending on the profile and the motor, be negligibly small.

NB !

The principle of the feed forward fails with wrong parametrization (e.g. roughly incorrectly configured inertia or incorrectly configured last load) or signal limitations (e.g. Limitation of the motor current or the motor revolutions in the acceleration phase)!

Source target value signals during a positioning

Example development of the source target value signals during a positioning which is used as a source for the feedforward channels.

xws: | Position setpoint value of the setpoint generator
nws: | Speed setpoint - setpoint generator
aws: | Acceleration setpoint value setpoint generator
rws: | Jerk setpoint value set-point generator


Parker Servo Drive

Vorige Seite

Nächste Seite

Influence of the feedforward measures


Movement cycle without feedforward (current controller with EMC observer)

No feedforward

PSD new - no feedforward


Movement cycle with feedforward measures (current controller with EMC observer)

Note: Basis for representation is the PSD default controller structure (PI speed controller with km=0% and current control with EMC observer).

Revolution feedforward 100%

PSD new - revolution feedforward

Revolution and acceleration feedforward 100%

PSD new - revolution and acceleration FFW

Revolution, acceleration, and current feedforward 100%

PSD new - n a i FFW


Position, velocity and acceleration filter

The filters in the PSD firmware are implemented as P-T1 filters (first order deceleration component; time constant Tpt1).

Position and velocity filter

Position filter (Object 0x3832.5) and velocity filter (Object 0x3822.B) are set in % The preset filter constant can be checked in the objects

  • 0x3820.0x22 Tpt1-speed and
  • 0x3830.0x20 Tpt1-Position

.

Acceleration filter

The acceleration filter (0x3822.D) is shown in µs.

Please note!

It cannot be excluded that the settings of the filters may have a destabilizing effect. In this case, the filter time constant must be reduced.


Proceeding during controller optimization

In this chapter you can read about:

Main flow chart of the controller optimization

Controller optimization disturbance and setpoint behaviour (standard)

If the control behaviour is not sufficient for the present application, an optimization is required. We recommend the following approach.

Overview on the approach to setup + optimization

  • At first, the disturbance and set point behaviour of the velocity loop at standstill and at different displacement velocities is optimized (stiffness, attenuation, filter).
  • After that, the necessary motion profiles are set via the setup tool and the desired guiding behaviour in the entire velocity range is set via the feedforward control (motion profiles, feedforward).


Main flow chart of the controller optimization


Controller optimization disturbance and setpoint behaviour (standard)

In this chapter you can read about:

Controller optimization of toothed belt drive

Controller optimization guiding transmission behavior


Controller optimization of toothed belt drive

Remarks:

  • The stiffness of a drive able to oscillate can be slightly increased by using the D-component. If the D-component is too large, the control is destabilized.
  • Due to the double position differentiation, the D-component is rather noisy and may excite the control loop in the higher-frequency range. The filtering of the D-component using acceleration filters (0x3822.D) can dampen the higher-frequency components at the expense of dynamics.
  • The correct combination of the 3 parameters (stiffness, D-component, acceleration filter) will lead to the best control results
  • The D-component (0x3822.5) is set in %. The value range: 0...4000000 %
    Values up to 5000 % are quite common.


Controller optimization guiding transmission behavior


Communication via EtherNet/IP

In this chapter you can read about:

X61, X62 Connection of field buses (Ethernet)

Ethernet address

P10:Meaning of the Bus LEDs

Object numbers for multi-axis modules

Ethernet IP - description

Acyclic parameter channel


X61, X62 Connection of field buses (Ethernet)

RJ45-Socket: Assignment

Pin | Wire pair No. | RJ45 (X61) | RJ45 (X62)
 |  | out | in
1 | 2 | Tx + | Tx +
2 | 2 | Tx - | Tx -
3 | 3 | Rx + | Rx +
4 | 1 | - | reserved
5 | 1 | - | reserved
6 | 3 | Rx - | Rx -
7 | 4 | - | reserved
8 | 4 | - | reserved

Wiring with Ethernet Crossover cable Cat5e (from X61 to X62 of the next device without termination); for this, we offer our CBD000C0-T00-T0 interface cable.

Please use shielded cables:

  • SF/UTP: Cable fully shielded or
  • S/STP, S/FTP: additional shielding around the 4 pairs of wires.

Place the shield flat on the plug!

Meaning of LEDs X60, X61 & X62

LED green: Connection/activity indicator

Off | No connection
On | Connected, no activity
Flickering | Connected, activity

LED yellow: Speed indicator

Off | 10Base-T
Flickering | 100Base-TX


Ethernet address

Ethernet address can be set via S12 and S13.

Address_setting

Setting:

S12: Device address higher value half-byte (accept with power ON)
S13: Device address low value half-byte (accept with power ON)
The address 1 ... 240 (0x01 ... 0xF0) is possible; the range 241 ... 255 (0xF1 ... 0xFF) is reserved for special functions!

Example: S12=2, S13=1
Address= 0x21: S12*16 + S13 = 2*16 + 1 = 33

After switching on PSD the IP address value

  • "192.168.10.S12_S13" (X60 PC interface) e.g. "192.168.10.33"

resp.

  • "192.168.100.S12_S13" (X61/X62 field bus interface) e.g. "192.168.100.33"

is set.

In addition, the set address becomes part of the host name. The address set via S12_S13 is appended to the prefix "PSD1-" as a string with 3 digits:

  • Hostname= "PSD1-" followed by "S12_S13_3digit_String"

In the example:

  • Hostname=PSD1-033

If the IP address has been modified and is no longer known, the address can be reset to the default setting with S12_S13 = 249 (0xF9):

  • IP address = 192.168.10.2 (X60 PC) resp. 192.168.100.2 (X61/X62 field bus)
  • SubNetmask = 255.255.0.0
  • Gateway_IP = 192.168.10.254 (X60 PC) resp. 192.168.100.254 (X61/X62 field bus)
  • Hostname = PSD1-002

After that or in general the complete IP - address (not only the last part) can be redefined as follows:

  • At X60 via the objects 0x2500.0x04 & 0x2500.0x01 (Bit 12)
  • At X61/X62 via the objects 0x2605.0x04 & 0x2605.0x01 (Bit 12)


P10:Meaning of the Bus LEDs

Red LED (right): Error

LED is influenced by the transitions of the status diagram

Error LED red (right, b) | Error | Description
Off | No error |
Jitter (Flickering) | Boot error | Error during initialization. Position of S12/S13 was changed. Reset by power off/on. Exception 1: A value (VendorID, ProductCode, Revision, SerialNumber) of the idendtiyObject (0x1018) was changed. Reset by power off/on.
Flashing (Blinking) | Invalid configuration | Mapping error; i.e., the master could not correctly execute the configuration of the processing data (mapping) respectively the processing data length of master and device vary.
Single flash | Unsolicited change of status | Slave changed the status independently or same cause as with double flash
Double flash | Application watchdog timeout | Timeout; cyclic communication was interrupted (e.g. cable was removed)
On | PDI watchdog timeout |

Green LED (left): EtherCAT state

LED shows the states of the status diagram

Status LED green (left, a) | Condition | Description
Off | INITIALIZATION | Initialization
Flashing (Blinking) | PRE-OPERATIONAL | Ready
Single flash | SAFE-OPERATIONAL | Master reads values
On | OPERATIONAL | Mode of operation

Status diagram

Transition | Action
1 | Start mailbox communication
2 | Stop mailbox communication
3 | Start input update
4 | Stop input update
5 | Start output update
6 | Stop output update
7 | Stop output update, stop input update
8 | Stop input update, stop mailbox communication
9 | Stop output update, stop input update, stop mailbox communication

Meaning of the LED states

EtherCAT LED Zustände


Object numbers for multi-axis modules

The object numbers of the objects provided in the instructions always refer to the first axis of a multi-axis module or to a single-axis drive PSD1-S.

The objects are structured as follows:

Object number range | Range for ...
0x2000 ... 0x2FFF | Device-specific objects (not axis-specific)
0x3000 ... 0x3FFF | Manufacturer specific objects for axis 1 (= single axis)
0x4000 ... 0x4FFF | Manufacturer specific objects for axis 2
0x5000 ... 0x5FFF | Manufacturer specific objects for axis 3
0x6000 ... 0x67FF | DS402 objects for axis 1 (= single axis)
0x6800 ... 0x6FFF | DS402 objects for axis 2
0x7000 ... 0x77FF | DS402 objects for axis 3

The object numbers of the 2nd and, where appropriate 3. axis can be determined as follows:

  • Manufacturer specific object axis 2 = manufacturer specific object axis 1 + 0x1000
    Manufacturer specific object axis 3 = manufacturer specific object axis 2 + 0x1000 = manufacturer specific object axis 1 + 0x2000

    Example "Stiffness (bandwidth) factor speed controller": 0x3822.1 (axis 1) => 0x4822.1 (axis 2) => 0x5822.1 (axis 3)
  • DS402 object axis 2 = DS402 object axis 1 + 0x800
    DS402 object for axis 3 = DS402 object for axis 2 + 0x800 = DS402 objects for object axis 1 + 0x1000

    Example "Target position": 0x607A (axis 1) => 0x687A (axis 2) => 0x707A (axis 3)


Ethernet IP - description

In this chapter you can read about:

Ethernet IP characteristics

System model

Device types

Device modell

Messaging model

Status LEDs


Ethernet IP characteristics

Category

Specifications

Profile

DS402

Ethernet/IP
  • Generic device support for CIP and encapsulated layer

Ethernet
  • Several Ehernet interfaces are supported e.g., for devices with embedded switch technology (for the support of linear or ring topology)

Connection established
  • Device Level ring (DLR) functionality is supported (announce based ring nod)

Connections
  • Simultaneous support for up to 10 I/O connections
  • Simultaneous support for up to 10 encapsulation sessions
  • Simultaneous support for up to 2 explicit messaging connections per encapsulation session
  • Unconnected explicit messaging is supported

Service(s)
  • Quality of Service (QoS) supported
  • UDP for order list services, list targets and list identity for encapsulation protocol available
  • Pv4 address conflict detection for EtherNet/IP devices

Device master file
  • PSD1

Product Code
  • PSD1S: 21297 (0x5331)
  • PSD1M_1: 19761 (0x4D31) (1 power stage)
  • PSD1M_2: 19762 (0x4D32) (2 power stages)
  • PSD1M_3: 19763 (0x4D33) (3 power stages)

Vendor code
  • 4

Realized object grades
  • Identity
  • Message Router
  • Assembly
  • Connection manager
  • Device level ring
  • QoS
  • PSD1 object pool
  • TCP/IP Interface
  • Ethernet Link


System model

CIP (Common Industrial Protocol) is running via the PCP/IP protocol in the EtherNet/IP network system adaption and can therefore be used with each TCP/IP supported database, among them IEEE 802.3 or better known as Ethernet.

The following illustration shows EtherNet/IP within the CIP architecture.


Device types

Message server:

Reacts to explicit new inquiries of a news client; this is the minimum functionality of all CIP devices. Is typically used for configuration or programming.

Message Client:

Generates explicit messaging services upon request.

Adapter:

Exchanges real time I/O data by a scanner. Does not initiate connections. Includes message server functionality. Is typically used for packages of I/O.

Scanner:

Exchanges real time I/O data by a scanner.

Can initiate connections and react to connection inquiries of other devices.

Includes the functionality of the adapter class. Is typically used for PC based controls or PlCs.

Seen from the device type, PSD is a scanner.


Device modell

In this chapter you can read about:

Implemented object classes

Identity Object

Assembly object

PSD1 object pool

CIP uses the abstract object modulation for describing the communication from the product’s points of view. This following illustration shows a typical device object modell.

The objects required in a typical device are:

  • Either a connection object or a connection manager object
  • Identity object
  • TCP/IP Interface object
  • EtherNet Link Object
  • Message Router Object (at least its function)

Depending on the functionality of the device further objects are attached. The CIP specification summizes all devices with similar functionality to device types with corresponding profiles. Such a CIP profile includes the complete description of the object structure and its behaviour. Device designers must use a profile. Each device which does not fall within the scope of a special profile must use generic device profile or a design specific profile.


Implemented object classes

In PSD the following object classes are implemened:

Object name | Class ID | Description
Identity | 0x01 | Manages the identity data which identify the device in an EtherNet/OP network
Message Router | 0x02 | Manages explicit message traffic and passes on the message to the correct target
Assembly | 0x04 | Combines attribute data of one or several objects to on data component assembly accessible via the network
Connection manager | 0x06 | Manages explicit and I/O connections
Device level ring | 0x47 | Provides the configuration interface and status information interface for the DLR protocal
QoS | 0x48 | Configuration of certain behaviours in EtherNet/ IP devices with regards to QoS
PSD1 object pool | 0x64 | Read and write acces to all PSD1 parameters (objects)
TCP/IP Interface | 0xF5 | Manages the connection to TCP/IP protocol stack
Ethernet Link | 0xF6 | Manages the communication with the physical Ethernet connection


Identity Object

Instance 1

Attribute ID | Access | Name | Datatype | Wert
1 | GET | Vendor ID | UINT | 4
2 | GET | Geräteausbau | UINT | 43 (Generic)
3 | GET | Bestellschlüssel | UINT | 21297 PSD1S1 19761 PSD1M_1 19762 PSD1M_2 19763 PSD1M_3
4 | GET | Revision | Struct of |
 |  | Major Revision | USINT | 2
 |  | Minor Revision | USINT | 5
5 | GET | Status | UINT | …
6 | GET | Serial number | UDINT | …
7 | GET | Product Name | SHORT_STRING | "PSD1S1", "PSD1M1", "PSD1M2" or "PSD1M3"


Assembly object

The assembly objects binds attributes of the object class PSD1 object poos (ID 0x64) which allow to send data to or from each object via an individual connection or to receive them. Assembly objects can be use to link input or output data. The terms “Input” and “Output” are define from the network’s point of view. An input generates data in the network and an output reads data out of the network.

Assembly Instance 0x64 (100)

The assembly instance connects the input data of various device objects or axis status objects, e.g., status word (0x6041.0), actual position (0x6064.0), actual velocity (0x606C. 0), error code (0x603F. 0).

Instance 100

Attribute ID | Access | Name | Data Type | Baugröße
3 | GET | Data | Array of Byte | 1 … 64 Octet

The size of attribute 3 depends on the number of mapped objects and their data length.

The object mapping for this assembly instance con be configured with the PSD Servo Manager.

Assembly Instance 0x65 (101)

This assembly instance binds the output data of various device objects or axis control objects, e.g., Controlword (0x6040.0), TargetPosition (0x607A. 0), ProfileVelocity (0x6081.0), ProfileAcceleration (0x6083.0).Instance 101

Attribute ID | Access | Name | Data Type | Baugröße
3 | SATZ | Data | Array of Byte | 1 … 64 Octet

The size of attribute 3 depends on the number of mapped objects and their data length.

The object mapping for this assembly instance con be configured with the PSD Servo Manager.


PSD1 object pool

PSD1 objects marked by index or sub-index present device parameter/ axis parameters or functions.

Via explicit messagine (class 3 connection), the manufacturer specific object class 0x64 provides fast read and write access to all PSD1 objects available in the device.

For this purpose read access via service GET_ATTRIBUTE_SINGLE and write access via service SET_ATTRIBUTE_SINGLE is possible via instance ID as index and the attribute ID as sub-index.

Class ID | Instance ID (Index) | Attribute ID (Sub-Index) | Service (ID) | Function
0x64 | 0x0001 – 0xFFFF | 0x00 – 0xFF | Get_Attribute_Single (0x0E) | Read PSD1 Object
0x64 | 0x0001 – 0xFFFF | 0x00 – 0xFF | Set_Attribute_Single (0x10) | Write PSD1 Object

Object description, data type, data length and access rights are listed in object directory.

The data length of strings is defined by a 2-byte prefix.


Messaging model

In this chapter you can read about:

Implicit messaging (Class 1 connection)

Explicit messaging (Class 3 connection)

CIP uses 2 standard type for messages:

  • Implicit messaging
  • Explicit messaging

Bothe message types are implemented in PSD.


Implicit messaging (Class 1 connection)

For the cyclic I/O data exchange implicit messaging is used. The I/I message are sent via the UDP protocol of TCP/IP.

I/O messages are sent between devices as soon as CIP class 1 connection to the I/O connection point is realized. Typically assembler objects are used for I/O connection points.

Assembly objects provide the possibility to display data from different instances attributes of various classes in an individual attribute (in an assembly object). Usually this mapping is used for I/O message in order to maximize efficiency of the control data exchange in the network. Assembly mapping provides I/O data in one block; therefore there are less connection object instances and less transitions in the network. Usually the process data are combined from different application objects.

The scanner sends the output data via point-to-point connections. Usually the adapter publishes the input data to one or several users via multicast connection .


Explicit messaging (Class 3 connection)

Explicit messaging is used for point-to-point messaging of type client server. The server side is connected to a message router object and the client site to a client application object. The explicit message are sent via the TCP protocol of the TCP/IP suite.

Explicit messages can be sent in connected or unconnected form. Each request receives a service code with path information to the desired object (attribute) within the target device.

Explicit messaging is typical for:

  • Diagnosis
  • Information
  • Configuration


Status LEDs

In this chapter you can read about:

P10a: Status display of the device

P10b: Status display of the network

2 types of status displays are used:

  • Status display of the device
  • Status display of the network


P10a: Status display of the device

Status display LED P10 a (left) | Status | Description
Off | PSD off | PSD without power supply
Green | PSD operational | PSD is working correctly
Green, flashing | Stand by | PSD not configured
Red, flashing | Minor error | PSD reports a recoverable minor error Note: faulty or inconsistent configuration is a minor error
Red | Main error | PSD report not recoverable serious error
Green / red , flashing | Self test | PSD performs self test


P10b: Status display of the network

Status display LED P10 b (left) | Status | Description
Off | PSD off No IP address | In case the device does not have an IP address (or is switched off) the LED must be OFF.
Green | Connected | If the device has built up at least one connection (also to the message router).
Green, flashing | No connection | If the device does not have a connection but has received an IP address.
Red, flashing | Connection time out | One or several connections where this device is the target device shows time out This state can be quit if all time out connections are restored or if a reset is made.
Red | Double IP | IP address is already existing
Green / red, flashing | Self test | PSD performs self test


Acyclic parameter channel

In this chapter you can read about:

Parameter access via APA

Access to the objects of the PSD is possible via the acyclic data exchange.

Access via the file formate of "Base Mode Parameter Access".

Furthermore it is possible to communicate via an acyclic parameter channel.


Parker Servo Drive

Vorige Seite

Nächste Seite

Parameter access via APA


Parker Servo Drive

Vorige Seite

Nächste Seite

Parameter access with 4 Words


Basic APA

With the APA interface (acyclic parameter access) it is possible to read/write parameters in addition to the cyclic data exchange. The PLC sends the request which is answered and returned by the PSD1 as quickly as possible.

APA structure: | Byte 1 | Octet 2 | Byte 3 | Byte 4 | Octet 5 | Octet 6 | Octet 7 | Octet 8
 | PI |  | IND |  | PDA

PI: Parameter recognition (Byte 1.and 2)

IND: Subindex (Byte 3), PNU high order Bit 8 … 15 (Byte 4)

PDA: Parameter data (Byte 5. to 8) Byte 5 = MSB, Byte 8 = LSB

PI structure: | Byte 1 |  |  |  |  |  |  |  | Octet 2
 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 |  | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
 | RID |  |  |  | SPM | PNU / Object Index low order

RID: Request or response ID (value range 0 ... 15)

Always set RID to 0 before writing the request and only set to value when the remaining data of the request is set. Recommended procedure.

Procedure of a request:

  • Set RID (request ID) = 0 (depending on the data structure, set the 1st byte, 1st word or 1st double word to 0).
  • Write remaining data
  • RIP write (or. 1. Byte, 1. word or 1. double word)
  • Wait for response and process it.
  • Set RID (request ID) =, 1st word or 1st double word to 0). Set Byte, 1. word or 1. double word to 0)

SPM: reserved

PNU Low: Parameter number (Object Index) low order bit 0…10

IND structure: | Byte 3 |  |  |  |  |  |  |  |  | Byte 4
 | 15 |  | 14 | 13 | 12 | 11 | 10 | 9 | 8 |  | 7 |  | 6 | 5 | 4 | 3 | 2 | 1 | 0
 |  | Subindex |  |  |  |  |  |  |  |  |  | PNU / Object Index high order

PNU high: Parameter number (Object Index) high order bit 8…15

PNU structure: | MSB |  |  |  |  |  |  |  |  | LSB
 | 15 | 14 |  | 13 | 12 | 11 | 10 | 9 | 8 |  | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
 | 0 | 0 | 0 |  | 0 | 0 | PNU / Object no. low order
 | PNU high order |  |  |  |  |  |  |  |  |
 | 7 | 6 |  | 5 | 4 | 3 | 2 | 1 | 0 |  |

Warning!

The following is necessary:

Bit 8 PNU = [Bit 8 PNU low] OR [Bit 0 PNU high]

Bit 9 PNU = [Bit 9 PNU low] OR [Bit 1 PNU high]

Bit 10 PNU = [Bit 10 PNU low] OR [Bit 2 PNU high]


Request/Response processing

Request/Response IDs

Request

RID

Request PLC ® PSD1

Response PSD1 ® PLC

positive negative

0

No request
write data in frame (request).. Recommended procedure.

Procedure of a request:

  • Set RID (request ID) = 0 (depending on the data structure, set the 1st byte, 1st word or 1st double word to 0).
  • Write remaining data
  • RIP write (or. 1. Byte, 1. word or 1. double word)
  • Wait for response and process it.
  • Set RID (request ID) =, 1st word or 1st double word to 0). Set Byte, 1. word or 1. double word to 0)

0

1

Read parameter value

1.2

2

Set parameter value (word)

1

3

Set parameter value (double word)

2

6

Read parameter value (array)

4.5

7

7

Set parameter value (array of word)

4

/

8

Set parameter value (array of double word)

5

8

9

Read number of array elements

6

Vendor specific requests

13

Read object value (parameter)

13

14

Write object value (parameter)

14

15

Read object value once (parameter)

15

  • The controller transfers an order to a PSD1.
  • The controller repeats this order at least until a response is received from PSD1.
    This procedure ensures the transfer of orders /responses on the user level.
  • Only one order is being processed at a time.
  • PSD1 continues to make the response available until the controller formulates a new order.
  • For request ID 1, 6, 8 and 13, PSD1 updates the response cyclic with the actual value.
  • Parameter data of word size takes place with byte 7 and 8, while parameter of double word size is performed with byte 5 through 8.
  • Error Code has word size is performed with byte 7 and 8 for Request ID 1 to 9.

Rsp-ID | PSD1 ® PLC | Rsp-ID | PSD1 ® PLC
0 | No response | 7 | Request declined (with error No.)
1 | Word parameter transfer ok | 8 | No user level for APA interface
2 | Double word parameter transfer ok | 9 | Factory use
4 | Array word parameter transfer ok () | 10 | Factory use
5 | Array double word parameter ok | 14 | Object value transfer ok
6 | Array size transfer ok | 13, 15 | Object value transfer ok

The information for parameter subindex (parameter array) also applies to PROFIdrive profile V3, i.e., that the subindex is counted from 0, while for PROFIdrive profile V2 the subindex is counted from 1.

Subindex bei DPV0/DPV1


Read examples
Read statusword1 (PNU = 968.0) with the value 0x2070
Read parameter | RID | SPM | Ph | PNU low order | Sidx | PNU high order | D3 MSB | D2 | D1 |  | D0 LSB
Request | 1 | x | 3 | 0xC8 | 0x00 | 0x00 | x | x | x | X
Reply | 1 | x | 3 | 0xC8 | 0x00 | 0x00 | 0x00 | 0x00 | 0x20 | 0x70
Read ActualPosition (PNU = 0x6064.0) with the value 100.000 (0x000186A0)
Read parameter | RID | SPM | Ph | PNU low order | Sidx | PNU high order | D3 MSB | D2 | D1 |  | D0 LSB
Request | 1 | x | 0 | 0x64 | 0 | 0x60 | x | x | x | X
Reply | 1 | x | 0 | 0x64 | 0 | 0x60 | 0x00 | 0x01 | 0x86 | 0xA0

Ph: Bit 8, 9, 10 of PNU low order


Write examples
Set controlword1 (PNU = 967.0) with value 0x0406
Parameters set word | RID | SPM | Ph | PNU low order | Sidx | PNU high order | D3 MSB | D2 | D1 |  | D0 LSB
Request | 2 | x | 3 | 0xC7 | 0x00 | 0x00 | 0x00 | 0x00 | 0x04 | 0x06
Reply | 1 | x | 3 | 0xC7 | 0x00 | 0x00 | 0x00 | 0x00 | 0x04 | 0x06
Set target position (o0x607A.0) with the value 350,000 (0x00055730)
Parameters set Dword | RID | SPM | Ph | PNU low order | Sidx | PNU high order | D3 MSB | D2 | D1 |  | D0 LSB
Request | 3 | x | 0 | 0x7A | 0x00 | 0x60 | 0x00 | 0x05 | 0x57 | 0x30
Reply | 2 | x | 0 | 0x7A | 0x00 | 0x60 | 0x00 | 0x05 | 0x57 | 0x30

Ph: Bit 8, 9, 10 of PNU low order


I/O expansion

With this additional extension it’s possible to read/write objects (parameter) with up to 16 data bytes.

Different to the standard APA, the object data has the byte order LSB first then MSB; but the byte order can be changed for 16, 32 or 64 bit values with the BO flags in the Request Control byte.

APA structure: | Byte 1 | Byte 2 | Byte 3 |  | Byte 4 | Byte 5 |  | Byte 6 | Byte 7 | Byte 8
Request | RC | SI | IND |  |  | OD
Response | RC | LEN | - | DT |  | OD
Error Response | 7 | 2 |  | 0x0A |  | ECH | ECL

RC: | Request/ response code (1st Byte) | OD: | Object data (5th to 8th byte) Byte 5 = LSB, Byte 8 = MSB
SI: | Object subindex | LEN: | Object length
IND: | Object Index (3rd high order byte 4th low order byte) | DT: | Data Type
ECH: | High order error code (MSB) | ECL: | Low order error code (LSB)

RC structure: | Byte 1
 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8
RID=13, 14 or 15 | RID |  |  |  | BO |  | DBA

RID:

Request/Response IDs

Always set RID to 0 before writing the request and only set to value when the remaining data of the request is set. Recommended procedure.

Procedure of a request:

  • Set RID (request ID) = 0 (depending on the data structure, set the 1st byte, 1st word or 1st double word to 0).
  • Write remaining data
  • RIP write (or. 1. Byte, 1. word or 1. double word)
  • Wait for response and process it.
  • Set RID (request ID) =, 1st word or 1st double word to 0). Set Byte, 1. word or 1. double word to 0)

BO: | Byte order | 00 = no modification of the Byte order 01 = Swap U16; 10 = Swap U32; 11 = Swap U64
DBA: | Data buffer access | 00 = Read/write ObjData 00...03 and execute the request 01 = Read/write ObjData 04…07 access to data buffer only) 10 = Read/write ObjData 08…11 (access to data buffer only) 11 = Read/write ObjData 12…15 (access to data buffer only)

Attention! Byte order of Error Code is always the same, first MSB then LSB (BO doesn’t control this).


Read Examples
Get Statusword1 (PNU = 968.0) with the value 0x2070
Read parameters | RID | BO | DBA | SI | IND |  | D0 (LSB) | D1 | D2 | D3(MSB)
Requirement | 0xF | 00 | 00 | 0x00 | 0x03 | 0xC8 | x | x | x | x
 |  |  |  | LEN |  | DT |  |  |  |
Response | 0xF | 00 | 00 | 0x02 | - | 0x0A | 0x70 | 0x20 | 0x00 | 0x00
Get Statusword1 (o968.0) with the value 0x2070, but with swaped response data
Read parameters | RID | BO | DBA | SI | IND |  | D1 | D0(LSB) | D2 | D3(MSB)
Requirement | 0xF | 01 | 00 | 0x00 | 0x03 | 0xC8 | x | x | x | x
 |  |  |  | LEN |  | DT |  |  |  |
Response | 0xF | 01 | 00 | 0x02 | - | 0x0A | 0x20 | 0x70 | 0x00 | 0x00
Read ActualPosition (o0x6064.0) with the value 100.000 (0x000186A0)
Read parameters | RID | BO | DBA | SI | IND |  | D0 (LSB) | D1 | D2 | D3(MSB)
Requirement | 0xF | 00 | 00 | 0x00 | 0x60 | 0x64 | x | x | x | x
 |  |  |  | LEN |  | DT |  |  |  |
Response | 0xF | 00 | 00 | 0x04 | - | 0x0B | 0xA0 | 0x86 | 0x01 | 0x00
Read ActualPosition (PNU = 0x6064.0) with the value 100000 (0x000186A0) , but with swapped response data
Read parameters | RID | BO | DBA | SI | IND |  | D3(MSB) | D2 | D1 | D0(LSB)
Requirement | 0xF | 10 | 00 | 0x00 | 0x60 | 0x64 | x | x | x | x
 |  |  |  | LEN |  | DT |  |  |  |
Response | 0xF | 10 | 00 | 0x04 | - | 0x0B | 0x00 | 0x01 | 0x86 | 0xA0


Write Examples
Set Controlword1 (o967.0) with the value 0x0406
Read parameters | RID | BO | DBA | SI | IND |  | D0 (LSB) | D1 | D2 | D3(MSB)
Requirement | 0xE | 00 | 00 | 0x00 | 0x03 | 0xC7 | 0x06 | 0x04 | 0x00 | 0x00
Response | 0xE | 00 | 00 | 0x00 | 0x03 | 0xC7 | 0x06 | 0x04 | 0x00 | 0x00
Set Controlword1 (o967.0) with the value 0x0406, but with swaped request data
Read parameters | RID | BO | DBA | SI | IND |  | D1 | D0(LSB) | D2 | D3(MSB)
Requirement | 0xE | 01 | 00 | 0x00 | 0x03 | 0xC8 | 0x04 | 0x06 | 0x00 | 0x00
Response | 0xE | 01 | 00 | 0x00 | 0x03 | 0xC8 | 0x04 | 0x06 | 0x00 | 0x00
Set target üpsition (o0x607A.0) with the value 350000 (0x00055730)
Read parameters | RID | BO | DBA | SI | IND |  | D0 (LSB) | D1 | D2 | D3(MSB)
Requirement | 0xE | 00 | 00 | 0x00 | 0x60 | 0x7A | 0x30 | 0x57 | 0x05 | 0x00
Response | 0xE | 00 | 00 | 0x00 | 0x60 | 0x7A | 0x30 | 0x57 | 0x05 | 0x00
Set target position (o0x607A.0) with the value 350000 (0x00055730), but with swapped request data
Read parameters | RID | BO | DBA | SI | IND |  | D3(MSB) | D2 | D1 | D0(LSB)
Requirement | 0xE | 10 | 00 | 0x00 | 0x60 | 0x64 | 0x00 | 0x05 | 0x57 | 0x30
Response | 0xE | 10 | 00 | 0x00 | 0x60 | 0x64 | 0x00 | 0x05 | 0x57 | 0x30


Data Types
ID | ID-Hex | Name
1 | 0x01 | Bit string [1Bit]
2 | 0x02 | Bit string [8Bit]
3 | 0x03 | Bit string [16Bit]
4 | 0x04 | Bit string [32Bit]
5 | 0x05 | Bit string [64Bit]
9 | 0x09 | Unsigned small integer [8Bit]
10 | 0x0A | Unsigned half integer [16Bit]
11 | 0x0B | Unsigned integer [32Bit]
12 | 0x0C | Unsigned long integer [64Bit]
17 | 0x11 | Small integer [8Bit] (signed)
18 | 0x12 | Half integer [16Bit] (signed)
19 | 0x13 | Integer [32Bit] (signed)
20 | 0x14 | Long integer [64Bit] (signed)
25 | 0x19 | Visible String
26 | 0x1A | Octet String
33 | 0x21 | 32Bit Floating Point (IEEE754)
34 | 0x22 | 64Bit Floating Point (IEEE754)
49 | 0x31 | Duration (t#0s)
50 | 0x32 | Date (d#2010-12-31)
51 | 0x33 | Time of day(tod#00:00:00)
52 | 0x34 | Date and Time (dt#2010-12-31+00:00:00)


Parameter access with 6 Word

In addition to cyclic data exchange, you can use the APA (Acyclic Parameter Access) interface to read/write parameters. The PLC sends a request that will be processed by the PSD1 a.s.a.p. and sends back the corresponding response.


Request structure

Byte 1 | Octet 2 | Byte 3 | Byte 4 | Octet 5 | Octet 6 | Octet 7 | Byte8 | Octet 9 | Byte10 | Byte11 | Byte12
Order/reply header |  |  |  | Data
RC | SI | Idx |  | OD0/8 | OD1/9 | OD2/10 | OD3/11 | OD4/12 | OD5/13 | OD6/14 | OD7/15

RC: | Request/ response Monitoring: | SI: | Object subindex
Idx: | Object Index ; Byte 3 = MSB, Byte) 4 = LSB | OD1..OD16: | Object Data; OD1 = LSB, OD16 = MSB, if BO = 00

RC structure: | Byte 1
 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
 | RTB | DBA | BO |  | RID

RTB: | Request/response toggle Bit |
BO: | Byte order | 00 = no modification of the Byte order 01 = Swap U16; 10 = Swap U32; 11 = Swap U64
DBA: | Data buffer access | 0 = Read/write ObjData 00...07 and execute the request 1 = Read/write ObjData 08…16 (access to data buffer only)
RID: | Request/Response ID |

Always set RID to 0 before writing the request and only set to value when the remaining data of the request is set. Recommended procedure.

Procedure of a request:

  • Set RID (request ID) = 0 (depending on the data structure, set the 1st byte, 1st word or 1st double word to 0).
  • Write remaining data
  • RIP write (or. 1. Byte, 1. word or 1. double word)
  • Wait for response and process it.
  • Set RID (request ID) =, 1st word or 1st double word to 0). Set Byte, 1. word or 1. double word to 0)

RC

PLC request ® PSD1

RC PSD1 ® PLC

RTB

DPA

BO

RID

positive

negative

0/1

0

xx

0

No inquiry

0/128

0

0/1

0

xx

1

Read object value once

0/128

Not 0/128

0/1

0

xx

2

Write object value

0/128

Not 0/128

0/1

0

xx

3

Read object value

0/128

Not 0/128

For objects with data length > 8 bytes, bear the following in mind:

  • To get a clean write access, first write the object data OD8...OD15 into the data buffer
  • To get a clean read access, first write the object data OD8...OD15 into the data buffer

A request can be repeated by switching from RTB.

Important:IF (RTB request == RTB reply) è Request handled.


Response structure

In this chapter you can read about:

Read Examples

Write Examples
The response control (1. Byte) shows if a request is executed successful.
RC | Response PSD1 ® PLC
0/128 | Request done, possible data in OD1...OD16
Not equal 0/128 | Access denied, because ....

By a write access, the transmitted request is mirrored to the response, other than RC.
Byte 1 | Byte 2 | Byte 3 | Byte 4 |  | Byte 5 |  | Byte 6 |  | Byte 7 |  | Byte8 |  | Byte 9 |  | Byte10 |  | Byte11 |  | Byte12
Response Header |  |  |  | Data
0/128 | Subindex | Index |  | OD1/9 |  | OD2/10 |  | OD3/11 |  | OD4/12 |  | OD5/13 |  | OD6/14 |  | OD7/15 |  | OD8/16

By a read access, the requested data is transmitted back as follows:
Byte 1 | Byte 2 | Byte 3 | Byte 4 |  |  | Byte 5 |  | Byte 6 |  | Byte 7 |  | Byte8 |  | Byte 9 |  | Byte10 |  | Byte11 |  | Byte12
Response Header |  |  |  |  | Data
0/128 | LEN | - |  | DT | OD1/9 |  | OD2/10 |  | OD3/11 |  | OD4/12 |  | OD5/13 |  | OD6/14 |  | OD7/15 |  | OD8/16

RC: Response Control LEN: Object data length (bytes)

DT: Data Type OD1..OD16: Object data; OD1 = LSB, OD16 = MSB, if BO = 00

If a request is denied, the reason is written to OD1 and OD2 (16 bit Error Code)
Byte 1 | Byte 2 | Byte 3 | Byte 4 |  | Byte 5 |  | Byte 6 |  | Byte 7 |  | Byte8 |  | Byte 9 |  | Byte10 |  | Byte11 |  | Byte12
Response Header |  |  |  | Data
RC | Subindex | Index |  | ECH |  | ECL |  | OD3/11 |  | OD4/12 |  | OD5/13 |  | OD6/14 |  | OD7/15 |  | OD8/16

ECH: Error Code (MSB); ECL: Error Code (LSB)


Read Examples
Get Statusword1 (PNU = 968.0) with the value 0x2070
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x1 | 0x00 | 0x03 | 0xC8 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 00 | 0x1 | 0x02 | - | 0x0A | 0x70 | 0x20 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Get Statusword1 (o968.0) with the value 0x2070, but with swaped response data
 | RTB | DBA | BO | RID | SI | IND |  | D1 | D0 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 01 | 0x1 | 0x00 | 0x03 | 0xC8 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 01 | 0x1 | 0x02 | - | 0x0A | 0x20 | 0x70 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Read ActualPosition (o0x6064.0) with the value 100.000 (0x000186A0)
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x1 | 0x00 | 0x60 | 0x64 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 00 | 0x1 | 0x04 | - | 0x0B | 0xA0 | 0x86 | 0x01 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Get ActualPosition (o0x6064.0) with the value 100000 (0x000186A0) , but with swaped response data
 | RTB | DBA | BO | RID | SI | IND |  | D3 | D2 | D1 | D0 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 10 | 0x1 | 0x00 | 0x60 | 0x64 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 10 | 0x1 | 0x04 | - | 0x0B | 0x00 | 0x01 | 0x86 | 0xA0 | 0x00 | 0x00 | 0x00 | 0x00
Get AppTP_U64 (o0x2000.9) with the value 0x1234567890ABCDEF
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x1 | 0x09 | 0x20 | 0x00 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 00 | 0x1 | 0x08 | - | 0x0C | 0xEF | 0xCD | 0xAB | 0x90 | 0x78 | 0x56 | 0x34 | 0x12
Get AppTP_U64 (o0x2000.9) with the value 0x1234567890ABCDEF, but with swaped response data
 | RTB | DBA | BO | RID | SI | IND |  | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0
Req | 0/1 | 0 | 11 | 0x1 | 0x09 | 0x20 | 0x00 | x | x | x | x | x | x | x | x
 |  |  |  |  | LEN |  | DT |  |  |  |  |  |  |  |
Rsp | 0/1 | 0 | 11 | 0x1 | 0x08 | - | 0x0C | 0x12 | 0x34 | 0x56 | 0x78 | 0x90 | 0xAB | 0xCD | 0xEF


Write Examples
Set Controlword1 (o967.0) with the value 0x0406
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x2 | 0x00 | 0x03 | 0xC7 | 0x06 | 0x04 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Rsp | 0/1 | 0 | 00 | 0x2 | 0x00 | 0x03 | 0xC7 | 0x06 | 0x04 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Set Controlword1 (o967.0) with the value 0x0406, but with swaped request data
 | RTB | DBA | BO | RID | SI | IND |  | D1 | D0 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 01 | 0x2 | 0x00 | 0x03 | 0xC7 | 0x04 | 0x06 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Rsp | 0/1 | 0 | 01 | 0x2 | 0x00 | 0x03 | 0xC7 | 0x04 | 0x06 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Set target position (o0x607A.0) with the value 350000 (0x00055730)
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x2 | 0x00 | 0x60 | 0x7A | 0x30 | 0x57 | 0x05 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Rsp | 0/1 | 0 | 00 | 0x2 | 0x00 | 0x60 | 0x7A | 0x30 | 0x57 | 0x05 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00
Set target position (o0x607A.0) with the value 350000 (0x00055730), but with swapped request data
 | RTB | DBA | BO | RID | SI | IND |  | D3 | D2 | D1 | D0 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 10 | 0x2 | 0x00 | 0x60 | 0x7A | 0x00 | 0x05 | 0x57 | 0x30 | 0x00 | 0x00 | 0x00 | 0x00
Rsp | 0/1 | 0 | 10 | 0x2 | 0x00 | 0x60 | 0x7A | 0x00 | 0x05 | 0x57 | 0x30 | 0x00 | 0x00 | 0x00 | 0x00
Get AppTP_U64 (o0x2000.9) with the value 0x1234567890ABCDEF
 | RTB | DBA | BO | RID | SI | IND |  | D0 | D1 | D2 | D3 | D4 | D5 | D6 | D7
Req | 0/1 | 0 | 00 | 0x2 | 0x09 | 0x20 | 0x00 | 0xEF | 0xCD | 0xAB | 0x90 | 0x78 | 0x56 | 0x34 | 0x12
Rsp | 0/1 | 0 | 00 | 0x2 | 0x09 | 0x20 | 0x00 | 0xEF | 0xCD | 0xAB | 0x90 | 0x78 | 0x56 | 0x34 | 0x12
Get AppTP_U64 (o0x2000.9) with the value 0x1234567890ABCDEF, but with swaped response data
 | RTB | DBA | BO | RID | SI | IND |  | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0
Req | 0/1 | 0 | 11 | 0x2 | 0x09 | 0x20 | 0x00 | 0x12 | 0x34 | 0x56 | 0x78 | 0x90 | 0xAB | 0xCD | 0xEF
Rsp | 0/1 | 0 | 11 | 0x2 | 0x09 | 0x20 | 0x00 | 0x12 | 0x34 | 0x56 | 0x78 | 0x90 | 0xAB | 0xCD | 0xEF


Positioning & Control according to Can CiA DS402

In this chapter you can read about:

Device control by means of status machine (Finite state automaton)

DS402 operating modes

Operating mode homing mode (machine zero)

Operating mode jogging (manual mode)

Operating mode - profile velocity mode (speed control)

Operating mode: Profile Position Mode (Position control)

Touch Probe - store effective position event controlled


Device control by means of status machine (Finite state automaton)

In this chapter you can read about:

State machine

Status values

Transitions

For simple control and in order to standardize fixed device states are defined.

The transition between the states is made via the control word or by an external event (e.g. error).

The status word delivers information about the drive and indicates its device state.

The correlation of the device sates as well as the possible transitions are called state machine and can be displayed in an image.


State machine

1) Bit 3 of the status word (fault) is only set if bit 7 of the status word (fault reset) is at "0".

‹, Œ, , ... : Status transitions

(A) Low level power | Control voltage switched on. Power supply ready to turn on.
(B) High level power | Power supply switched on. Motor not powered
(C) Torque | Motor powered
Notes
  • The status printed in bolt are stable states and are checked by the master.
  • The transitions 3 & 4 can only be requested by the master.
  • The transition of "Ready to switch on" to "Operation enable" (transitions 3 & 4) can be required by the master via one command only by a mutual setting of the control word - Bit 0, 1, & 3 ="1".
  • The drive does not accept transition 3 if no power supply voltage is active.
  • The status “switch on disabled” can automatically pass through local signals of the drive. The transition 2 must only be activated by the master if the drive does not carry it out.


Status values

Designation | Explanation
Not ready to switch on | Control voltage switched on Initialization Brake closed Not ready to turn on
Switch on disable | Initialization completed Parameter values can be changed Power supply voltage switched off Travel commands not possible
Ready to switch on | Power supply voltage can be switched on Parameter values can be changed Travel commands not possible
Switched on | Power supply voltage switched on Parameter values can be changed Travel commands not possible Motor de-energized
Operation enable | Motor energized Device is ready for carrying out travel commands Parameter values can be changed
Quick stop active | The "Quick stop" function has been executed Motor energized Parameter values can be changed
Fault reaction 1 active | A fault has occurred The motor is stopped with the ramp QuickStopDecel and is de-energized at standstill. Parameter values can be changed
Fault 1 | Error state, motor de-energized, error can be read Travel commands not possible Parameter values can be changed A positive flank is expected at FAULT RESET
Fault reaction 2 active | A fault has occurred The motor is stopped with the ramp QuickStopDecel and remains de-energized. Parameters can be changed
Fault 2 | Error state, motor energized, error can be read Travel commands not possible Parameters can be changed A positive flank is expected at FAULT RESET

*

If the delay of the actual motion is bigger than the QuickStopDecel value, the value of the actual motion (the bigger value) is used.

In the operating modes Cyclic Synchronous Position / Velocity Mode QuickStopDecel value on object 0x34A8.0x00 is limited downwards.


Transitions

  • The transition of "Ready to switch on" to "Operation enable" (transitions 3 & 4) can be required by the master via one command only by a mutual setting of the control word - Bit 0, 1, & 3 ="1".
  • In deviating from the DS402 standard, transition 2 from “Switch On Disabled” to “Ready to switch on” is also possible with Bit 0 set in the control word. This makes it possible to switch from "Switch On Disabled" to "Operation Enabled" with just one command in the control word.
  • Transition 3 “Switch On” is only permitted with activated AC power voltage (bit 4 “Voltage enable” in status word is 1 -> DC link voltage bigger than error threshold)
  • Transition 8: Unlike DS402, here "ramping with MinSlowDown" (0x3428.0x00" (0x605B=1)!
Ramps used

For various transitions, for which the device leaves the status "Operation Enable" (travel commands may be active), various ramps can be set. The following is necessary:

Transition | Ramps / objects (PSD standard) | Behavior configurable via object ...
5 | MinSlowDown* / 0x3428.0x00 | 0x605C.0x00
8 | MinSlowDown* / 0x3428.0x00 | 0x605B.0x00
9 | MinSlowDown* / 0x3428.0x00 | 0x605B.0x00
11 | QuickStopDecel* / 0x6085.0x00 | 0x605A.0x00
12 | Automatic transition | 0x605A.0x00
13 | QuickStopDecel* / 0x6085.0x00 | -
17 | QuickStopDecel* / 0x6085.0x00 | -

The ramps can also be set in the PSD ServoManager under [image] Axis1: ramps.

1 | = MinSlowDown (0x3428.0x00)
2 | = QuickStopDecel (0x6085.0x00)

*

If the deceleration of the current motion is greater than the QuickStopDecel or the MinSlowDown value then the value of the current motion (the greater value) is used.

In the Cyclic Synchronous Velocity operating modes, the QuickStopDecel or MinSlowDown is limited downwards to object 0x34A8.0x00.

In the Cyclic Synchronous Position operating modes, a lower limit is not set (except for 0x3311.8), as no gearing is defined (hard coupling to the master velocity).


DS402 operating modes

In this chapter you can read about:

Changing operating modes

Operating modes according to DS402 are set via object 0x6060.00.

Value 0x6060.00 | Description
-1 | Jogging (Manual operation)
+1 | Profile position mode (position control)
+3 | Profile velocity mode (speed control)
+6 | Homing mode (machine zero)

The operating modes “profile position mode” & “profile velocity mode” can also be configured via PSD ServoManager.

The object is then described during device start and after a configuration download.

The successful switching of the operating modes can be checked via object 0x6061.00:

Value 0x6061.00 | Description
-1 | Jogging (Manual operation)
+1 | Profile position mode (position control)
+3 | Profile velocity mode (speed control)
+6 | Homing mode (machine zero)
-99 | PSD is in configuration mode via PSD ServoManager


Changing operating modes

Change of operating mode is possible under the following status:

  • Fault 1
  • Fault 2
  • Quick Stop Active
  • Switch on disabled
  • Ready to Switch on
  • Switched on
  • After STOP (CW1 Bit 8) after standstill of the motor

In the status word, operating mode change is indicated by bit 10 ="1".

In the status “operation enable”, changing operating modes is only possible if no travel command is active.


Operating mode homing mode (machine zero)

Setting the operating mode BA 0x6060.0x00 = +6

The operating mode is switched to “Homing" during operation (via the bus) and is not supported by the configuration in the PSD1-tool.

Control word Bit 4 ="1": Homing operation start (activate machine zero run)

Functional description as well as different machine zero operating modes can be found here.


Control word 1 (Controlword 1) 0x6040.0x00 (Homing mode)

Bit | Name |  |  | Shutdown | Switch on | Switch on & enable operation | Disable voltage | Quick stop | Disable operation | Enable operation | Fault / warning reset
0 | Switch on |  |  | X | 1 | 1 | X | X | 1 | 1 | X
1 | Enable voltage |  |  | 1 | 1 | 1 | 0 | 1 | 1 | 1 | X
2 | Quick stop |  |  | 1 | 1 | 1 | X | 0 | 1 | 1 | X
3 | Enable operation |  |  | X | 0 | 1 | X | X | 0 | 1 | X
7 | Fault reset |  |  | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
Transitions |  |  |  | 2,6,8 | 3 | 3+4 | 7,9,10,12 | 7,10,11 | 5 | 4.16 | 15
Bit |  |  | Definition
4 |  |  | ="1": Homing operation start (activate homing run)
5 |  |  | ="0" (reserved)
6 |  |  | ="0" (reserved)
8 | Halt |  | ="1": Halt (Stop with abort) with the "Slow Down" ramp (standard). Configurable via object 0x605D. Remains in state "Operation enabled".
9 |  |  | ="0" (reserved)
10 |  |  | ="0" (reserved)
11 |  | ="0" (reserved)
12 |  | ="0" (reserved)
13 |  | ="0" (reserved)
14 |  | ="0" (reserved)
15 |  | ="0" (reserved)


Status Word 1 (Status word) 0x6041.0x00 (op 6, Homing mode)

Bit |  | Not Ready to Switch on | Switch on disabled | Ready to Switch on | Switched on | Operation enabled | Quick stop active | Fault reaction active | Fault
0 | Ready to switch on | 0 | 0 | 1 | 1 | 1 | 1 | 1 | 0
1 | Switched on | 0 | 0 | 0 | 1 | 1 | 1 | 1 | 0
2 | Operation enable | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0
3 | Fault | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1
4 | Voltage enable | x | x | x | 1 | 1 | 1 | x | x
5 | Quick stop | x | x | 1 | 1 | 1 | 0 | x | x
6 | Switch On Disabled | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
7 | ="1": Warning (error with error response 0xE) is displayed. Bit automatically goes to "0" after the error cause is no longer present.
 | Description

8

="1": Speed=0 (drive motionless) (based on nominal value)

9 | ="1": Remote (parameters can be changed via fieldbus, control word is processed). ="0": The control word is not processed. However, objects can be read & described (unless in setup mode of the PSD ServoManager)

 | Description
10 | ="1": Target reached 1)
11 | reserved
12 | ="1": Homing attained
13 | ="1": Homing error
14 | ="1": Actuator referenced, Please note: Multi-turn absolute encoder are generally reported as referenced
15 | "0" STO inactive "1" STO active

1)

Bit 10 is set to 1 if operating mode has been changed.

If quick stop option code (object 0x605A) = 5, 6, 7 or 8, Bit 10 is set to 1 when the quick stop process is completed and the PSD has stopped.

If stop has occurred and the PSD was stopped, Bit 10 will also set to 1.


Status bits for homing run

Bit 13 | bit 12 | bit 10 | Meaning
0 | 0 | 0 | Machine reference run active
0 | 0 | 1 | Machine reference run interrupted or not started
0 | 1 | 0 | Machine reference reached but destination not reached
0 | 1 | 1 | Machine reference run was successfully performed
1 | 0 | 0 | Error; velocity is not 0
1 | 0 | 1 | Error; velocity is not 0
1 | 1 | X | factory use


Operating mode jogging (manual mode)

Setting the operating mode BA 0x6060.0x00 = -1

The operating mode switching to “Jogging" takes place during operation (via the bus) and is not supported by the configuration in the ServoManager.

0x6040 Bit 4 ="1" Jog+ (Hand+)

0x6040 Bit 5 ="1" Jog+ (Hand-)

0x6040 Bit 8 ="1" Stop (Stop without termination)

Velocity, acceleration and jerk for manual mode are defined via objects:

0x346A.0x00: Velocity for Jog+/-

0x3468.0x00: Acceleration for Jog+/-

0x346E.0x00: Deceleration for Jog+/- 1)

0x3469.0x00: Jerk for Jog+/-

Values can be set via the PSD ServoManager or via SDO.

1) only from PSD firmware >= 1.10.1, with a deceleration value of 0 (default value) will the acceleration value be accepted as a deceleration value.


Control word 1 (Controlword 1) 0x6040.0x00 (manual mode)

Bit | Name | Shutdown | Switch on | Switch on & enable operation | Disable voltage | Quick stop | Disable operation | Enable operation | Fault / warning reset
0 | Switch on | X | 1 | 1 | X | X | 1 | 1 | X
1 | Enable voltage | 1 | 1 | 1 | 0 | 1 | 1 | 1 | X
2 | Quick stop | 1 | 1 | 1 | X | 0 | 1 | 1 | X
3 | Enable operation | X | 0 | 1 | X | X | 0 | 1 | X
7 | Fault reset | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
Transitions |  | 2,6,8 | 3 | 3+4 | 7,9,10,12 | 7,10,11 | 5 | 4.16 | 15

Bit | Definition
4 | ="1": Jog+(Manual+)
5 | ="1": Jog- (Manual-)
6 | ="0" (reserved)
8 | ="1": Halt (Stop with abort) with the "Slow Down" ramp (standard). Configurable via object 0x605D. Remains in state "Operation enabled".
9 | ="0" (reserved)
10 | ="0" (reserved)

11 | ="0" (reserved)
12 | ="0" (reserved)
13 | ="0" (reserved)
14 | ="0" (reserved)
15 | ="0" (reserved)


Status Word 1 (Status word) 0x6041.0x00 (op -1, jogging mode)

Bit |  | Not Ready to Switch on | Switch on disabled | Ready to Switch on | Switched on | Operation enabled | Quick stop active | Fault reaction active | Fault
0 | Ready to switch on | 0 | 0 | 1 | 1 | 1 | 1 | 1 | 0
1 | Switched on | 0 | 0 | 0 | 1 | 1 | 1 | 1 | 0
2 | Operation enable | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0
3 | Fault | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1
4 | Voltage enable | x | x | x | 1 | 1 | 1 | x | x
5 | Quick stop | x | x | 1 | 1 | 1 | 0 | x | x
6 | Switch On Disabled | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
7 | ="1": Warning (error with error response 0xE) is displayed. Bit automatically goes to "0" after the error cause is no longer present.
 | Description

8

="1": Speed=0 (drive motionless) (based on nominal value)

9 | ="1": Remote (parameters can be changed via fieldbus, control word is processed). ="0": The control word is not processed. However, objects can be read & described (unless in setup mode of the PSD ServoManager)

 | Description
10 | ="1": Target reached (corresponds to Position / Speed / Gearing reached) 1)
11 | ="1": Internal limit active / hardware end limits activated
12 | ="0"
13 | ="0"
14 | ="0"
15 | "0" STO inactive "1" STO active

1)

Bit 10 is set to 1 if operating mode has been changed.

If quick stop option code (object 0x605A) = 5, 6, 7 or 8, Bit 10 is set to 1 when the quick stop process is completed and the PSD has stopped.

If stop has occurred and the PSD was stopped, Bit 10 will also set to 1.


Operating mode - profile velocity mode (speed control)

In this chapter you can read about:

Speed monitoring

Control word 1 (Controlword) 0x6040.0x00 Profile Velocity Mode

Status word 1 (Status word) 0x6041.0x00 (op 3, Profile Velocity Mode)

Dynamic speed specification

Setting operating mode BA 0x6060.0x00 = +3

The speed controlled operation (profile velocity mode) includes the following sub-functions:

  • Setpoint generation by the ramp generator
  • Speed recording by differentiation of the position signal
  • Speed control by suitable input and output signals
  • Monitoring of the velocity by speed window and speed thresholds, each with adjustable times.

Function overview


Speed monitoring

There are various monitoring functions for the actual speed value (0x3309.02)

  • a target window
  • underrunning of a speed
  • exceeding a speed

the sensitivity of the display can be influenced over a certain time.

Structure:

Speed window

1 | 0x606D.0 speed window
2 | 0x606E.0 speed window time
3 | 0x330A.01 speed reached (no linkage to nominal value) Speed reached with setpoint linkage 0x606B = 0x60FF) DS402: Status word 1 Bit 10 PROFIdrive: Status word Bit 8
Reference speed 0x606F.0 not reached

1 | 0x606F.0 reference speed
2 | 0x6070.0 speed window
3 | 0x330A.02 speed not reached DS402: Status word Bit 12 PROFIdrive: no illustration in status word
Reference speed 0x3202.1 exceeded

1 | 0x3202.01 reference speed
2 | 0x3202.02 speed window
3 | 0x330A.03 speed exceeded DS402: no illustration in status word PROFINET: Status word 1 Bit 10


Control word 1 (Controlword) 0x6040.0x00 Profile Velocity Mode

Bit | Name | Shutdown | Switch on | Switch on & enable operation | Disable voltage | Quick stop | Disable operation | Enable operation | Fault / warning reset
0 | Switch on | X | 1 | 1 | X | X | 1 | 1 | X
1 | Enable voltage | 1 | 1 | 1 | 0 | 1 | 1 | 1 | X
2 | Quick stop | 1 | 1 | 1 | X | 0 | 1 | 1 | X
3 | Enable operation | X | 0 | 1 | X | X | 0 | 1 | X
7 | Fault reset | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
Transitions |  | 2,6,8 | 3 | 3+4 | 7,9,10,12 | 7,10,11 | 5 | 4.16 | 15

Bit

Name

Definition

4

="0" (reserved)

5

="0" (reserved)

6

="0" (reserved)

8

Halt

="0": Speed control active or speed control is continued
="1": Halt (Stop without abort) with the "Slow Down" ramp (standard). Configurable via object 0x605D

Writeable | Yes | Mapping on TxPD | No
Unit | - | Mapping on RxPD | No
Format | INT16 / Half integer / 16 Bit | Takes effect after | Immediately
Default value | Without default value |  |

Description

This object defines the desired Halt option code based on DS 402 specification.

This object shall indicate what action is performed when the halt function is executed. The slow down ramp is the deceleration value of the used mode of operations.

Halt option codes according to DS 402:

Value | Definition
-32768 to -1 | Manufacturer-specific
0 | Reserved
+1 (default) | Slow down on slow down ramp and stay in Operation Enabled
+2 | Slow down on quick stop ramp and stay in Operation Enabled
+3 | Slow down on current limit and stay in Operation Enabled
+4 | Slow down on voltage limit and stay in Operation Enabled
+5 to +32767 | Reserved

DS402 0x605D (Halt option code) value definition

PSD halt option code implementation:

Value | Definition
-32768 to -1 | Manufacturer-specific Slow down on slow down ramp and stay in Operation Enabled
0 | Reserved, will behave like this: Slow down on slow down ramp and stay in Operation Enabled
+1 (default) | Slow down on slow down ramp and stay in Operation Enabled
+2 | Slow down on quick stop ramp and stay in Operation Enabled
+3 | Slow down on current limit and stay in Operation Enabled
+4 | Slow down on voltage limit and stay in Operation Enabled
+5 to +32767 | Reserved, will behave like this: Slow down on slow down ramp and stay in Operation Enabled

PSD 0x605D (Halt option code) value definition

DS402 Cmd | Bits of control word |  |  |  |  | DS402 Transitions |  | Conditional Execution |  | Deceleration ramp used |  | Target State
 | 8 | 3 | 2 | 1 | 0
Halt | 1 | 1 | 1 | 1 | 1 |  | - |  | 0x605D=1 *) **) |  | Slow down 1) |  | - (16 Halt (Standstill) ) or 13 operation enabled )
 |  |  |  |  |  |  |  |  | 0x605D=2 |  | Quick Stop 2)

*) PSD default, **) DS402 default

1) min slow down ramp is only used if deceleration is higher than with currently used motion deceleration

2) quick stop is only used if deceleration is higher than with currently used motion deceleration

9

="0" (reserved)

10

="0" (reserved)

11 | ="0" (reserved)
12 | ="0" (reserved)
13 | ="0" (reserved)
14 | Edge 0==>1: Set current actual position and target position to new value SetPositionMode (0x34E9.00) PositionOffset (0x34E8.00) Standard: Set to position 0 Status Indicator: Status word 1 (SW-1) or Statusword 1 Bit 14 See status word 1 (statusword) Profile velocity operating mode
15 | ="0" (reserved)


Status word 1 (Status word) 0x6041.0x00 (op 3, Profile Velocity Mode)

Bit |  | Not Ready to Switch on | Switch on disabled | Ready to Switch on | Switched on | Operation enabled | Quick stop active | Fault reaction active | Fault
0 | Ready to switch on | 0 | 0 | 1 | 1 | 1 | 1 | 1 | 0
1 | Switched on | 0 | 0 | 0 | 1 | 1 | 1 | 1 | 0
2 | Operation enable | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0
3 | Fault | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1
4 | Voltage enable | x | x | x | 1 | 1 | 1 | x | x
5 | Quick stop | x | x | 1 | 1 | 1 | 0 | x | x
6 | Switch On Disabled | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
7 | ="1": Warning (error with error response 0xE) is displayed. Bit automatically goes to "0" after the error cause is no longer present.
 | Description

8

="1": Speed=0 (drive motionless) (based on nominal value)

9 | ="1": Remote (parameters can be changed via fieldbus, control word is processed). ="0": The control word is not processed. However, objects can be read & described (unless in setup mode of the PSD ServoManager)

Description

10

Target reached 1)

="0" | STOP (Control word 1 Bit 8) ="0": Target speed not reached
 | STOP (Control word 1 Bit 8) ="1": Axis is braking
="1" | STOP (Control word 1 Bit 8) ="0": Target speed reached (corresponds to the set revolutions window)
 | STOP (Control word 1 Bit 8) =”1”. Target speed is 0 and is reached.

11

="1": Internal limit active / hardware end limits activated (not for homing)

12

="0" revolutions/speed is not 0 (corresponds to the set speed window)

="1" revolutions/speed is 0 (corresponds to the set revolutions window)

13

="0"

14

For control word 1 Bit 14 =1: "0": Triggered position setting; "1"=position setting successfully completed

otherwise ="0" (reserved)

15

"0" STO inactive "1" STO active

1)

By changing the setpoint, bit 10 ="0" is set (refers to control word bit 14).

Bit 10 is set to 1 if operating mode has been changed.

If quick stop option code (object 0x605A) = 5, 6, 7 or 8, Bit 10 is set to 1 when the quick stop process is completed and the PSD has stopped.

If stop has occurred and the PSD was stopped, Bit 10 will also set to 1.


Dynamic speed specification

Speed and acceleration can be dynamically be changed.

Example: Dynamic velocity and acceleration modification (without jerk limitation)

1)

A new motion set (velocity; acceleration = deceleration) is immediately taken over.

The jerk can only be modified when the axis is at standstill.


Operating mode: Profile Position Mode (Position control)

In this chapter you can read about:

Control word 1 (Controlword 1) 0x6040 (Profile position mode)

Status word 1 (status word) 0x6041.0x00 (profile position mode)

Positioning functions

Electronic gearbox - Gearing

Velocity in profile position mode

Setting of operating mode BA 0x6060 = +1

The following structure image shows the processing of the motion function (defined by target position as well as velocity, acceleration and delay) to internal setpoints.

As a result, the given max/min values are limited.

Object descriptions:

Example of a simple positioning

Motion objects


Control word 1 (Controlword 1) 0x6040 (Profile position mode)

Bit | Name | Shutdown | Switch on | Switch on & enable operation | Disable voltage | Quick stop | Disable operation | Enable operation | Fault / warning reset
0 | Switch on | X | 1 | 1 | X | X | 1 | 1 | X
1 | Enable voltage | 1 | 1 | 1 | 0 | 1 | 1 | 1 | X
2 | Quick stop | 1 | 1 | 1 | X | 0 | 1 | 1 | X
3 | Enable operation | X | 0 | 1 | X | X | 0 | 1 | X
7 | Fault reset | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
Transitions |  | 2,6,8 | 3 | 3+4 | 7,9,10,12 | 7,10,11 | 5 | 4.16 | 15

Bit

Definition

4

="1": New setpoint (Start)

5

="1": Change set immediately / change setpoint immediately

6

Mode0

abs/rel: setting of the positioning mode (see below)

8

Halt

="1": Halt (Stop without termination) (SlowDownRamp defined via 0x605D.0x00) remains in status “operation enabled"

Writeable | Yes | Mapping on TxPD | No
Unit | - | Mapping on RxPD | No
Format | INT16 / Half integer / 16 Bit | Takes effect after | Immediately
Default value | Without default value |  |

Description

This object defines the desired Halt option code based on DS 402 specification.

This object shall indicate what action is performed when the halt function is executed. The slow down ramp is the deceleration value of the used mode of operations.

Halt option codes according to DS 402:

Value | Definition
-32768 to -1 | Manufacturer-specific
0 | Reserved
+1 (default) | Slow down on slow down ramp and stay in Operation Enabled
+2 | Slow down on quick stop ramp and stay in Operation Enabled
+3 | Slow down on current limit and stay in Operation Enabled
+4 | Slow down on voltage limit and stay in Operation Enabled
+5 to +32767 | Reserved

DS402 0x605D (Halt option code) value definition

PSD halt option code implementation:

Value | Definition
-32768 to -1 | Manufacturer-specific Slow down on slow down ramp and stay in Operation Enabled
0 | Reserved, will behave like this: Slow down on slow down ramp and stay in Operation Enabled
+1 (default) | Slow down on slow down ramp and stay in Operation Enabled
+2 | Slow down on quick stop ramp and stay in Operation Enabled
+3 | Slow down on current limit and stay in Operation Enabled
+4 | Slow down on voltage limit and stay in Operation Enabled
+5 to +32767 | Reserved, will behave like this: Slow down on slow down ramp and stay in Operation Enabled

PSD 0x605D (Halt option code) value definition

DS402 Cmd | Bits of control word |  |  |  |  | DS402 Transitions |  | Conditional Execution |  | Deceleration ramp used |  | Target State
 | 8 | 3 | 2 | 1 | 0
Halt | 1 | 1 | 1 | 1 | 1 |  | - |  | 0x605D=1 *) **) |  | Slow down 1) |  | - (16 Halt (Standstill) ) or 13 operation enabled )
 |  |  |  |  |  |  |  |  | 0x605D=2 |  | Quick Stop 2)

*) PSD default, **) DS402 default

1) min slow down ramp is only used if deceleration is higher than with currently used motion deceleration

2) quick stop is only used if deceleration is higher than with currently used motion deceleration

Standstill via STOP is displayed by status word Bit 10 =”1” / positioning can be continued.

9

="0" (Unlike DS402, the function of a "1" is not supported)

10

="0" (reserved)

6 (Mode0) | 0 | 1 | 0 | 1 | 0 | 1 | 0 | 1
11 | reserved
12 | reserved
13 (Mode1) | 0 | 0 | 1 | 1 | 0 | 0 | 1 | 1
14 | reserved
15 (Mode2) | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 1
Mode2..0 (15,13,6) | 0 MoveAbs | 1 DS402 relative (e.g.ModeAdd) | 2 MoveRel | 3 Velocity | 4 Gearing1 | 5 RegMove | 6 RegSearch | 7 Gearing2

Selection of the positioning mode in the "direct positioning" operating mode with bit 6, 13 and 15:

Mode2..0

Bits 15,13,M0

M0 (Mode0):

DS402:

Bit 6

PROFIdrive:

Bit 12

15

13

M0

Selection of the motion function

0

0

0

MoveAbs

Absolute positioning: an already defined machine reference point (e.g. absolute value encoder) OR a successfully carried out machine zero move are required.

0

0

1

Relative positioning according to DS402

DS402 relative positioning corresponding to 0x60F2.0x00 "Positioning option codes"

Object 0x60F2.0x00:

bit 1 | bit 0 | Function
0 | 0 | Positioning relative to the previous target position (If this is not defined, this applies: relative to 0)
0 | 1 | Positioning relative to the current position setpoint 0x60FC.0x00 (output of the setpoint generator)
1 | 0 | Positioning relative to the position actual value 0x6064.0x00
1 | 1 | reserved

Can also be set via the ServoManager.

0

1

0

MoveRel

Relative positioning.

0

1

1

Velocity

(DS402,

PROFIdrive)

Speed control (with active position controller)

1

0

0

Gearing1

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only) without setting the transmission ratio.

1

0

1

RegMove

Reg-related positioning (Remaining route/route from registration mark, preparatory command for RegSearch)

1

1

0

RegSearch

Reg-related positioning (registration mark search)

1

1

1

Gearing2

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only)

with setting of the transmission ratio via positioning parameters (numerator=positioning target, denominator=positioning speed)

With each positioning mode the setpoint specification is made via target position (0x607A)

Change of the motion function

A change between the motion function is dynamically possible.


Status word 1 (status word) 0x6041.0x00 (profile position mode)

Bit |  | Not Ready to Switch on | Switch on disabled | Ready to Switch on | Switched on | Operation enabled | Quick stop active | Fault reaction active | Fault
0 | Ready to switch on | 0 | 0 | 1 | 1 | 1 | 1 | 1 | 0
1 | Switched on | 0 | 0 | 0 | 1 | 1 | 1 | 1 | 0
2 | Operation enable | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0
3 | Fault | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1
4 | Voltage enable | x | x | x | 1 | 1 | 1 | x | x
5 | Quick stop | x | x | 1 | 1 | 1 | 0 | x | x
6 | Switch On Disabled | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
7 | ="1": Warning (error with error response 0xE) is displayed. Bit automatically goes to "0" after the error cause is no longer present.
 | Description

8

="1": Speed=0 (drive motionless) (based on nominal value)

9 | ="1": Remote (parameters can be changed via fieldbus, control word is processed). ="0": The control word is not processed. However, objects can be read & described (unless in setup mode of the PSD ServoManager)

Description

10

Target reached 1)

="0": | STOP (Bit 8 in control word) ="0" target position / speed / gearing not reached Stop (Bit 8 in control word) =”1" axis slows down
="1": | Stop (Bit 8 in control word) ="0" target position reached & in "position reached" window / speed setpoint reached / In Gear (drive follows setpoint) Stop (Bit 8 in control word) =”1" velocity/ speed = 0

By changing the setpoint, bit 10 ="0" is set (refers to control word bit 14).

11

="1": Internal limit active / hardware end limits activated

12

="1": Setpoint acknowledge (new setpoint value is accepted)

13

="1": Following error

14

="1": Registration found (reg detected) / Gearing active (during synchronization & synchronicity achieved)

15

="1": STO active; = "0": STO inactive

1)

Bit 10 is set to 1 if operating mode has been changed.

If quick stop option code (object 0x605A) = 5, 6, 7 or 8, Bit 10 is set to 1 when the quick stop process is completed and the PSD has stopped.

If stop has occurred and the PSD was stopped, Bit 10 will also set to 1.


Positioning functions

In this chapter you can read about:

Positioning window - position reached

Continuous mode

MoveAbsolute, MoveRelative and MoveRel (DS402)

Positioning in reset mode (modulo)

Reg-related positioning (RegSearch, RegMove)


Positioning window - position reached

Position reached indicates that the target position is located within the position window.

In addition to the position window, a position window time is supported. If the actual position goes inside the position window, the position window time is started. If the actual position is still inside the position window after the position window time, "Position reached" is set.

If the actual position leaves the position window within the position window time, the position window time is started again.

When leaving the position window at "position reached" = "1", the position reached is immediately set to "0".

Position monitoring is active even if the position leaves the position window due to external measures.

The position monitoring is only active after the target position at the setpoint generator output has been reached (speed setpoint and acceleration setpoint = 0).

1: Position window (0x6067)

2: Position window time(0x6068)

3: Position reached with setpoint linkage (0x60FC.0 = 0x607A.0)


Position reached - examples

The diagram shows 2 position windows (12: in grey) and (13: in yellow):

1 | Target position
2 | Position setpoint and actual value progression
3 | Position setpoint at the output of the setpoint generator
4 | Actual position value
5 | Time until the setpoint generator has reached the target position
6 | Course of the position deviation (8) and the following error (7)
7 | Following error: Difference between actual position value and position setpoint at the output of the setpoint generator.
8 | Position offset: Difference between actual position value and target position.
9 | Position deviation falls below the position window (13), position reached (14) is only set, however, when the position setpoint at the output of the setpoint generator (3) has reached the target position and the position window time (arrow length) has expired. Also displayed by velocity (16) and acceleration (17) = 0
10 | Position deviation falls below the position window (12), position reached (15) is set, because now also the position setpoint at the output of the setpoint generator (3) has reached the target position and the position window time (arrow length) has expired. Also displayed by velocity (16) and acceleration (17) = 0 Then: Position deviation exceeds the position window (12), position reached (15) is reset immediately.
11 | Position deviation exceeds the position window (12) and the position window time (arrow length) has expired, position reached (15) is set.
12 | Position window small (grey)
13 | Position window large (yellow)
14 | Position reached for position window (13: in yellow)
15 | Position reached for position window (12: in yellow)
16 | Speed setpoint of the setpoint generator
17 | Acceleration setpoint of the setpoint generator


Continuous mode

Before each positioning, the setpoint is set to 0 and starts from there (with the detection of the start bit a new positioning command leads internally to a jump in the current (displayed and used as a basis for the next positioning target) positioning setpoint to value 0)

The actual position thus changes by the same distance (-> the following error remains unchanged).

Input e.g. for continuous feed applications with conveyor belt or feed roller with variable feed.

Notes:

This does not apply to the RegMove command, additive positioning (=relative positioning according to DS402 with 0x60F2 ‘relative option’ Bit = 0) and with the absolute test move.

Only PROFIdrive:

The operating mode is activated from firmware version 1.10.1 via bit 14 in control word 1 (CW1).

(Previously, it could only be permanently activated via the ServoManager or controlled via direct access to the object 0x60F2.0x00 Bit 15 ("1"= activated).)

DS402:

The continuous functionality is either permanently activated via the ServoManager or it can be directly dynamically controlled via object 0x60F2.0x00 Bit 15 ("1"=activated) depending on demand.


MoveAbsolute, MoveRelative and MoveRel (DS402)

Motion functions

MoveAbs: Absolute positioning.
MoveRel: Relative positioning.
MoveRelative (DS402): Relative positioning according to DS402

Motion functions are selected via the Control word.

Mode2..0

Bits 15,13,M0

M0 (Mode0):

DS402:

Bit 6

PROFIdrive:

Bit 12

15

13

M0

Selection of the motion function

0

0

0

MoveAbs

Absolute positioning: an already defined machine reference point (e.g. absolute value encoder) OR a successfully carried out machine zero move are required.

0

0

1

Relative positioning according to DS402

DS402 relative positioning corresponding to 0x60F2.0x00 "Positioning option codes"

Object 0x60F2.0x00:

bit 1 | bit 0 | Function
0 | 0 | Positioning relative to the previous target position (If this is not defined, this applies: relative to 0)
0 | 1 | Positioning relative to the current position setpoint 0x60FC.0x00 (output of the setpoint generator)
1 | 0 | Positioning relative to the position actual value 0x6064.0x00
1 | 1 | reserved

Can also be set via the ServoManager.

0

1

0

MoveRel

Relative positioning.

0

1

1

Velocity

(DS402,

PROFIdrive)

Speed control (with active position controller)

1

0

0

Gearing1

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only) without setting the transmission ratio.

1

0

1

RegMove

Reg-related positioning (Remaining route/route from registration mark, preparatory command for RegSearch)

1

1

0

RegSearch

Reg-related positioning (registration mark search)

1

1

1

Gearing2

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only)

with setting of the transmission ratio via positioning parameters (numerator=positioning target, denominator=positioning speed)
Change of the motion function

A change between the motion function is dynamically possible.


Movement objects for MoveAbs, MoveRel and MoveRel (DS402)

Motion functions are executed as displayed in the diagrams below:

  • 1: Target position
  • 2: Travel speed
  • 3: Maximum Acceleration
  • 4: Maximum deceleration
  • 5: Jerk

Target position / distance

Target position or distance in the selected length unit.
Object 0x607A (32 Bit) or 0x341C.0x01 (I16)

Note:

For velocity (Modebits2...0=011), the target position is used as the target speed.
For Gearing2 (Modebits2...0=111), the target position is used as the transmission ratio numerator.

Speed

(Maximum) velocity in length unit/s

Object 0x6081 (32 Bit unsigned) or 0x341C.0x02 (U16)

Note:

For Gearing2 (Modebits2...0=111), the target speed is used as the transmission ratio denominator.

Acceleration

Acceleration in length unit/s2

Object 0x6083 (32 Bit) or 0x341C.0x03 (U16)

Deceleration (only during positioning)

Deceleration in length unit/s2

Object 0x6084 (32 Bit) or 0x341C.0x04 (U16)

With deceleration = 0 is deceleration = acceleration

Jerk

The jerk can be reduced in the setpoint path via a variable average-value filter (ramp filter).

Object: 0x60A4.1


Dynamic positioning

Dynamic acceleration, speed and target position are realized.

Jerk cannot be changed dynamicilly.

Example 1 Control word Bit 5 ="1": Change set immediately / change setpoint immediately

The changed target speed (3) as well as the changed target position (5) was accepted immediately during an active positioning with the signal STW1 Bit 4 “New set-point”.

Example 2 Control word Bit 5 =”0": Do not change setpoint immediately

The changed target position with modified speed is not accepted immediately with the signal CW1 Bit 4 “New set-point” but only after the active positioning is completed (0x60FC.0 = 0x607A.0).


Motion sequence

Example 1: Control word 1 Bit 5 = "1": Change setpoint immediately

  • The control word Bit 4 ="1" activates the target position (object 0x607A.0x00).
  • The motion is started and
  • bit 12 of the status word =”1” shows that the target position was accepted.
  • Bit 12 of the status word is active until control word bit 4 is reset.
  • Now a new target position can be specified which is only activated by control word bit 4 ="1".
  • Via bit 12 of the status word =”1” “position reached” is issued.

Further examples


Positioning in reset mode (modulo)

Reset mode is available for applications in which the positioning range repeats; some examples are: Rotary table applications, conveyor....

After the reset distance, which can be exactly specified as numerator and denominator, the position values in the drive are reset to 0.

Example:

Conveyor belt with reset path

A reset path of 300 000 mm can be entered directly with numerator = 300 000 mm and denominator = 1.

Reset operation is not possible for linear motors!


Position mode Modulo (reset mode)
Defining and activating the Modulo operation:

Setting the reset distance via the numerator (numerator = object 0x3120.0x0B) > and denominator (denominator = object 0x3120.0x0C) > 0! in increments.

This can be set in the ServoManager or directly via the objects.

Functions of the Modulo operation

In Modulo mode, the following functions can be selected for absolute positioning with the PSD ServoManager or directly via object 0x60F2.0x00:

Positioning

0x60F2.0x00

remarks

bit 7

bit 6

Normal

0

0
  • Usual positioning similiar to linear axis.
  • When the position range limits are reached or exceeded, the input value automatically moves to the other end of the range.
  • The range limit is at 0 .... Numerator/Denominator (defined by object 0x3120.B and 0x3120.C)
  • Positioning can be relative or absolute.
  • Only with this bit combination is the movement greater than a Modulo value.
  • Standard setting.

Only negative direction

0

1
  • Positioning only in a negative direction, minimal positioning limit = 0
  • If the target position is greater than the actual position, the axis moves over the minimum position limit (=0) to the target position.
  • If position 0 (minimum position) is reached, the value skips to numerator/ denominator.

Only positive direction

1

0
  • Positioning only in a positive direction
  • If the target position is smaller than the actual position, the axis moves over the maximum position limit (0x3120.0x0B/0x3120.0x0C) to the target position.
  • If numerator/denominator (maximum position) is reached, the position value skips to 0

Shortest route

1

1
  • Positioning with the shortest path to the target position
  • If the difference between the actual value and target position is 50% of the reset distance, the drive runs positively.
    I.e., if the difference in e. g. a 360° system is 180°, the axis moves in a positive direction.

With active Modulo positioning, the software end limits are not monitored.

Dynamic positioning

In dynamic positioning, a decision concerning the positioning travel is not taken on the basis of the actual position, but on the basis of the braking position resulting from the motion parameters.

Please note:

  • For positioning specifications smaller than zero and greater than or equal to the reset distance, the drive moves with the "Normal" positioning.
    For Modulo positioning, the positioning target e. g. for reset distance 360° must lie in the 0..359.999999° range.
  • The positioning functions are neither effective in test movements nor in an automatic positioning after homing travel (if this was not deactivated in the configuration).
  • When operating the PSD with CODESYS Softmotion (e.g. with Parker PAC Controller), Modulo should be configured on the controller side for softmotion axis and NOT on the drive side. In this case, software end limit errors and Modulo on the drive side must be deactivated!


Examples

In this chapter you can read about:

One-way lock

Shortest path


One-way lock

In this chapter you can read about:

Example: Reset distance 360°, lock in negative direction

Example: Reset distance 360°, lock in positive direction

Example: Reset distance 360°, lock in negative direction, dynamic positioning

Example: Reset distance 360°, lock in positive direction, dynamic positioning


Example: Reset distance 360°, lock in negative direction

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in negative direction

Target position 340°, target position 330°

-> actual movement by 330-340=-10°

Correction: Movement by -10°+360°=350°

-> target = old target position+350°= target position + 360°=690°


Example: Reset distance 360°, lock in positive direction

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in positive direction

Target position 30, target position 180°

-> actual movement by 180-30=+150°

Correction: Movement by 150°-360°=-210°

Target = old target position -210° = target position-360°=-180°


Example: Reset distance 360°, lock in negative direction, dynamic positioning

Parker Servo Drive
Example: Reset distance 360°, lock in negative direction, dynamic positioning

In this chapter you can read about:

Example: Reset distance 360°, lock in negative direction, dynamic positioning: n<0

Example: Reset distance 360°, lock in negative direction, dynamic positioning: n>0


Example: Reset distance 360°, lock in negative direction, dynamic positioning: n<0

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in negative direction, dynamic positioning: n<0

current target position 10°, target position 180°, braking position -40°

-> movement after braking by 180--40=+220°

Correction:

None

current target position 10°, target position 180°, braking position -400°

-> movement after braking by 180--400=+580°

Correction:

Target = target position-360°=180°-360°=-180°

current target position 10°, target position 330°, braking position -60°

-> movement after braking by 330--60=+390°

Correction:

Target = target position-360°=330°-360°=-30°

Current target position 30°, target position 10°, braking position -40° (320°)

-> movement after braking by 10--40=+50°

Correction:

None

Current target position 30°, target position 340°, braking position -40° (320°)

-> movement after braking by 340--40=+380°

Correction:

Target = target position-360°=340°-360°=-20°


Example: Reset distance 360°, lock in negative direction, dynamic positioning: n>0

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in negative direction, dynamic positioning: n>0

Current target position 330°, target position 355°, braking position 390° (30°)

-> movement after braking by 355-390=-35°

Correction:

Target = target position +360°=715°

Current target position 330°, target position 5°, braking position 390° (30°)

-> movement after braking by 5-390=-385°

Correction:

Target = target position +2*360°=715°

Current target position 330°, target position 50°, braking position 390° (30°)

-> movement after braking by 50-390=-340°

Correction:

Target = target position +360°=410°

Current target position 330°, target position 50°, braking position 750° (30°)

-> movement after braking by 50-750=-700

Correction:

Target = target position +2*360°=770°


Example: Reset distance 360°, lock in positive direction, dynamic positioning

Parker Servo Drive
Example: Reset distance 360°, lock in positive direction, dynamic positioning

In this chapter you can read about:

Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0

Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0


Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0

Current target position 10°, target position 180°, braking position 40°

-> movement after braking by 180-40=+140°

Correction:

Target = target position-360°=-180°

Current target position 10°, target position 180°, braking position 400°

-> movement after braking by 180-400=+220°

Correction:

None

Current target position 10°, target position 180°, braking position 760°

-> movement after braking by 180-760=-580°

Correction:

Target = target position +360°=540°


Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, lock in positive direction, dynamic positioning: n>0

Current target position 30°, target position 10°, braking position –40° (320°)

-> movement after braking by 10--40=+50°

Correction:

Target = target position-360°=10°-360°=-350°

Current target position 30°, target position 340°, braking position –40° (320°)

-> movement after braking by 340--40=+380°

Correction:

Target = target position2*360°=340°-2*360°=-380°

Current target position 30°, target position 300°, braking position –40° (320°)

-> movement after braking by 300--40=+340°

Correction:

Target = target position-360°=300°-360°=-60°

Current target position 30°, target position 300°, braking position -400° (320°)

-> movement after braking by 300--400=+700°

Correction:

Target = target position2*360°=300°-2*360°=-420°


Shortest path

In this chapter you can read about:

Example: Reset distance 360°, shortest path (static)

Example: Reset distance 360°, shortest path with dynamic positioning


Example: Reset distance 360°, shortest path (static)

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, shortest path (static)

Target position 30, target position 350°

-> actual movement by 350-30=320°

Correction:

-> Target = target position-360°=-180°

Target position 330, target position 10°

-> actual movement by 10-330=-320°

Correction:

Target = target position +360°=370°


Example: Reset distance 360°, shortest path with dynamic positioning

Parker Servo Drive

Vorige Seite

Nächste Seite

Example: Reset distance 360°, shortest path with dynamic positioning

Current target position 330°, target position 355°, braking position 390° (30°)

-> movement after braking by 355-390=-35°

Correction:

none

Current target position 330°, target position 5°, braking position 390° (30°)

-> movement after braking by 5-390=-385°

Correction:

Target = target position +360°=365°

Current target position 330°, target position 200°, braking position 390° (30°)

-> movement after braking by 200-390=-190°

Correction:

Target = target position +360°=560°

Current target position 330°, target position 220°, braking position 390° (30°)

-> movement after braking by 220-390=-170°

Correction:

none


Reg-related positioning (RegSearch, RegMove)

The Touch Probe functionality cannot be used simultaneously with RegSearch / RegMove.

For registration mark-related positioning, 2 motions are defined.

RegSearch

Search movements: Relative positioning to search for an external signal - a registration mark
This can e. g. be a label on a product.

The maximum search distance is specified via the TargetPositionAxis object (0x607A.0x00).

If a direction reversal is necessary to reach the target, error 0x7386 is issued.

The standard movement objects apply for this positioning.

For the search movement, a "restricted area" or an "allowed area" can be defined for the registration mark - registration mark window.

RegMove

The external signal interrupts the search movement (RegSearch) and the second movement follows without transition by an offset.

The offset (of RegSearch) is defined via object TargetPositionAxis ((0x607A.0x00)). After start permit for RegMove, the previously transferred TargetPositionAxis becomes visible in the Position Offset status object (0x34C8.0x00).

The drive comes to a standstill at the position of the mark signal + the configured offset (remaining route).

The standard movement objects apply for this positioning.

The movement functions are selected via the control word.

Mode2..0

Bits 15,13,M0

M0 (Mode0):

DS402:

Bit 6

PROFIdrive:

Bit 12

15

13

M0

Selection of the motion function

0

0

0

MoveAbs

Absolute positioning: an already defined machine reference point (e.g. absolute value encoder) OR a successfully carried out machine zero move are required.

0

0

1

Relative positioning according to DS402

DS402 relative positioning corresponding to 0x60F2.0x00 "Positioning option codes"

Object 0x60F2.0x00:

bit 1 | bit 0 | Function
0 | 0 | Positioning relative to the previous target position (If this is not defined, this applies: relative to 0)
0 | 1 | Positioning relative to the current position setpoint 0x60FC.0x00 (output of the setpoint generator)
1 | 0 | Positioning relative to the position actual value 0x6064.0x00
1 | 1 | reserved

Can also be set via the ServoManager.

0

1

0

MoveRel

Relative positioning.

0

1

1

Velocity

(DS402,

PROFIdrive)

Speed control (with active position controller)

1

0

0

Gearing1

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only) without setting the transmission ratio.

1

0

1

RegMove

Reg-related positioning (Remaining route/route from registration mark, preparatory command for RegSearch)

1

1

0

RegSearch

Reg-related positioning (registration mark search)

1

1

1

Gearing2

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only)

with setting of the transmission ratio via positioning parameters (numerator=positioning target, denominator=positioning speed)

Accuracy of the reg detection: ±62.5 µs


Motion profile with RegSearch, RegMove

The movement profile for RegSearch and RegMove is specified via the standard movement objects and can be specified cyclically or acyclically as required.

The respective objects are stored in the drive and must only be resend to the drive if the values change.

If a direction reversal is necessary to reach the target, error 0x7386 is issued.

With RegMove the jerk is taken over by RegSearch, the target position corresponds to the position offset (path up from marker).


Define reg-related positioning / denied zone or clearance window

In this chapter you can read about:

StartIgnore > StopIgnore

Within the reg window a reg signal will be ignored.

The reg window is defined by

Start of the lock-out zone (object 0x34B8: StartIgnoreAxis)

and

End of lock-out zone (Object 0x34B9: StopIgnoreAxis)

defined.

Beginning and end of the lock-out zone are absolute values and therefore also valid with negative position values. The positions of the two reg windows are interpreted relatively to the positon during "Start" of RegSearch (actual position).

Please note:

The reg. restriction window is the same for all reg motion sets!

Function:

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg window: Beginning of Registration lock-out zone (StartIgnore)
StopIgnore: | Reg window: End of Registration lock-out zone (StopIgnore)
Reg: | Reg signal (configurable input)
Regf | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)


StartIgnore > StopIgnore

By StartIgnore > StopIgnore a reg release window can be defined:


Examples

In this chapter you can read about:

Example: Example - reg related positioning process

Example 1: Reg comes after the reg restriction window

Example 2: Reg within the reg restriction window

Example 3: Reg is missing or comes after termination of the RegSearch motion set

Example 4: Reg comes before the reg restriction window

Example 5: The registration mark comes after the reg restriction window, registration mark can, however, not be reached without direction reversal


Example: Example - reg related positioning process

StartIgnore > StopIgnore

Sequence: First, specify the remaining distance / positioning offset via RegMove and then the RegSearch function.

Process for setting the remaining distance/ position offset:

  • (1) Write position offset (remaining distance, relative to the detected reg position) into the object 0x607A.0x00 & set control word 1 4 ="0”.
  • (2) Accept RegMove parameter: control word 1, Bit 15=”1” & Bit 13=”0” & set <VAR_Bewegungsfunktion_3rd_Bit_6_12>="1" and Start Bit 4= "1" .
  • (2) Confirmation that RegMove Offset value is correctly loaded via the Bit status word 1, setpoint acknowledgement Bit 12= edge 0 -> 1.
  • (2) The motion objects are buffered for RegMove.
    0x607A.0x00 => 0x34C8.0x00 (Positionen offset)
    0x6081.0x00 => 0x34CA.0x00 (Velocity)
    0x6083.0x00 => 0x34CB.0x00 (Acceleration)
    0x6084.0x00 => 0x34CC.0x00 (Deceleration)
    With this, different motion objects can be defined for RegSearch & RegMove.
  • (3)Control word 1, reset Start Bit 4 to="0"
  • Then start the positioning for the RegSearch as follows.

Procedure of the RegSearch function.

  • (3) Load maximum position value via the object target position 0x607A.0x00 & set control word 1 start Bit 4 ="0”. Check
    all remaining motion parameters for this movement.
  • (4), (5) Start RegMove movement: control word 1, Bit 15=”1” & Bit 13=”1” & set <VAR_Bewegungsfunktion_3rd_Bit_6_12>=”0" and Start Bit 4= "1".
  • (5) Confirmation that RegSearch movement is correctly started via the status word 1, setpoint acknowledgement Bit 12= edge 0 -> 1.
  • (6) Control word 1, reset Start Bit 4 to="0"
  • (7) on the Reg detection via Status word 1, Bit 14=”1” (Reg detected).
    RegMove starts with motion parameters from 0x34C...
  • (8) Waiting for the RegMove done detection via the status word 1, Bit 10= "1".


Example 1: Reg comes after the reg restriction window

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg ignore window: Beginning of lock-out zone
StopIgnore: | Reg ignore window: End of lock-out zone
Reg: | Reg signal (configurable input)
Regf: | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)


Example 2: Reg within the reg restriction window

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg ignore window: Beginning of lock-out zone
StopIgnore: | Reg ignore window: End of lock-out zone
Reg: | Reg signal (configurable input)
Regf: | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)

The reg is ignored; the drive moves to the target position from the RegSearch motion set.


Example 3: Reg is missing or comes after termination of the RegSearch motion set

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg ignore window: Beginning of lock-out zone
StopIgnore: | Reg ignore window: End of lock-out zone
Reg: | Reg signal (configurable input)
Regf: | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)

The drive moves to the target position from the RegSearch motion set


Example 4: Reg comes before the reg restriction window

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg ignore window: Beginning of lock-out zone
StopIgnore: | Reg ignore window: End of lock-out zone
Reg: | Reg signal (configurable input)
Regf: | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)

As from the reg, the drive moves on relatively by the offset defined in RegMove and then stops at that position (same behavior as in example 1).


Example 5: The registration mark comes after the reg restriction window, registration mark can, however, not be reached without direction reversal

Braking path > RegMove Offset, i.e., the desired distance after Reg cannot be achiebed without reverse movement; an error is generated:

Start | Start signal for reg positioning
RegSearch: | Positioning for reg search
RegMove: | Positioning according to reg
StartIgnore: | Reg ignore window: Beginning of lock-out zone
StopIgnore: | Reg ignore window: End of lock-out zone
Reg: | Reg signal (configurable input)
Regf: | Signal: Reg detected (Status word 1 Bit 14)
POS: | Signal: Position reached (Status word 1 Bit 10)

Error

Status word 1 Bit3

Remedy:

  • Change RegMove motion objects: Decrease deceleration time & increase velocity.
  • Increase RegMove distance-
  • Move Reg position.


Electronic gearbox - Gearing

For PSD1-M multi axes devices (2- or 3- axes devices) an electronic gearbox (Gearing) underneath the axes is possible.

With the Gearing motion function (electronic gear), PSD slave axis is moved synchronously to a PSD master axis. A 1:1 synchronism or any transmission ratio can be selected via the gear factor.

A negative sign of the transmission ratio numerator (which means reversal of direction) is permitted.

The function is configured via the objects:

0x34AC.0x2

Gearing operating mode:

Signal source:
0x0001: Setpoint position value axis 1

0x0002: Setpoint position value axis 2

0x0003: Setpoint position value axis 3

0x0007: Actual position value axis 1

0x0008: Actual position value axis 2

0x0009: Actual position value axis 3

Signal source must always be another axis.

0x34AA.0x0

(I32)

Numerator transmission factor

Gearing1 (Modebits 2..0 =100):

The numerator must be set prior to setting the startbit via object 0x34AA.0 (once in the object, cyclically or acyclically via field bus). Default value is 1.

Gearing2 (Modebits 2..0 =111):

The numerator is set on the content of the object 0x607A.0 (TargetPosition, I32) or 0x341C.0x01 (I16) when the startbit is recognized. The object 0x34AA.0 may not be additionally described directly by the bus for Gearing2.

These values can only be modified when the axis is at a standstill!

By specifying numerator and denominator, accuracy is increased and long-term drift is avoided.
The values must not be 0.

A negative factor is possible (numerator <0).

0x34AB.0x0

(U32)

Denominator transmission factor

Gearing1 (Modebits 2..0 =100):

The denominator must be set prior to setting the startbit via object 0x34AB.0 (once in the object, cyclically or acyclically via field bus). Default value is 1.

Gearing2 (Modebits 2..0 =111):

The denominator is set on the content of the object 0x6081.0 (ProfileVelocity, U32) or 0x341C.0x02 (U16) when the startbit is recognized. The object 0x34AB.0 may not be additionally described directly by the bus for Gearing2.

0x34A8.0x0

Acceleration to reach synchronicity
Please note:
  • Behavior: the drive accelerates (with acceleration 0x34A8.0x0) until the master speed is reached - this is shown with Bit 10 Synchronicity reached. Position losses during acceleration to master speed are not made up.
  • If the torque synchronicity is not achieved e.g. because of limiting effects, the position difference that arises will be made up (by the active position controller).

The transmission factors (0x34AA.0x0 & 0x34AB.0x0) can only be modified when the axis is at a standstill!


Velocity in profile position mode

In this chapter you can read about:

Dynamic speed specification at motion function velocity in profile positioning mode

The motion function “velocity” (speed control) in profile position mode is used like a normal positioning. The function “STOP” (CW1 Bit 8=“1”) is used as stop with termination.

The movement functions are selected via the control word.

Mode2..0

Bits 15,13,M0

M0 (Mode0):

DS402:

Bit 6

PROFIdrive:

Bit 12

15

13

M0

Selection of the motion function

0

0

0

MoveAbs

Absolute positioning: an already defined machine reference point (e.g. absolute value encoder) OR a successfully carried out machine zero move are required.

0

0

1

Relative positioning according to DS402

DS402 relative positioning corresponding to 0x60F2.0x00 "Positioning option codes"

Object 0x60F2.0x00:

bit 1 | bit 0 | Function
0 | 0 | Positioning relative to the previous target position (If this is not defined, this applies: relative to 0)
0 | 1 | Positioning relative to the current position setpoint 0x60FC.0x00 (output of the setpoint generator)
1 | 0 | Positioning relative to the position actual value 0x6064.0x00
1 | 1 | reserved

Can also be set via the ServoManager.

0

1

0

MoveRel

Relative positioning.

0

1

1

Velocity

(DS402,

PROFIdrive)

Speed control (with active position controller)

1

0

0

Gearing1

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only) without setting the transmission ratio.

1

0

1

RegMove

Reg-related positioning (Remaining route/route from registration mark, preparatory command for RegSearch)

1

1

0

RegSearch

Reg-related positioning (registration mark search)

1

1

1

Gearing2

Electronic gearing to setpoints or actual values (PSD1-M multi-axis devices only)

with setting of the transmission ratio via positioning parameters (numerator=positioning target, denominator=positioning speed)


Dynamic speed specification at motion function velocity in profile positioning mode

Speed and acceleration can be dynamically be changed.

Example: Dynamic velocity and acceleration modification (without jerk limitation)

1)

A new motion block (velocity, acceleration = deceleration) is accepted with “New Set point” STW1 Bit 4=”1”.

The jerk can only be modified when the axis is at standstill.


Touch Probe - store effective position event controlled

In this chapter you can read about:

Touch Probe function: Object 0x60B8

Touch Probe status: 0x60B9

Touch Probe trigger source: 0x60D0.1

Independent from the operating mode the effective position can be captured event controlled with this function.

  • The function Touch Probe is realized according to DS402 V3.
  • The function supports one channel (probe 1)
  • The 4 digital inputs can be used as trigger input (input 0 is standard)
  • The actual position values are memorized with positive and negative edge of the trigger input.
  • As soon as the event occurs the first time it will be triggered; continuous mode (continuous) is in planning stage.
  • Triggering with the hardware or software zero pulse of the positioning encoder is in planning stage.
  • The accuracy of the recording is ±62.5 µs.

The Touch Probe functionality cannot be used simultaneously with RegSearch / RegMove.
Function overview

Illustrated below is the operation with digital input I0. The remaining inputs may be configured the same way.

Procedure:

Activate Touch Probe 1 (0x60B8 Bit 0 =1)

Activate desired reaction with positive/ negative edge (0x60B8) Bit 4 & 5)

PSD is waiting for the triggering event.

The status (0x60B9) can be used to determine whether a value has been saved.

The identified position value can be found in 0x60BA or 0x60BB.


Touch Probe function: Object 0x60B8

Bit | Value | Meaning
0 | 0 | Switch off Touch Probe 1
 | 1 | Switch on Touch Probe 1
1 | 0 | Trigger with 1. Event
 | 1 | Trigger with each event (in preparation)
3.2 | 00 | Trigger with a digital input configured in PSD ServoManager
 | 01 | in preparation
 | 10 | The trigger source is defined by object 0x60D0.01.
 | 11 | factory use
4 | 0 | Touch Probe 1 switched off with positive edge
 | 1 | Touch Probe 1 switched on with positive edge
5 | 0 | Touch Probe 1 switched off with negative edge
 | 1 | Touch Probe 1 switched on with negative edge

Additional information can be found in the object list: 0x60B8


Touch Probe status: 0x60B9

Bit | Value | Meaning
0 | 0 | Touch Probe 1 switched off
 | 1 | Touch Probe 1 switched on
1 | 0 | Touch Probe 1 no value memorized with positive edge
 | 1 | Touch Probe 1 value memorized with positive edge
2 | 0 | Touch Probe 1 no value memorized with negative edge
 | 1 | Touch Probe 1 value memorized with negative edge

Additional information can be found in the object list: 0x60B9


Touch Probe trigger source: 0x60D0.1

Value | Meaning
0 | factory use
1 | Touch Probe 1 trigger source is digital input 0
2 | Touch Probe 1 trigger source is digital input 1
3 | Touch Probe 1 trigger source is digital input 2
4 | Touch Probe 1 trigger source is digital input 3
> 4 | factory use

Additional information can be found in the object list: 0x60D0.1


PSD objects

In this chapter you can read about:

Object access via TCP/IP

The object numbers of the objects provided in the instructions always refer to the first axis of a multi-axis module or to a single-axis drive PSD1-S.

The objects are structured as follows:

Object number range | Range for ...
0x2000 ... 0x2FFF | Device-specific objects (not axis-specific)
0x3000 ... 0x3FFF | Manufacturer specific objects for axis 1 (= single axis)
0x4000 ... 0x4FFF | Manufacturer specific objects for axis 2
0x5000 ... 0x5FFF | Manufacturer specific objects for axis 3
0x6000 ... 0x67FF | DS402 objects for axis 1 (= single axis)
0x6800 ... 0x6FFF | DS402 objects for axis 2
0x7000 ... 0x77FF | DS402 objects for axis 3

The object numbers of the 2nd and, where appropriate 3. axis can be determined as follows:

  • Manufacturer specific object axis 2 = manufacturer specific object axis 1 + 0x1000
    Manufacturer specific object axis 3 = manufacturer specific object axis 2 + 0x1000 = manufacturer specific object axis 1 + 0x2000

    Example "Stiffness (bandwidth) factor speed controller": 0x3822.1 (axis 1) => 0x4822.1 (axis 2) => 0x5822.1 (axis 3)
  • DS402 object axis 2 = DS402 object axis 1 + 0x800
    DS402 object for axis 3 = DS402 object for axis 2 + 0x800 = DS402 objects for object axis 1 + 0x1000

    Example "Target position": 0x607A (axis 1) => 0x687A (axis 2) => 0x707A (axis 3)

The object descriptions are available in the ObjectEditor.


Object access via TCP/IP

In this chapter you can read about:

Object dictionary

Object access via binary protocol

Object access via ASCII-Protokoll

  • Port 44821 with 3 access points is available for the access to the PSD via TCP/IP.
  • Objects of the PSD can be read and written via an ACII protocol or alternatively via a binary protocol (reduced data volume).
  • Via a Ethernet switch, several devices can be connected.
  • The same function (with a different IP address) is also available via the field bus interface (X62). The advantage is that the Switch is then needed.
    Note: With the EtherCAT bus, the EtherCAT master must support the functionality "EoE" (Ethernet over EtherCAT) for this.

The object descriptions are available in the ObjectEditor.


Object dictionary

In this chapter you can read about:

Object dictionary structure

Every parameter is represented by a single object structure containing describing attributes.

The object dictionary is organized according to CANopen CiA 301 specification and objects can be accessed via an index and a sub-index.

These objects are organized in the object dictionary, organized as array of object entry elements.

(Almost) all objects can be accessed acyclic via field-bus, some objects are marked to be allowed for fast PDO transfer. E.g., Read/write access is also one property of an object.

Because of its complexity the object dictionary is built by a PC-Tool that generates the required source code file for firmware compilation.


Object dictionary structure

In this chapter you can read about:

Structure of the object ID:

Structure of the SI units (International system of units) according to DS303_2:

Structure of an object entry:
Structure of the object ID:
typedef union {
 | struct { |  |  |
 |  | U16 | Index; | // object index
 |  | U16 | Subindex; | // object subindex
 | } w; |  |  |
 | U32 |  | uID; | // object identifier = (index << 16) + subindex
}T_OBJ_ID;

Structure of the SI units (International system of units) according to DS303_2:
typedef union {
 | struct { |  |
 | U8 | Profil; | // SI profile specific
 | U8 | Denominator; | // SI unit denominator
 | U8 | Numerator; | // SI unit numerator
 | U8 | Prefix; | // SI prefix
 | }b; |  |
 | U32 | uSI; | // SI unit
}T_SI_UNITS;

Structure of an object entry:
typedef struct {
 | T_OBJ_ID | sId; | // object Id
 | U8 | bSysDataType; | // system data type
 | U8 | bLen; | // sizeof(data)
 | U8 | bRawDataType; | // raw data type
 | U8 | bNormFactorSidx; | // normalization factor subindex
 | U32 | uAccess; | // data access flags
 | T_SI_UNITS | sUnit; | // SI unit
 | void* | pvData; | // pointer to object data/function
 | void* | pvRawData; | // pointer to object raw data
 | void* | pvNormFactor; | // pointer to normalization factor
 | U8* | pbName; | // pointer to object (parameter) name
 | void* | pvMinValue; | // pointer to data min value
 | void* | pvMaxValue; | // pointer to data max value
 | void* | pvDefaultValue; | // pointer to default value
}T_OBJECT;


Object access via binary protocol

In this chapter you can read about:

Frame layout

Add-on character coding

Write object - WrObj-Frame

Read object - RdObj-Frame

Write domain object - DownloadObj-Frame

Read domain object - UploadObj-Frame

Read dictionary - RdDic-Frame

Rsp-Frame data format coding

Error detection
  • The binary protocol with error detection is based on 10 different frames:
  • 5 request and 1 scope trigger telegrams the PLC sends to the drive
  • 4 response telegrams the drive sends to the PLC.


Frame layout

Basic structure:
Start Code | AddOn | Address | Number of Databytes - 1 | Data |  |  |  | Error detection
SC | Aon | Adr | L | D0 | D1 | ... | Dn | Crc(Hi) | Crc(Lo)
The start code defines the frame type and is composed as follows:
 | Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
SC | Frame Type | Frame ID |  |  |  | NOT USED | AddOn | Gateway | Address
0x8x | Not defined | 1 | 0 | 0 | 0 | x | x | x | x
0x9x | RdDic: read object dictionary entry | 1 | 0 | 0 | 1 | x | x | x | x
0xAx | RdObj: read object | 1 | 0 | 1 | 0 | x | x | x | x
0xBx | UploadObj: read domain object | 1 | 0 | 1 | 1 | x | x | x | x
0xCx | WrObj: write object | 1 | 1 | 0 | 0 | x | x | x | x
0xDx | DownloadObj: write domain object | 1 | 1 | 0 | 1 | x | x | x | x
0xEx | Not defined | 1 | 1 | 1 | 0 | x | x | x | x
0xFx | Not defined | 1 | 1 | 1 | 1 | x | x | x | x
0x02 | LongRsp: long response | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0
0x05 | Rsp: response | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 1
0x06 | Ack: positive acknowledgement | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0
0x07 | Nak: negative acknowledgement | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 1

Bit 7,6,5 and 4 of the start character are the identifier for the frame type.

Bit 3, 2, 1 and 0 have different meanings for the request and response frame.

Request_Frame

  • Address flag (Bit 0 = 1 ) indicates a following address byte
  • Gateway flag (Bit 1 = 1) indicates that this frame has to be routed to another destination
  • Add-On flag (Bit 2 = 0) indicates a following add-on byte

Response_Frame

  • Bit 2,1 and 0 are used to identify the response
  • Bit 3 always 0

The maximum number of data bytes in the request telegram is 256, in the response telegram 253,

if the length extension of the Add-On byte is not used.

The error detection with CRC16 is made via the CCITT table algorithm for all characters.

After receiving the start code, the timeout monitoring is activated in order to avoid that PSD waits in vain for further characters (e.g. connection interrupted).

The timeout period between 2 received characters is fixed to 100 ms


Add-on character coding

Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0
Routing |  |  | 0 | Request add-on
Routing |  |  | 1 | Length extension

This add-on character follows the start code, if the Add-on flag (Bit 2) in the start code is not set.

The routing flags (Bit 7...5) define 8 possible destinations for this frame, if the Gateway flag (Bit 1) in the start code is set. The length extension flag (Bit 4) defines the meaning of the following 4 flags (Bit 3...0).

Bit 4 = 0: Request add-on for 16 possible optional request tokens, used to expand the read/write object access

Bit 4 = 1: Length extension

Rd/WrObj => Number of data bytes = (Length extension * 256) + L.

UploadObj => L = L; Number m of octets = (Length extension * 256) + m.

DownloadObj => L = (Length extension * 256) + L; Number m of octets = (Length extension * 256) + m.

Routing Destination
Value | Destination
0 | Not defined
… | Not defined
7 | Not defined

Read Object Request Add-On coding
Value | Add-On
0 | Get value
1 | Get short info (data type, value, DicEntry index)
2 | Get info (name, data type, value, unit, DicEntry index)
3 | Get name
4 | Get data type
5 | Get unit
6 | Get limits
7 | Get addresses (value/function, raw data, norm.factor)
8 | Get raw data (type, value)
9 | Get raw data type
10 | Get raw data value
11 | Get normalization factor value


Write object - WrObj-Frame

Overwrite an object with the given value, drive answers with Ack- or Nak-Frame.

Data length = 1…256
SC | Aon | Adr | L | D0 | D1 | D2 | D3-Dn | Crc(Hi) | Crc(Lo)
1100x1xx |  |  | n-1 | Index(Hi) | Index(Lo) | Subindex | Value | 0x.. | 0x..

Data length = 1…1530
SC | Aon | Adr | L | D0 | D1 | D2 | D3-Dn-1 | Crc(Hi) | Crc(Lo)
1100x0xx | xxx1nnnn(Hi) |  | n (Lo) | Index(Hi) | Index(Lo) | Subindex | Value | 0x.. | 0x..

Positive acknowledgement - Ack-Frame
SC | L | D0 | D1 | Crc(Hi) | Crc(Lo)
0x06 | 1 | 0 | 0 | 0x.. | 0x..

drive response, if a write access was successful or a function is executed completely.

Negative acknowledgement - Nak-Frame
SC | L | D0 | D1 | Crc(Hi) | Crc(Lo)
0x07 | 1 | ErrNo.(Hi) | ErrNo.(Lo) | 0x.. | 0x..

drive response, if access to the object was denied (e.g. function cannot be executed at that point in time or object has no reading access). ErrNo is coded according to the CiA Device Profile DSP 402.


Read object - RdObj-Frame

Reading one or several objects drive answers with Rsp-, LongRsp-, Ack- or Nak-Frame.

Data length = 1…256
SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | D5 | ... | Dn | Crc(Hi) | Crc(Lo)
1010x1xx |  |  | n-1 | Idx1(Hi) | Idx1(Lo) | Sidx1 | Idx2(Hi) | Idx2(Lo) | Sidx2 | ... | ... | 0x.. | 0x..

Data length = 1…1530
SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | D5 | ... | Dn | Crc(Hi) | Crc(Lo)
1010x0xx | xxx1nnnn(Hi) |  | n (Lo) | Idx1 | Idx1 | Sidx1 | Idx2 | Idx2 | Sidx2 | ... | ... | 0x.. | 0x..

Response - Rsp-Frame
SZ | L | D0-Dx-1 | Dx-Dy-1 | Dy-D.. | D..-D.. | D..-Dn | Crc(Hi) | Crc(Lo)
0x05 | n-1 | Value 1 | Value 2 | Value 3 | Value.. | Value n | 0x.. | 0x..

drive response (n < 257), if the object can be read, else drive sends the Nak-Frame.

Long Response - LongRsp-Frame
SZ | Length |  | D0-Dx-1 | Dx-Dy-1 | Dy-D.. | D..-D.. | D..-Dn | Crc(Hi) | Crc(Lo)
0x02 | high | low | Value 1 | Value 2 | Value 3 | Value.. | Value n | 0x.. | 0x..

drive response (n > 256), if the object can be read, else drive sends the Nak-Frame.


Write domain object - DownloadObj-Frame

Write to a domain object the number m of octets (e.g. firmware download).

Drive response is Ack- or Nak-Frame.

Number of octets m = 1…253
SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | D5 | D.. | Dm-2 | Crc(Hi) | Crc(Lo)
1101x1xx |  |  | n-1 | Index(Hi) | Index(Lo) | m | Octet 1 | Octet 2 | Octet3 | … | Octet m | 0x.. | 0x..

Number of octets m = 1…1527
SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | D5 | D.. | Dm-2 | Crc(Hi) | Crc(Lo)
1101x0xx | xxx1nnnn(Hi) |  | n (Lo) | Idx(Hi) | Idx(Lo) | Sidx | Octet 1 | Octet 2 | Octet3 | … | Octet m | 0x.. | 0x..


Read domain object - UploadObj-Frame

Reading from a domain object the number m of octets (e.g. firmware upload).

Drive response is Rsp-, LongRsp- or Nak-Frame.

Number of octets m = 1…255
SC | Aon | Adr | L | D0 | D1 | D2 | Crc(Hi) | Crc(Lo)
1011x1xx |  |  | 2 | Index(Hi) | Index(Lo) | m | 0x.. | 0x..

or

SC | Aon | Adr | L | D0 | D1 | D2 | D3 | Crc(Hi) | Crc(Lo)
1011x1xx |  |  | 3 | Index(Hi) | Index(Lo) | Subindex | m | 0x.. | 0x..

or

SC | Aon | Adr | L | D0 | D1 | D2 | D3 | Crc(Hi) | Crc(Lo)
1011x0xx | xxx10000 |  | 4 | Index(Hi) | Index(Lo) | Subindex | m | 0x.. | 0x..

Number of octets m = 1…1530
SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | Crc(Hi) | Crc(Lo)
1011x1xx |  |  | 4 | Index(Hi) | Index(Lo) | Subindex | m (Hi) | m (Lo) | 0x.. | 0x..

or

SC | Aon | Adr | L | D0 | D1 | D2 | D3 | D4 | Crc(Hi) | Crc(Lo)
1011x0xx | xxx10000 |  | 5 | Index(Hi) | Index(Lo) | Subindex | m (Hi) | m (Lo) | 0x.. | 0x..


Read dictionary - RdDic-Frame

SC | Aon | Adr | L | D0 | D1 | D2 | D3 | Crc(Hi) | Crc(Lo)
0x9X |  |  | 3 | Index (Hi) | Index | Index | Index (Lo) | 0x.. | 0x..

Reading one dictionary entry by entry index

First entry index = 0

The number of dictionary entries can be read with index = 0xFFFFFFFF


Rsp-Frame data format coding

D0 | D1 | D2 | D3 | D4 | D5 |  | D6 | D7 | D8 | D9 | D10 |  | D11 | D12 | … | … | Dn
V_STRING, O_STRING
1. char | 2.cha | 3.cha | 4.cha | ... | ... |  | ... | ... | ... | ... | ... |  | ... | ... | ... | … | …
BYTE, UINT8, INT8
Value |
WORD, UINT16, INT16
1. Value |  | 2. Value |  | 3. Value |  |  | 4. Value |  | 5. Value |  | 6. Value |  |  | 7. Value |  | …
High | Low | High | Low | High | Low |  | High | Low | High | Low | High |  | Low | High | Low | High | Low
DWORD, UINT32, INT32, BOOL, FLOAD, TIME, DATE, TOD, DT
1. Value |  |  |  | 2. Value |  |  |  |  | 3. Value |  |  |  |  | …
High |  |  | Low | High |  |  |  | Low | High |  |  |  | Low | High |  |  | Low
LWORD, UINT64, INT64, DOUBLE
1. Value |  |  |  |  |  |  |  |  | 2. Value
High |  |  |  |  |  |  |  | Low | High |  |  |  |  |  |  |  | Low
Get Value
Value as shown above
Get Data Type
U8 DataType
Get Name
Parameter Name
Get Unit
U8 SI-Profile, U8 SI-Denominator, U8 SI-Numerator, U8 SI-Prefix
Get Limits
Min-Value as shown above, Max-Value as shown above
Get Addresses
U32 Value/Function address U32 Raw data address U32 Normalization factor address
Get Short Info
U8 DataType, Parameter Value as shown above (if V_STRING Null-terminated, if O_STRING 1. Byte = string length ), U32 Dictionary Entry Index
Get Info
Parameter Name Null-terminated, U8 Data Type, Parameter Value as shown above (if V_STRING Null-terminated, if O_STRING 1. Byte = string length), U8 SI-Profile, U8 SI-Denominator, U8 SI-Numerator, U8 SI-Prefix, U32 Dictionary Entry Index
Get Dictionary Entry Number
U32 Value as shown above
Get Dictionary Entry
Parameter Name Null-terminated
U8 DataType, U16 Index, U16 Subindex, U8 SIZEOF (Parameter), U8 RawDataType, U8 NormFactorSidx; U32 AccessFlags; |  |  |  |  |  | Parameter Value as shown above (if V_STRING Null-terminated) U8 SI-Profile, U8 SI-Denominator, U8 SI-Numerator, U8 SI-Prefix, Min-Value as shown above, |  |  |  |  |  | Max-Value as shown above U32 Address of Parameter value/Parameter function U32 Address of raw Parameter value, if this is a function U32 Address of Normalization factor


Error detection

The checksum of a frame is calculated via the following function and the corresponding table:

The "CRC16" variable is set to 0x0000 before starting the calculation for a frame.

Function call: CRC16 = UpdateCRC16(CRC16, Character);

This function is called for each Byte (Character) of the frame and the result gives the last two bytes of the frame

The drive checks the CRC value on receipt and reports CRC error in the case of a deviation.


CRC lookup table:

const unsigned int _P CRC16_table[256] = {

0x0000, 0x1021, 0x2042, 0x3063, 0x4084, 0x50a5, 0x60c6, 0x70e7,

0x8108, 0x9129, 0xa14a, 0xb16b, 0xc18c, 0xd1ad, 0xe1ce, 0xf1ef,

0x1231, 0x0210, 0x3273, 0x2252, 0x52b5, 0x4294, 0x72f7, 0x62d6,

0x9339, 0x8318, 0xb37b, 0xa35a, 0xd3bd, 0xc39c, 0xf3ff, 0xe3de,

0x2462, 0x3443, 0x0420, 0x1401, 0x64e6, 0x74c7, 0x44a4, 0x5485,

0xa56a, 0xb54b, 0x8528, 0x9509, 0xe5ee, 0xf5cf, 0xc5ac, 0xd58d,

0x3653, 0x2672, 0x1611, 0x0630, 0x76d7, 0x66f6, 0x5695, 0x46b4,

0xb75b, 0xa77a, 0x9719, 0x8738, 0xf7df, 0xe7fe, 0xd79d, 0xc7bc,

0x48c4, 0x58e5, 0x6886, 0x78a7, 0x0840, 0x1861, 0x2802, 0x3823,

0xc9cc, 0xd9ed, 0xe98e, 0xf9af, 0x8948, 0x9969, 0xa90a, 0xb92b,

0x5af5, 0x4ad4, 0x7ab7, 0x6a96, 0x1a71, 0x0a50, 0x3a33, 0x2a12,

0xdbfd, 0xcbdc, 0xfbbf, 0xeb9e, 0x9b79, 0x8b58, 0xbb3b, 0xab1a,

0x6ca6, 0x7c87, 0x4ce4, 0x5cc5, 0x2c22, 0x3c03, 0x0c60, 0x1c41,

0xedae, 0xfd8f, 0xcdec, 0xddcd, 0xad2a, 0xbd0b, 0x8d68, 0x9d49,

0x7e97, 0x6eb6, 0x5ed5, 0x4ef4, 0x3e13, 0x2e32, 0x1e51, 0x0e70,

0xff9f, 0xefbe, 0xdfdd, 0xcffc, 0xbf1b, 0xaf3a, 0x9f59, 0x8f78,

0x9188, 0x81a9, 0xb1ca, 0xa1eb, 0xd10c, 0xc12d, 0xf14e, 0xe16f,

0x1080, 0x00a1, 0x30c2, 0x20e3, 0x5004, 0x4025, 0x7046, 0x6067,

0x83b9, 0x9398, 0xa3fb, 0xb3da, 0xc33d, 0xd31c, 0xe37f, 0xf35e,

0x02b1, 0x1290, 0x22f3, 0x32d2, 0x4235, 0x5214, 0x6277, 0x7256,

0xb5ea, 0xa5cb, 0x95a8, 0x8589, 0xf56e, 0xe54f, 0xd52c, 0xc50d,

0x34e2, 0x24c3, 0x14a0, 0x0481, 0x7466, 0x6447, 0x5424, 0x4405,

0xa7db, 0xb7fa, 0x8799, 0x97b8, 0xe75f, 0xf77e, 0xc71d, 0xd73c,

0x26d3, 0x36f2, 0x0691, 0x16b0, 0x6657, 0x7676, 0x4615, 0x5634,

0xd94c, 0xc96d, 0xf90e, 0xe92f, 0x99c8, 0x89e9, 0xb98a, 0xa9ab,

0x5844, 0x4865, 0x7806, 0x6827, 0x18c0, 0x08e1, 0x3882, 0x28a3,

0xcb7d, 0xdb5c, 0xeb3f, 0xfb1e, 0x8bf9, 0x9bd8, 0xabbb, 0xbb9a,

0x4a75, 0x5a54, 0x6a37, 0x7a16, 0x0af1, 0x1ad0, 0x2ab3, 0x3a92,

0xfd2e, 0xed0f, 0xdd6c, 0xcd4d, 0xbdaa, 0xad8b, 0x9de8, 0x8dc9,

0x7c26, 0x6c07, 0x5c64, 0x4c45, 0x3ca2, 0x2c83, 0x1ce0, 0x0cc1,

0xef1f, 0xff3e, 0xcf5d, 0xdf7c, 0xaf9b, 0xbfba, 0x8fd9, 0x9ff8,

0x6e17, 0x7e36, 0x4e55, 0x5e74, 0x2e93, 0x3eb2, 0x0ed1, 0x1ef0

};


CRC function:

unsigned int UpdateCRC16(unsigned int crc,unsigned char value) {

unsigned int crc16;

crc16 = (CRC16_table[(crc >> 8) & 0x00FF] ^ (crc << 8) ^ (unsigned int)(value));

return crc16;

}


Object access via ASCII-Protokoll

In this chapter you can read about:

Command strings

Response strings

User commands

Switch features on/off

The general body of a command string is:

[#] [Adr] CMD CR

# optional gateway token for routing commands to another device

Adr max. 2 digits for optional address (routing)

CMD command tokens

CR delimiter (carriage return)

Command strings

  • Are built of visible ASCII characters (0x20 … 0x7E).
  • Lower case are converted automatically to upper case and spaces are removed, if the characters are not enclosed by double quote characters ( " ).
  • All commands start with an alphabetic character (A…Z) or with the underscore character ( _ ).
  • Integer and fractional part of numerical data is separated by a decimal point.
  • A number can be entered in the hex format by a leading dollar character (e.g. $12) and values can be requested in hex format with an additional dollar character before the delimiter character.
  • All characters less than 0x20 (except the delimiter) and greater than 0x7E (except start code of binary command) are filtered out and removed.
  • With the reception of a character greater than 0x7F the ASCII protocol is terminated, the received characters are discarded and automatically switched to the binary protocol.

Response strings

  • All received commands are acknowledged by a ASCII response string terminated with the delimiter character.
  • The length of the response depends on the given command.
  • A command that assigns a value to the drive or triggers a function is acknowledge by the prompt character ( > ).
  • Commands requesting data from the drive are acknowledged with the accordingly response string.
  • In the case of an error (e.g. wrong syntax, bad argument or no write access) the response has the format

!xxxxCR

The 4 digits following the exclamation mark represent the error code in hex format according to the CiA Device Profile DS402.


User commands

In this chapter you can read about:

Write object

Read object value

Read object name

Read object info

Read object data type

Read object unit

Read object limits

Read object flags

Read object normalization factor subindex

Read object raw data

Read object addresses

Read object command specifier overview

Read object dictionary entry


Write object

Writing a new value to a parameter.

O [$] Index , [$] Subindex = [$][%] ValueCR

The optional dollar character allows the hex input of Index, Subindex and Value (e.g. O$6040.0=$1F CR).

The optional percent character allows the input of a Value in the established IP-Address notation, but only if the data type is U32 (e.g. O$2500.4=%192.168.100.7 CR).

The response is >CR if the command was ok, or !xxxxCR if an error occurred.


Read object value

Reading the actual value of a parameter.

O [$] Index , [$] Subindex [$][%] CR

The optional dollar character after Subindex allows a hex output, therefore object values can be requested in hex format (e.g. O$6041.0$ CR à 0xhhhh CR).

Depending on the data type the response exists of 2, 4 or 8 hex digits.

The optional percent character allows the output of a Value in the established IP-Address notation, but only if the data type is U32 (e.g. O$2500.4%$ CR à 192.168.100.7 CR).


Read object name

Reading the name of a parameter.

O [$] Index , [$] Subindex N CR


Read object info

Reading the entry index, data type, name, value and unit of a parameter.

O [$] Index , [$] Subindex I CR

The response has the format Entryindex; Datatype; Name; Value; UnitCR


Read object data type

Reading the data type of a parameter.

O [$] Index , [$] Subindex T CR

A possible response for reading a parameter data type could be Int64CR


Read object unit

Reading the unit of a parameter.

O [$] Index , [$] Subindex U CR

A possible response for reading a parameter unit could be m*10^-3CR


Read object limits

Reading the min/max values of a parameter.

O [$] Index , [$] Subindex L CR

The response has the format MinValue; MaxValueCR


Read object flags

Reading the access flags of a parameter.

O [$] Index , [$] Subindex F CR

The response has the format FF; FF;..;..;FFCR

Possible access flags are

NO | None (no flag is set) | IN | Init
EX | Execute | WR | Write
MM | Min/Max Check | PR | Process data read
PW | Process data write | AR | Array
RC | Record (struct) | DO | Domain
CF | Config | DF | Default
VP | Valid parameter | MP | Motor plaid
DM | Developer Mode | LI | Set to Limit


Read object normalization factor subindex

Reading the subindex of the normalization factor.

O [$] Index , [$] Subindex S CR


Read object raw data

Reading the raw data value of a parameter.

O [$] Index , [$] Subindex R CR


Read object addresses

Reading the address of the parameter value/function, the raw data value and the norm. factor value.

O [$] Index , [$] Subindex A CR

The response format is:

Address of parameter value/function; Address of raw data value;

Address of normalization factor valueCR


Read object command specifier overview

The command specifier is used to get special object information as described above.

The common command for using it is:

O [$] Index , [$] Subindex Specifier [$][%] CR

Specifier | Object information
none | Object value
A | Address of object value/function, raw data value and normalization factor value
F | Access flags
I | Entry index, data type, name, value and unit
L | min/max values
N | Name
R | Raw data value
S | Normalization factor subindex
T | Data type
U | Units


Read object dictionary entry

Reading the dictionary entry of one existing object. The entry index starts with 0.

D Entryindex CR

The response format is:

Parameter name; Index; Subindex; Data type; SIZEOF(Parameter); Bus-Data type; Norm factor; Access flags; Parameter value; Parameter unit; Min value; Max value; Address of Parameter value/function;

Address of raw data value; Address of normalization factor valueCR

To read the number of existing objects type DCR


Switch features on/off

Enable or disable special communication features.

F Featurenumber CR

Error message

Enables/Disables the output of the ASCII error message.

F 1 CR


Error handling

In this chapter you can read about:

Calling up the error list in PSD servo manager

CSV export of errors

Error - & Event History (standard)

Failure condition & Event History (according to PROFIdrive)


Calling up the error list in PSD servo manager

You will find the description of the PSD error in the error list of the PSD ServoManager. Click on "Tools" under " [image] Show Error info..." or to "?" in the help menu.


CSV export of errors

In the ErrorViewer in the menu File you can export the objects as *.csv file.

The attributes of the error are separated by semicolons and can be read directly with Excel, for example.


Error - & Event History (standard)

In this chapter you can read about:

Error history

Event history


Error history

Object 0x32E0.0xn shows the 32 most recent errors that caused an error response. Error with the error response: "0xE: No reaction throw warning” are not recorded here.

n = 1: most recently occurred errors

...

n = 32 oldest error in the list

Object 0x32E1.0xn contains the operating time[ms] during which the respective error occurred.

Example: 361805200 ms: Operating time = 100 hours / 30 minutes / 5.2 s.


Event history

Object 0x32E8.0xn shows the 32 most recent events. Error with the error response: "0xE: No reaction throw warning” as well as acknowdgement are recorded here.

n = 1: most recent occured event

...

n = 32 oldest event in the list

Object 0x32E1.0xn contains the operating time[ms] during which the respective error occurred.

Example: 361805200 ms: Operating time = 100 hours / 30 minutes / 5.2 s.


Failure condition & Event History (according to PROFIdrive)

In this chapter you can read about:

Structure of error & event history according to PROFIdrive

Warning mechanisms via error - & event - Bits

Histories of 8 error states are recorded.

Each error status description records the last 8 errors & events (warnings).

When the errors are acknowledged, the complete error status is stored in the history.


Structure of error & event history according to PROFIdrive

Error conditions | Error code of errors & events PNU945.x Object 0x3C2D.x | Error time of error & events PNU948.x Objekt 0x3C30.x | Subindex*;
Current error state (n) | 0x7310 | Time 5 | 0x1
 | 0x2381 | Time 6 | 0x2
 | 0x5498: | Time 7 | 0x3
 | 0x2311 | Time 8 (newest entry) | 0x4
 |  |  | 0x5
 |  |  | 0x6
 |  |  | 0x7
 |  |  | 0x8
most recently acknowledged error state n-1 | 0x2381 | Time 1 | 0x9
 | 0x5498: | Time 2 | 0xA
 | 0x2311 | Time 3 | 0xB
 | 0x6083 | Time 4 (Last Error before quit) | 0xC
 |  |  | 0xD
 |  |  | 0xE
 |  |  | 0xF
 |  |  | 0x10
 | . . . | . . . | . . .
Oldest acknowledged error state n-7 |  |  | 0x39
 |  |  | 0x3A
 |  |  | 0x3B
 |  |  | 0x3C
 |  |  | 0x3D
 |  |  | 0x3E
 |  |  | 0x3F
 |  |  | 0x40

Errors are filled from top to bottom:

new error => | Error 1 |  |  | Error 1 |  |  | Error 1 |  |  | Error 1 |  |  | Error 1
 |  | 0 | new error => |  | Error 2 |  |  | Error 2 |  |  | Error 2 |  |  | Error 2
 |  | 0 |  |  | 0 | new error => |  | Error 3 |  |  | Error 3 |  |  | Error 3
 |  | 0 |  |  | 0 |  |  | 0 | new error => |  | Error 4 |  |  | Error 4
 |  | 0 |  |  | 0 |  |  | 0 |  |  | 0 | new error => |  | Error 5
 |  | 0 |  |  | 0 |  |  | 0 |  |  | 0 |  |  | 0
 |  | 0 |  |  | 0 |  |  | 0 |  |  | 0 |  |  | 0


Warning mechanisms via error - & event - Bits

Each error and each event is additionally reported via a Bit. For this, 8 "Warning Words" (PNU953 ... PNU960; corresponding objects 0x3C35 ... 0x3C3C) are defined.

The assignment of the error to the bit is made via the event ID.

You can find these in the object description of the "Warning Words" and in the Error list.

The corresponding bit ="1" means that the associated error has occurred; it automatically returns to "0" after the cause of the error is no longer present (after e.g. the motor temperature has dropped back down below the limit value).

Setting one or more warning bits is indicated by PROFIdrive status word Bit 7 ="1".


Technical data

In this chapter you can read about:

PSD1-S: Single device

PSD1-M: Multi-axes system

Motors/ feedback/ motor holding brake

Digital inputs / outputs (specifications)

Technical data STO

EC directives and applied harmonized EC norms (PSD1)

EMC limit values PSD1

Insulation requirements PSD1

Environmental requirements PSD1

cUL certification

Ethernet IP characteristics


PSD1-S: Single device

In this chapter you can read about:

Network connection PSD1-S

Output data PSD1-S 1/3*230 VAC

Control Voltage 24 VDC PSD1-S

Braking operation PSD1-S

Size / weight of PSD1-S


Size / weight of PSD1-S

Category | Specifications
Controller type | Weight [kg] | Dimensions Height x Width x Depth (mm]
PSD1-S_1200 | 1.33 | 200 x 50 x 180
PSD1-S_1300

Mounting


PSD1-M: Multi-axes system

In this chapter you can read about:

Mains Connection Power module PSD1-M_P010 without line choke

Mains connection Power module PSD1-M_P010 with line choke

Mains Connection Power module PSD1-M_P020 without line choke

Mains connection Power module PSD1-M_P020 with line choke

Output data servo modules PSD1-M (3*400 VAC)

Detailed output data Servo module PSD1-M

Control voltage 24 VDC PSD1-M (X9 on the mains module)

Braking operation PSD1-M

Dynamic braking module

Size / Weight PSD1-M


Control voltage 24 VDC PSD1-M (X9 on the mains module)

Category | Specification
Voltage range | 21.6 - 27.0 VDC (24 VDC -10 % +12.5 %)
Ripple | 0.5 Vpp
Requirement according to safe extra low voltage (PELV) | Yes
Electric current drain | PSD1-M_P010: 0.2 A PSD1-M_P020: 0.3 A ea. PSD1-M Axis: 1.0 A + Output current of digital outputs (fed via connectors X17/2, 3) + Output current of motor brakes (fed via connectors X46/7 & 8; PSD1M_1800 X44/3 & 4) + Current requirements of optional boards


Braking operation PSD1-M

Mains modules

Device type | PSD1-M_P010 | PSD1-M_P020
Capacity/ storable energy | 550 µF/ 92 Ws at 400 V 53 Ws at 480 V | 1175 µF/ 197 Ws at 400 V 114 Ws at 480 V
Minimum braking resistance | 27 W | 10 W
Recommended nominal power rating | 500 ... 1500 W | 500...5000 W
Pulse power for 1s | 22 kW | 60 kW
Maximum permissible continuous current | 13 A | 25 A
Servo Drives
Category | Specification
Controller type | PSD1-M (unless PSD1-M_1800) | PSD1-M_1800 (30 A)
Capacitance / storable energy (±20 %) | 220 mF / 37 Ws at 400 V 21 Ws at 480 V | 440 mF / 74 Ws at 400 V 42 Ws at 480 V


Dynamic braking module

Data of the integrated dynamic brake module PSD1-M_P
Category | Specifications
Mains module | Maximum current |  | Max. Duty Cycle | Minimum resistance value
 | Peak | Duration
PSD1-M_P010 | 28.8 A | 4.27 A (500 W) | 2.2 % (@60 s) | 27 W
 |  | 7.5 A (1500 W) | 6.7 % (@60 s)
PSD1-M_P020 | 78.0 A | 7.06 A (500 W) | 0.82 % (@60 s) | 10 W
 |  | 22.3 A (5000 W) | 8.2 % (@60 s)
Recommended braking resistors
Category | Specifications
Mains module | Minimum resistance value | Power
PSD1-M_P010 | 27 W | 500 W ... 1500 W
PSD1-M_P020 | 10 W | 500 W ... 5000 W

External ballast resistors from Parker.


Size / Weight PSD1-M

Category | Specifications
Controller type | Weight [kg] | Dimensions Height x Width x Depth (mm]
PSD1-M_1300 | 4 | 360 x 50 x 270
PSD1-M_1500
PSD1-M_1600
PSD1-M_P010
PSD1-M_2220 | 4
PSD1-M_2330
PSD1-M_2440
PSD1-M_2630
PSD1-M_3222 | 4.2
PSD1-M_3433
PSD1-M_1800 | 6.8 | 360 x 100 x 270
PSD1-M_P020 | 6,3

Mounting (Mounting and dimensions PSD1-M size 1, Mounting and dimensions PSD1-M size 2, Mounting and dimensions PSD1-S)


Motors/ feedback/ motor holding brake

In this chapter you can read about:

Motor technologies supported

Feedback system HIPERFACE DSL®

Resolver

Incremental encoder / analog Hall sensor

Motor holding brake output


Motor technologies supported

Category

Specifications

Motors

Direct drives

  • Linear motors
  • Torque motors
  • Sinusoidally commutated synchronous motors
    • Maximum rotating field frequency: 590 Hz
      max. Velocity: 60*590/number of pole pairs in [min-1].
    • Maximum number of poles = 1200
  • Temperature sensor supported:
    • KTY84-130(insulated in accordance with EN60664-1 or IEC60664-1)
    • PTC / NTC switches
    • KTY83-110
    • PT1000
  • 3 phase synchronous direct drives


Feedback system HIPERFACE DSL®

 | Single Turn | Multiturn
Order Number | ENCODERS5 | ENCODERS6
Resolution | 18 Bit | 18 Bit
Measurement steps per revolution | 262144 | 262144
Captured revolutions | 1 | 4096
Integral non-linearity | ± 80 " | ± 80 "
Differential non-linearity | ± 40 " | ± 40 "
Maximum speed | 12000 min-1 | 9000 min-1
Rotor moment of inertia | 450 gmm2 | 450 gmm2
Operating Temperature | -20 .. +105 °C | -20 .. +105 °C
Protection class | IP40 | IP40
Safety technology (IEC 61508 – EN ISO 13849) | SIL2; PL d | SIL2; PL d


Resolver

Category

Specifications

Resolution of the motor position
  • Position resolution: 16.6 Bits (= 0.005°)
  • Absolute accuracy: ±0.167°

Resolver supported
  • LTN: RE-21-1-A05, RE-15-1-B04
  • Tamagawa: TS2610N171E64, TS2620N21E11, TS2640N321E64, TS2660N31E64
  • Tyco (AMP): V23401-T2009-B202

Resolver data supported
  • Transformation ratio: 0.25... 1 (typical 0.5)
  • Excitation frequency 8 Hz
  • Amplitude of the excitation signal: max. 9.5 Vpp.
    (The resolver must be approved for at least this value).

Accuracy

The precision of the position signal is above all determined by the exactitude of the feedback system used.


Incremental encoder / analog Hall sensor

Category

Specification

Incremental encoder *
(Sine / Cosine or A/B square wave - signal)
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Supported signals:
    • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
      (an existing reference mark (Ref signal) is evaluated (with appropriately set machine zero mode) during machine zero run)

      Position resolution: 14 bit per sine/cosine period (at 1Vpp)

      -> with rotary encoder, unit incr./rev:
      encoder_line_count[periods/rev]*16384[incr./period]

      -> with linear encoder, unit e.g. incr./mm:
      16384[incr./period]*1000[um/mm]/Encoder_Periodlength[um]

      or
    • A/B - pulses: Physically RS422 (differential), A/B 90° phase shifted, max. 5 MHz
      (an existing reference mark (Z-track) is evaluated (with appropriate set machine zero mode) at machine zero run).

with the following commutation options:

  • Auto commutation

    or
  • U, V, W or R, S, T commutation signals (NPN open collector) e.g., digital hall sensors**, incremental encoders with commutation track (e.g., Hengstler F series with electrical ordering variant 6)

Analog Hall Sensor *
  • Linear or rotary
  • 5V supply voltage
    (optionally encoder controlled by voltage feedback via sense measuring lines)
  • Sin/Cos signal: Differential with 2.5V reference voltage, typically 1 Vpp (max. 4.7 Vpp), sine/cosine 90° phase-shifted, max. frequency 400 kHz
  • Position resolution: 14 bits (at 1Vpp) per sine/cosine period (= 14 bits per motor magnet period).

    -> for rotary motor, unit incr./rev:
    number_motor_pole_pairs [1/rev]*16384 incr.

    -> with linear motor: 16384[incr./pitch]
    with unit e.g. Incr./mm: 16384[incr.] / motor_pitch_length[mm].

* in the 1st development stage only for PSD1-S and PSD1MW1...: Multi axis devices with one power stage.

** the digital hall sensors are to be supplied via the encoder supply pin Vcc (5V nominal, higher voltage possible in case of connected encoder supply sense lines).


Motor holding brake output

Category | Specifications
Voltage operating range | 21 ... 27 VDC
Maximum output current (short circuit proof) | PSD1-S: 1.0 A PSD1-M: 1.6 A


Digital inputs / outputs (specifications)

Category

Specifications

Digital inputs
  • 4 Digital inputs
  • Input resistor 22 kW

All inputs and outputs do have 24 V level.

Input level:

"0" (low) = Rated Input Voltage £ 12.5 V

"1" (high= Rated Input Voltage ³ 13.5 V

Digital outputs
  • 2 Digital outputs (4 on mains module)
  • Load max. 100 mA


EC directives and applied harmonized EC norms (PSD1)

Category | Specifications
EU Low Voltage Directive 2014/35/EU | EN 61800‑5‑1, Standard for electric power drives with settable speed; requirements to electric safety EN 60664‑1, isolation coordinates for electrical equipment in low-voltage systems EN 60204-1, machinery norm partly applied
EC-EMC directive 2014/30/EU | EN 61800-3, EMC standard Product standard for variable speed drives


EMC limit values PSD1

Category | Specifications
EMC interference emission | Limit values in accordance with EN 61 800-3, Limit value class C3 with mains filter.
EMC disturbances | Industrial area limit values in accordance with EN 61 800‑3


Insulation requirements PSD1

Category | Specifications
Protection class | Protection class in accordance with EN 60664‑1
Protection against human contact with dangerous voltages | In accordance with EN 61800‑5‑1
Overvoltage Category | Voltage category III in accordance with EN 60664‑1


Environmental requirements PSD1

Category

Specification

General ambient conditions

In accordance with EN 60 721‑3‑3

Climate (temperature/humidity/barometric pressure): Class 3K22

Permissible ambient
temperatures:

Operation | 0 to +40 °C Class 3K22
Storage | -25 to +70 °C
Transportation | -25 to +70 °C

Tolerated humidity:

Operation | <= 85% Class 3K22
Storage | <= 95 %
Transport | <= 95 %

(Relative humidity)

Elevation of operating site

<=1000m above sea level for 100% load ratings

<=2000m above sea level for 1% / 100m power reduction

>2000m above sea level likewise with 1% / 100m power reduction but without UL & CE certification

Sealing

IP20 protection level in accordance with EN 60 529

Mechanical vibrations:

With packaging (transport/ storage): 10 m/s2; 9 – 200 Hz

Without packaging: 10 m/s2; 57 – 150 Hz

Pollution degree

Pollution degree 2 in accordance with EN 60664‑1 and EN 61800‑5‑1


cUL certification

Category | Specifications
PSD1M: | UL508C, 3rd Edition, power supply load revision November 9th, 2010. C22.2 N°.274-13, 12th Edition, last revision March 2013.
PSD1S: | UL61800-5-1 1st Edition, issued June, 8th, 2012 C22.2 No.274-13, 1st Edition, issued March, 2013
Certified | E-File_No.: E142140 The cUL approval is documented by a “UL” logo on the device (type specification plate).


Appendix: Description PSD ServoManager

In this chapter you can read about:

PSD optimization

PSD ObjectEditor


PSD optimization

In this chapter you can read about:

Overview optimization window

Status window

Commissioning window

Oscilloscope

Setting window for optimization objects


Overview optimization window

1 | Activate the selected axis (in this case axis: 1)
2 | Display: Watchdog active
3 | Display: Status of the actual axis
4 | Display: Motor powered
5 | Display: Motor turns
6 | Scope
7 | Editing area for oscilloscope settings and optimization objects
8 | Status Indicator
9 | Commissioning window with various functions.
10 | Only for programmable PSD: Start/stop of the PLC program, indicator of the state of the CODESYS runtime (start, stop, in breakpoint, in error)
11 | Switch UserUnits/increments (The switch setting determines whether the objects in UserUnits or increments are displayed in the ObjectEditor and the Status Indicator)
12 | Only for programmable PSD: CODESYS linked to PSD


Status window

1

Menu for administration of status-sets

  • Status - delete indicator
  • Load standard set from status values
  • Load created status set 1
  • Load created status set 2
  • Memorize created status set 1
  • Memorize created status set 2
  • Use standard status list
  • Use standard status list

2

Area of status indicator

Object name, value and object number (Hexadecimal)

Can be newly occupied by double click to a line. A window with the available status values opens.

3

Download error history from connected device

4

Status of digital inputs

Off (0 V)

On (24 V)

5

Status of digital outputs

Off (0 V)

On (24 V)

6

Actual intermediate circuit voltage

7

Status of STOA & STOB inputs

STO active

STO (24 V)

8

Actual / longest communication cycle time since the start of the ServoManager


Commissioning window

Movements in operating mode "commissioning" is monitored via Watchdog. In case a communication error occurs, movement is stopped immediately.

The State machine of the field buses is stopped during operating mode "Commissioning". It is displayed in the Status word by Bit ="0".

1 | Activate operating mode Commissioning "ON = green" = operating mode Commissioning active
2 | Activate the motor "ON = green" = motor energized
3 | Start the test movement set Right-click: Open input window to define test movement
4 | Select, define and start motion profiles. Available shortly!
5 | Manual mode active when button is pressed Right-click: Input window to define manual movement
6 | During the button is pressed, manual+ is active Right-click: Input window to define manual movement
7 | Activate machine zero run
8 | Stop movement
9 | With brake motors, brake can be operated manually.
10 | Auto-tuning call. Detection of the inertia of load and setting of optimization objects for position and speed control


Oscilloscope

In this chapter you can read about:

Overview oscilloscope

Setting of channels

Oscilloscope - Operating modes


Overview oscilloscope

The course of the individual objects can be recorded via the integrated 4-channel oscilloscope.

1 | Activate oscilloscope
2 | Select Operating mode & Scanning time
3 | Setting of channels
4 | Actual settings
5 | Setting of individual channels


Setting of channels

1 | Left-click: Select source for channel 1. A dialogue opens where an object can be selected by double-click. Right-click: Select color for the display of the channel
2 | Selected source for channel 1
3 | Deviation for channel 1 Right-click to set the optimum value displayed
4 | Enlarge deviation sensitivity (minimize on arrow left)
5 | Select by left-click between DC, AC , GND or Removing Channel in indicator
6 | Set Offset to 0
7 | Channel value on the mouse position (for recording memory in the right-hand section of the oscilloscope indicator)


Oscilloscope - Operating modes

1 | Settings window for the oscilloscope - select operating mode
2, 5 | Oscilloscope - Select operating mode
3 | Select scanning time
4 | Select maximum recording values


Setting window for optimization objects

In this chapter you can read about:

Window standard optimization objects

Window Advanced - optimization objects


Window standard optimization objects

1

Activate window optimization objects

2

Edit objects (by clicking on the value)

3

Load optimization-objects from connected devices

4

Menu for administration of optimization-objects

  • Select optimization-objects
    Standard: Most important objects to optimize drive
    Advanced: Extended selection of optimization-objects
  • Save actual setting of optimization-objects
  • Load actual setting of optimization-objects

5

Store objects in non-volatile device memory.

6

Take over objects (VP)

7

Error acknowledgement

8

Command line

9

Auto-tuning call. Detection of the inertia of load and setting of optimization objects for position and speed control


PSD ObjectEditor

In this chapter you can read about:

Overview ObjectEditor

CSV export of the objects


Overview ObjectEditor

Explanation of functions

1

Switching the description display (19) from “normal” to page view

2

File: Close; close the object editor

3

Selectable object access: Standard or advanced objects (see also in the object list)

4

Under "Device", the device objects are arranged

5

Under "Axis", the axis objects are arranged: Axis 1 ==> Axis 1

6

Object tree for selection of the objects

7

Selected object

8

Source of the object data

9

Program title with version and number of available objects

10

Display of the object numbers in the object tree (13): Switching by left mouse click

11

Zoom settings for the object description (16) under documentation.

Left mouse click: Zoom in; right mouse click: Zoom out

12

Search entry for the object search

13

Number of results found; can be selected individually

14

Status of the optimization window

disabled (inactive) or active (connected with PSD)

15

Firmly place object editor to the screen foreground: Switching by left mouse click

16

Axis, object number and object name of the object selected in the object tree (13).

17

Fieldbus & data type

18

Display of the object characteristics

19

Display of the object description

20

How is the object set to valid:

- Immediately

- After VP (27)

- After VC (26)

- After switching off/ on (24 VDC)

21

Automatic reading of the object values of the connected PSD; green switched on: Switching by left mouse click

22

Manual reading of the object values of the connected PSD

23

Entry field to change an object value

24

Write object in PSD

25

Save object in PSD (write flash)

26

VC; Re-calculate configuration: (see 20).

Caution: this is only possible at standstill!

27

VP, set changed object values to valid: (see 20).

28

Place actual object to one channel of the oscilloscope

29

Place actual object to a status message field

30

Status message field

31

Object available in CODESYS

32

ObjektFlag user units: If this flag is set, the object can optionally be shown in increments or in user units (Switch for this is in the optimization window) - depending on the flag, the user unit is UserUnits (Position), UserUnits/s (Velocity), UserUnit/s^2 (Acceleration) or 500us (JerkFilter).

1 | Activate the selected axis (in this case axis: 1)
2 | Display: Watchdog active
3 | Display: Status of the actual axis
4 | Display: Motor powered
5 | Display: Motor turns
6 | Scope
7 | Editing area for oscilloscope settings and optimization objects
8 | Status Indicator
9 | Commissioning window with various functions.
10 | Only for programmable PSD: Start/stop of the PLC program, indicator of the state of the CODESYS runtime (start, stop, in breakpoint, in error)
11 | Switch UserUnits/increments (The switch setting determines whether the objects in UserUnits or increments are displayed in the ObjectEditor and the Status Indicator)
12 | Only for programmable PSD: CODESYS linked to PSD


CSV export of the objects

In the Object Editor in the menu File you can export the objects as *.csv file.

The attributes of the objects are separated by semicolons and can be read directly with Excel, for example.


Appendix: Control technology in PSD

In this chapter you can read about:

Introduction

Configuration

Control technology


Introduction

In this chapter you can read about:

Basic structure of the control with PSD

Proceeding during configuration, setup and optimization


Basic structure of the control with PSD

PSD is an intelligent servo drive for different applications and dynamic motion sequences.

Basic structure of a control with the PSD servo drive

As shown in the above figure, the programmed motion sequences are generated by the internal PSD profile generator. Besides the setpoint position other status values (of the feed-forward control) are made available to the position controller in order to keep the following error as small as possible.

For the control, PSD requires on the one hand the actual position and on the other hand the commutation position, which represents the reference between the mechanic feedback position and the motor magnet.


Proceeding during configuration, setup and optimization

Overview of the processes during configuration and setup of the drive system

The controller presettings are calculated from the configured motor and application parameters with the aid of the automatic controller design which runs in the background.

These controller presettings provide normally for a stable and robust control. Due to continually rising application requirements, this pre-setting is often not sufficient, so that further optimization of the control behaviour is necessary.

This manual describes the setup and optimization procedure.

In order to better understand the correlations and interactions, we will describe in the first step the individual correlations and physical values, that are required for the configuration and the prespecification of the control loops. In the following, the function blocks for the optimization implemented in the servo drive as well as the setup tool are described.


Configuration

In this chapter you can read about:

Control path

Electromotoric countercheck EMC

Mass inertia

Nominal point data

Typical problems of a non optimized control

I²t - monitoring of the motor


Control path

For the motors, the knowledge of the mathematical model is a prerequisite.

Mathematically idealized model of the control path:

U: | Control voltage
UEMK: | electromagnetically generated voltage in the motor
T: | electric time constant of the motor winding
L: | Stator inductance
R: | Stator resistance
MA: | Drive torque of the motor
ML: | Load torque
MB: | Acceleration torque
I: | Actual current r.m.s. (torque-producing)
KT: | Torque constant
Jmot: | Motor mass moment of inertia
Jext: | external mass moment of inertia
Jtotal: | Total mass moment of inertia
a: | Acceleration
n: | Velocity
Explanation:

The motor is controlled by the servo drive with control voltage U. During motion of the motor, an internal back e.m.f. UEMC is induced. This antagonizes the control voltage and is therefore deduced in the motor model. The difference is available for the acceleration of the motor.

The first order delay component represents the delaying property of the motor winding with the time constant T=L/R. According to Ohm's Law, a current I=U/R results.

The drive torque of the motor is calculated by multiplying the current with the motor torque constant KT. This is antagonized by the load torque of the machine.

The remaining acceleration torque accelerates the motor.

The resulting acceleration depends on the total mass moment of inertia (= motor + load moment of inertia).

The integration of the acceleration (sum of the acceleration over time) results in the velocity of the motor, which influences the amplitude of the induced EMC voltage.

All motor parameters relevant for the control quality will be explained below.


Electromotoric countercheck EMC

A non-energized synchronous motor induces an induction voltage, the so-called EMC voltage during an armature movement.

The EMC constant (motor EMC) states the value of the induced voltage subject to velocity.

The EMC constant corresponds to the motor torque constant KT, which represents the correlation between the torque-producing current and the drive torque, however in a different unit.

The EMC voltage antagonizes the control voltage of the servo drive.

As the control voltage of the drive is not unlimited, it must be taken into consideration that the drive may approach the voltage limit at high velocities and therefore high EMC voltages.

The EMC constant is important with respect to the velocity control design.

You will find the EMC constant on the type identification plate of the motor or, if available, as part of the electronic motor label.


Mass inertia

The mass moment of inertia (moment of inertia) is also an important motor parameter for the design of the velocity control loop, together with the external mass moment of inertia of the load.


Nominal point data

In this chapter you can read about:

Motor characteristic line of a synchronous servo motor (torque via velocity)

Calculation of the reference current from the characteristic line.

The nominal point data can be found in the velocity characteristic line of the motor. The predefined nominal point can also be changed; it is then called reference speed and reference current.


Motor characteristic line of a synchronous servo motor (torque via velocity)

1: Nominal point

2: Forbidden range


Calculation of the reference current from the characteristic line.

or for linear motors

Additional parameters of a motor are:

  • Standstill current [mArms]
  • Pulse current [in % of the nominal current]
    The pulse current can be provided by the servo drive for the duration of the pulse current time (as far as the device current permits). The thermal pulse load of the motor rises due to the pulse current. This pulse load is monitored by the i²t monitoring in the servo drive.


Typical problems of a non optimized control

In this chapter you can read about:

Too high overshoot on velocity

Following Error (Position Error)

Increased following error

Instable behavior

Upon first setup of a control, the controller is normally not able to meet all application requirements at once. Typical problems may be:


Too high overshoot on velocity

1) | Actual velocity
2) | Setpoint velocity


Following Error (Position Error)

Too high following error (position error) during a movement

1) | target position
2) | Position deviation = following error
3) | Effective position


Increased following error

Increased following error when approaching the target position or the reduction of the following error takes too long

1) | Following error
2) | Setpoint velocity
3) | Actual velocity


Instable behavior

1) | Setpoint velocity
2) | Actual velocity
3) | Following error


I²t - monitoring of the motor

In this chapter you can read about:

Motor continuous usage:

With the I²t - monitoring, the motor is protected against overload or thermal destruction. For this, knowledge on the load bearing capacity of the motor is required. This information can be taken from the manufacturer documentation (motor parameters. PSD monitored:

  • Continuous usage of the motor (motor usage)
  • Pulse usage of the motor (motor pulse usage)

The motor overload protection has to be justified that 200% of the motor current will not be exceeded. The control has no protection with thermal memory retention. If the user requires a protection acc. EN 61800-5-1 with thermal memory retention, he has to implement such a protection himself. The user has to check whether the limited internal protection is sufficient for the application. The control function has to be tested.

Moreover with the PSD also a motor temperature control is possible. This is only supported when a qualified external temperature sensor is connected. The temperature protection has to be tested by the user.


Motor continuous usage:

This kind of monitoring watches over the continually deliverable torque (continuous current). This continuous current depends on the velocity and is acquired online from the linearization of the motor characteristic line.


Linearized motor characteristic lien for different operating points


Nominal point:

I0: | Standstill current
1: | Nominal point
IN: | Rated current
nN: | Rated Speed
2: | Forbidden range

For monitoring the continuous utilization, the linearized characteristic line between I0 and IN / nN is used as a threshold.


Reference point 1: higher velocity at reduced torque

I0: | Standstill current
rp1: | Reference point 1
I1: | Reference current to reference point 1
n1: | Reference velocity to reference point 1
2: | Forbidden range

For monitoring the continuous usage, the linearized characteristic line between I0 and I1 / n1 is used as a threshold.


Reference point 2: Increased torque thanks to additional cooling

I0: | Standstill current
1: | Nominal point
rp2: | Reference point 2
I2: | Reference current to reference point 2
n2: | Reference velocity to reference point 2
2: | Forbidden range

In order to monitor the continuous usage, the velocity-idenpendent current limit I2 is used.

If a r.m.s. current over the valid straight flows continually in the motor, the I²t monitoring will issue the "effective motor current monitoring" error message. The period of time until the error occurs depends on the thermal time constant of the motor defined in the motor parameters. The electronic temperature monitoring simulates approximately the temperature behavior of the motor. By defining a reference point different from the motor nominal data, the I²t monitoring of the motor can be adapted to changed thermal ambient conditions (e.g. air stream caused by a ventilator fan).


Control technology

In this chapter you can read about:

Dynamics of a control

Cascade control

Stiffness

Automated controller design

Controller coefficients

Luenberger Observer

Commutation settings of the automatic commutation


Dynamics of a control

In this chapter you can read about:

Structure of a control

Oscillating path

Stability, attenuation

Velocity, bandwidth

Setpoint and disturbance behaviour of a control loop

Response

Limitation behavior

A change in the input value of a dynamic transmission element causes a change of its output value. The change of the output value is however not immediately effective, but takes a certain time, the transient response. The course of the transient response is characteristic for certain kinds of transmission behavior.

For this reason, a complete description of the transmission properties of a control comprises the stationary behavior (all setpoint, actual and disturbance values in settled state), as well as the dynamic behavior.


Structure of a control

The basic task of a control is the generation and maintaining of a desired state or sequence in spite of interfering disturbances. It is essential that the effects of the disturbances are balanced with the correct force and at the correct time. In the above figure, the set point value W represents the desired state and the disturbance value Z represents the interfering disturbance. The actual value X represents the generated and maintained state.


Oscillating path

Oscillating control paths are control paths that respond with attenuated or unattenuated oscillation to an abrupt change in the setpoint value. Part of this class are for instance:

  • Linear actuators with toothed belts, as a toothed belt represents an elasticity.
  • A mechanic shaft with an external mass moment of inertia, as the shaft represents an elasticity due to its torsional properties.
    In general this kind of elasticity is due to a high ratio between JLoad/JMotor, as the shaft is normally not designed for this high external load and which may lead to a considerable distortion.


Stability, attenuation

In this chapter you can read about:

Stability problem in the high-frequency range:

Stability problem in the low-frequency range:

In general, two stability problems may occur in a servo drive control:


Stability problem in the high-frequency range:

The "control structure" figure shows that the reverse effect in the control loop (negative feedback) is a prerequisite for the functioning of a control system. Due to the delay in signal transmission, the effect of the negative feedback is diminished or even compensated. The reason is that the corrective measures of the controller are also delayed in the event of delayed signal transmission. This results in a typical oscillating course of the control variable. In the worst case, the deviation of the control variable and the effect of the corrective measures get in phase, if the delays reach a defined value. The negative feedback passes into positive feedback. If the product of the gain factors of all control loop components is higher than 1, the oscillation amplitude will continually rise.

In this case the control loop is unstable. In the total gain of 1 the oscillation keeps its amplitude and the control loop is within the limits of stability. The transient response can be characterized by the attenuation and the transient time (velocity).

Step response of a stable controller and of a controller approaching the stability limit
Rugged Well attenuated | Rugged Poorly attenuated | Stability limit not attenuated

W: Nominal value

x : Actual Value


Stability problem in the low-frequency range:

In this case the controller was set for a very inert control path, while the actual control path is much more dynamic. The controller reacts to a disturbance variable with a much too strong corrective measure so that the disturbance variable is overcompensated and even an increasing oscillation may be the result. In this case the mechanic system of the control path may be destroyed.

Velocity jerk response (low-frequency stability limit)

1: Speed setpoint

2: Rotation actual speed value


Velocity, bandwidth

In this chapter you can read about:

P-TE - Symbol

Jerk response of a delay component

Approximation of a well-attenuated control loop

Frequency response of the P-TE component (value and phase)

A well attenuated control loop can, under certain conditions, be approximated in order to simplify the controller design with a first order delay component (P-TE component) with the replacement time constant TE and the total gain Kp. A P-TE component represents a first order delay component and is a simple dynamic basic component.


Parker Servo Drive

Vorige Seite

Nächste Seite

P-TE - Symbol


Jerk response of a delay component

Jerk response of a first order delay component with Kp=1 and TE=2.0s

T: Tangent

S: Input jerk

P-TE: Output value of the P-TE component

TE: Time constant of the P-TE component

The definition of the delay time constant is displayed in the above figure. The time of intersection of the tangent and the jerk function itself is by definition the delay time constant (called filter time constant for filters) of a P-TE component. At this point in time the value of the jerk response is approx. 63% of the final value. In practice the jerk response corresponds, for instance, to the voltage charge curve of a capacitor.


Approximation of a well-attenuated control loop

The approximation of a well-attenuated control loop is based on the sameness of the control surface of the ideal first order delay component (P-T1 component) and the approximated system (P-TE component).

The control surface is a measure for the velocity of a system and is defined in the following figure. If the surface of the approximated system corresponds to the surface of the ideal system, the approximated system can be described, up to a certain frequency, with the transmission function of the P-T1 component.

Determination of the control surface from the transmission behaviour of a P-TE component
1: Control surface of the approximated system | 2: Control surface of the ideal P-T1 component

The velocity of a dynamic system can also be described in the frequency range. In the frequency range, the system behavior is analyzed to sinusoidal inputs signals of different frequencies (frequency response).

Input and output signals of a dynamic transmission component at a defined frequency f=f1

The bode diagram represents the behavior of a dynamic system (in our case of the P-TE component) against the input signal frequency with respect to amplitude and phase.


Frequency response of the P-TE component (value and phase)

Cut-off frequency

is the frequency where the input signal is attenuated by 3dB (-3dB attenuation). The phase shift between the output and the input is -45° at this frequency.

Precisely this cut-off frequency is called the bandwidth of a control loop.


Setpoint and disturbance behaviour of a control loop

In this chapter you can read about:

Demand behaviour

Disturbance behavior

Characteristics of a control loop setpoint response

The setpoint behaviour is the behaviour of the control loop for the set-point variable W. We assume that the disturbance variable Z=0.

The disturbance behaviour describes the behaviour of the control loop for disturbance variable Z. In this case, we assume, in analogy to the setpoint behaviour, that the set-point variable W=0.


Demand behaviour

W: Nominal value

X: Actual Value

Z: Disturbance variable


Disturbance behavior

W: Nominal value

X: Actual Value

Z: Disturbance variable

In order to examine the disturbance and setpoint behavior, the setup software of PSD offers 4 jerk functions.


Characteristics of a control loop setpoint response

TSr: | Response time. (Time elapsing until the control variable reaches one of the +-5% tolerance limits for the first time)
TS: | Settling time. (Time elapsing until the control variable ultimately enters the +-5% range)
Vm: | maximum overshoot width
1 | Tolerance range +-5%
2 | Nominal value


Response

The response of the controller is the behavior of the actual value with respect to the calculated profile of the setpoint generator. The kinematic status variables, speed, acceleration and jerk are fed into the cascade as feedforward signals. The feedforward signals work with calculated factors and contribute to an improved contour constancy due to the minimization of the following error.

Servo controller structure PSD

x : | Position actual value | n: | Actual (rotational) speed | i: | Actual current value
xw: | Setpoint position value | nw: | Speed Setpoint | jw: | Jerk setpoint value
aw: | Acceleration setpoint value |  |  |  |


Limitation behavior

Each control variable is limited by the control (actuating) element. If the control variable demanded by the controller is within the linear range (without limitation), the control loop shows the behavior defined by the design. If the controller demands however a higher control variable than permitted by the limitation, the control variable is limited and the controller slows down.

Note

You should therefore make sure that the control variable (output) of the controller does not remain within the limitation or only for a very short time.


Cascade control

In this chapter you can read about:

Structure of a cascade control

Cascade structure PSD

In drive technology, a cascading structure with several controllers (normally 3) is often used. This improves the control behavior. For this, additional sensors must be fixed within the control path. You will get the structure of a cascade control.


Structure of a cascade control

W1 | Setpoint value (setpoint) for the superposed controller 2
B2 | Setpoint value (setpoint) for the subordinate controller 1
X2: | Actual variable (actual value) for controller 2
X1: | Actual variable (actual value) for controller 1

The cascade control offers the following advantages:

  • Disturbances occurring within the control path, can be compensated in the subordinated control loop. Therefore they must not pass through the entire control path and are thus compensated earlier.
  • The delay times within the path can be reduced for the superposed controller.
  • The limitation of the intermediate variables can be made by the control variable limitation of the superposed controller rather easily .
  • The effects of the non-linearity for the superposed controllers can be reduced by the subordinate control loops.

In the servo drive PSD, a triple cascade control is implemented with the following controllers - position controller, velocity controller and current controller.


Cascade structure PSD


Stiffness

In this chapter you can read about:

Static stiffness

Dynamic stiffness

Correlation between the terms introduced

The stiffness of a drive represents an important characteristic. The faster the disturbance variable can be compensated in the velocity control path and the smaller the oscillation caused, the higher the stiffness of the drive. With regard to stiffness, we distinguish static and dynamic stiffness.


Static stiffness

The static stiffness of a direct drive is comparable with the spring rate D of a mechanical spring, and indicates the excursion of the spring in the event of a constant interference force. It is the ratio between the constant force FDmax of the motor and a position difference. Due to the I term in the velocity controller, the static stiffness is therefore infinitely high in theory, as the I term is integrated until the control difference vanishes. In a digital control the static stiffness is above all limited by the finite resolution of the position signal (the error must be at least one quantization step, so that it can be detected by the reading system) and by numerical resolution. Additional effects are for instance mechanical stiffness of the mechanic components in the control path (e.g. load connection, guiding system) as well as measurement errors of the measurement system.


Dynamic stiffness

The dynamic stiffness is described by the ratio between the change in load torque or in load force and the resulting position deviation (following error):

The higher this ratio (=dynamic stiffness), the higher the necessary change is load torque in order to generate a defined following error.

The dynamic stiffness can be acquired from the disturbance jerk response.


Correlation between the terms introduced

The introduced terms:

  • Stability
  • Cushioning
  • Velocity
  • Bandwidth
  • Setpoint and disturbance behavior
  • Control variable limitation
  • Replacement time constant
  • Stiffness

are related as follows:

  • A well-attenuated control features a stable control behavior.
  • The velocity of a control loop is a measure for the reaction rate of the controller to the disturbance variable (disturbance behavior) as well as to the setpoint variable (setpoint behavior).
  • The faster the control, the higher its bandwidth.
  • The term replacement time constant is an approximation and is only valid in a defined scope1. In this scope, the control is always stable and well-attenuated.
  • If the controller does not work in the linear range, but the control variable of the controller is within the limitation, the control slows down and the control difference rises.
  • The stiffness represents the bandwidth of the velocity control. The higher the stiffness value of the velocity control, the higher the bandwidth of the velocity controller and the stiffer the drive.


Automated controller design

In this chapter you can read about:

Step response of the velocity loop depending on the optimization parameter "attenuation" and "stiffness"

D-term

The controller design takes place after the configuration immediately before the configuration download into the device. The controller coefficients are preassigned according to the design method of cross-ratios so that a stable control is achieved.

The automatic, robust controller design calculates the P and I terms of the individual controllers (current, velocity, position) on the basis of the configured motor and application parameters.

Please observe:

Faulty motor and application parameters may lead under certain circumstances to instable controllers.

The controller parameters are not directly available for the optimization. Instead, they can be changed with the aid of the following optimization parameters:

Optimization of the current controller dynamics:
  • Current loop bandwidth in %
  • "Attenuation of current loop" in %

Optimization of the velocity loop dynamics:
  • "Stiffness" in %
  • "Attenuation" in %
  • Velocity loop - "D" term in %

The bandwidth parameter states the actually effective % of the calculated default velocity. The default bandwidth of the controller is fixed to approx. fGR=531Hz. In reverse this signifies that each motor delivers the same jerk response. The prerequisite is, of course, that you keep out of the control signal limitation (voltage limitation). The attenuation characterizes the controller's tendency to oscillate with respect to an excitation signal (see below). The stiffness (of the velocity loop, corresponds to the bandwidth of the current loop) describes the velocity of the velocity loop (see below).


Step response of the velocity loop depending on the optimization parameter "attenuation" and "stiffness"

Attenuation = 100%

Stiffness = 100%

1: Nominal value

2: Actual value (stiffness = 200%)

3: Actual value (stiffness = 100%)

4: Actual value (stiffness = 50%)

5: Actual value (attenuation = 500%)

6: Actual value (attenuation = 100%)

7: Actual value (attenuation = 50%)

D-term

The D-term parameter (of the velocity loop) activates existing control oscillations of drives with elastic coupling (e.g. toothed belt drives). Even for rack-and-pinion drives a D-term enables a higher stiffness.

The D-term is not automatically designed and must therefore be set manually.


Controller coefficients

In this chapter you can read about:

Speed Controller

Position loop

Dependence of the controller coefficients from the optimization objects

The controller coefficients of speed and position control are influenced by the optimization objects such as "stiffness" and/or "attenuation". The dependency is displayed below.

Speed Controller


Velocity Loop P Term

TEGD: | The replacement time constant of the closed velocity loop.
TN: | The mechanical integration time constant of the motor.
fLIN(): | Linear function (straight) between attenuation and KPV
Tm | Inertia
St | Stiffness
Dp | Cushioning

I-term KI speed controller

I-term KI in the speed controller

TEGD: | The replacement time constant of the closed speed control.
St | Stiffness


D-term of the KD velocity controller

KD_100%: | The defined 100% coefficient
D-term | D term

km structural factor

Factor to add a weighted amplification factor in the forward path of the speed controller. By varying between 0% (more phase loss, higher damping (=less overshoot)) and 100% (less phase loss, less damping (=more overshoot) = classic PI controller), the control structure can be adjusted.

As visualized in the standard cascade structure, this parameter also impacts the speed feedforward signal which is overridden in accordance with the integral part of the speed controller ("acceleration feed") scaled with factor KFFW_a (0x3832.04). This feedforward signal is scaled (-> reduced) with the factor (1-Km).

One limitation for the application of speed controller's factor Km is the parameter for optimizing the amplification of the integral part of the speed controller KI:

KI Faktor (0x3822.04) | Km adjustable?
= 10% | ü
< 10% | û (Km=100%)

Influence of km on the control dynamic

PSD km factor 0..100%

Position loop

The position loop is automatically adapted depending on the stiffness of the velocity loop.


P-term KV position loop

TEGD: | The replacement time constant of the closed velocity loop.
TX: | The position integration time constant of the motor.
St | Stiffness
Dp | Cushioning
fLIN(): | Linear function (straight) between 1/attenuation and KV


Luenberger Observer

In this chapter you can read about:

Introduction observer

Signal flow chart Luenberg observer


Introduction observer

A high signal quality of the actual signal value is of high significance in the control of the motor velocity n or the motor speed v. By means of oversampling and transmitter error compensation, a high-quality position signal can be produced for speed determination. As a rule the motor speed is determined by numeric differentiation of the motor position. In this case the quantization noise QvD of the digital speed signal depends on the quantisation Qx of the position signal and the sampling time TAR of the digital control loop:

Quantization speed signal QvD

The quantisation of the speed signal is inversely proportional to the sampling time TAR. Hence the demands for the lowest possible sampling time and the minimum quantization noise oppose each other in the determination of speed by numeric differentiation. The noise superimposed by the digital speed signal may be reduced by the low-pass filter, however this is always at the cost of the stability margin of the digital control loop. An alternative method is to determine the speed by integration of the acceleration. The dependence of the quantisation noise QvD of the digital speed signal on the quantisation Qx of the position signal and the sampling time TAR of the digital control loop is shown by the following correlation.

Quantization speed signal QvI

The observer technology offers the advantage that the velocity can be calculated with the aid of integration. The idea of the observer principle is to connect a mathematical model of the control path parallel to the section observed and with the same transfer behavior. In this case, the controller also has the intermediate variables (state variables) of the control path available. However in the presence of model deviations (in structure or parameters), different signal values occur between the model and the control path. For this reason, the technique cannot be employed in this way in practice. However, the model contains the measurable output signal of the control section as a redundant quantity. By comparing the two variables, a tracking control can be used to adapt the model state variables to the state variables of the control path. As the model deviations have become minor in this case due to the simple mechanical drive train, the observer now has an efficient aid available to increase the signal quality. Increase in signal quality in the observer means that the noise components decrease, and the dynamics improve as the observed speed is feedforward-controlled undelayed by the current and is not just calculated delayed from the position signal using simple differentiation.


Signal flow chart Luenberg observer

I(t): | Torque-forming motor current
Kt: | Torque constant
ML(t): | External disturbance torque
Jtotal: | Total mass moment of inertia (motor + load)
a(t): | Acceleration
n(t): | Velocity
x(t): | Position
Index b: | Observed signal quantities
h0…h2: | Controller coefficients of the tracking controller

The figure shows that an additional I element is connected for interference compensation to correct external disturbance forces in the observer. Therefore, the speed and the acceleration observed are statically precise. The same applies to the output of the integrator in the tracking controller which is a statically precise determination of an external interference torque ML. For this reason, the I component is not required in the speed controller for some applications, and the entire control can be set up as a state cascade control. This increases the bandwidth of the speed and position controlled member by factor 2. For this reason this increases the interference stiffness of the drive and the following error behavior improve.

Note

The use of the speed observer with interference compensation (=> no I-term in the speed control) needs an active position control. Without this superimposed control the axis drifts, even with a speed setpoint value of 0!

Here the quantization of the speed signal is proportional to the sampling time TAR and therefore no conflict exists any longer between the requirements for minimum sampling time and minimum quantization noise. For the integral velocity detection the motor current variable which is proportional to the acceleration can be used. This approach is particularly advantageous in direct drive engineering; due to the absence of a mechanical drive train there is a very good match between the mathematical model of the observer and the real physical control section in the fundamental frequency range of the control. This applies in particular to direct drive systems with fixed moving masses as otherwise the mismatch between model and the physical drive system has a destabilizing influence on the transfer behaviour of the speed control. A remedy is to increase the observer dynamics, however this increases the noise of the observed signals. Therefore, in the case of variable moving masses a compromise has to be found between the dynamics of the observer and the maximum stiffness of the drive.


Commutation settings of the automatic commutation

In this chapter you can read about:

Display of the commutation error in incremental feedback systems

Prerequisites for the automatic commutation

Course of the automatic commutation function

Other

Permanently excited synchronous motors can only be operated with an absolute feedback system (at least for electric motor rotation). The reason is the necessary commutation information (position assignment of the magnet field generated by the motor to the motor magnets). Without the commutation information, there is inevitably the possibility of a positive feedback between position and velocity loop ("running away" of the motor) or of bad motor efficiency (reduced force constant).

Digital hall sensors are the most common aid to prevent this. Due to the mechanical design it is however impossible or very hard to integrate these sensors in some motors. The PSD automatic commutation function (in the F12 direct drive device) described below allows however to use incremental feedback systems without hall sensors.

The functionality implemented in the servo drive establishes the necessary reference between motor stator field and permanent magnetic field without additional aids.

The incremental feedback devices are, in contrast to absolute feedback devices, able to acquire relative distances. It is true that any position can be approached from a starting point; however, there would be no consistency between these position values and a fixed virtual absolute system. Other than with an absolute feedback, the correlation between rotor and stator is lost if the position acquisition is switched off ("the position acquisition zero is lost"). When switching on, the actual position is randomly taken as zero. A commutation angle error can therefore absolutely not be excluded. Even a system adjusted before would show an angular error, for example after a current failure. Therefore, the angular error occurring randomly upon each new switching on must always be compensated in an incremental system.


Display of the commutation error in incremental feedback systems

De = 0 (adjusted) | De ¹ 0 (not adjusted)
 | Rotor was turned in switched-off state.

blue: | ideal position
red: | unfavourable position
PM: | magnetic flux of the permanent magnets
iS: | Current pointer
De | Commutation error
I’: | ideal position
iq: | Quadrature current (torque forming)

The automatic commutation function (AK) in PSD uses the position dependent sinusoidal torque course of permanently excited AC synchronous motors. If the motor windings are energized with DC voltage for instance, the motor develops a sinusoidal torque depending on the rotor position, which can be used for example by evaluating the resulting movement in order to determine the correct motor commutation.

The automatic commutation with movement in the PSD has the following properties:

  • The motor movement occurring during the commutation is, with correctly parameterized function, very small. It is typically in the range smaller than 10° electrical revolution (=10°/motor poles physically or 10°/360°*motor pitch for a linear motor).
  • The precision of the acquired commutation angle depends on the external conditions. However, lies normally in the range better than 5° electrical revolution.
  • The time until the termination of the commutation acquisition is typically below 10s.


Course of the automatic commutation function

If "automatic commutation with movement" is selected as source of commutation, the automatic commutation sequence runs once if the power stage is enabled. If the power stage is enabled or disabled afterwards, the automatic commutation will be left out. If an error occurs during the execution, the automatic commutation is aborted. A new "attempt to enable" the power stage will trigger a new automatic commutation.


Function principle of the automatic commutation with movement

The implemented method with movement is based on the sinusoidal dependence of the provided motor currents and the resulting movement on the effective commutation error. The acceleration performed by the motor (-> movement) in the event of constantly maintained current is a measure for the actual change in the commutation angle in the way that it disappears upon a change of exactly 0° and is, for other angles, the acceleration and its direction in dependence of the sign and value of the angular error (-180° .. 180°).

Acceleration torque depending on the commutation error.

De: | Commutation error
M/Mmax | normalized acceleration torque
Searching for the torque maxima (phase 1)

If the sum of the actual and the estimated error angle is ±90° electrically, the motor torque is maximal for the provided current. If you gradually increase the provided motor current, the motor will, from a defined value on, surpass its friction torque and exceed a motion threshold defined by O2190.3:

Illustration of the first phase

1): | Motion threshold O2190.3
2): | Waiting for standstill
O2190.2: | Starting current
Latching of the motor (phase 2)

Here, the drive is brought to the position with the provided motor torque=0, where the angular error is either +-180° or 0°.

Current rise in the second phase

O2190.1: | Rising time of latching current
1) | Maximalstrom von Regler oder Motor
2) | Maximum current from controller or motor
3) | Monitoring on 60° electrical movement

Motion reduction:

It is possible, to considerably reduce the motor movement occurring during the fine angle search with the aid of the "motion reduction" parameter (O2190.4).

Please respect also that the acquired commutation result may be slightly worse than without this measure.

Hint

As a current well above the nominal motor current is provided here, there may be saturation effects on iron core motors, which might lead to an instable current loop (-> highly frequent "creaking noises" Test for positive feedback (phase 3 during the automatic commutation). This can be avoided by activating the saturation characteristic line in the motor data.

Test for positive feedback (phase 3)

Here it is verified, if the motor performs a motion in the expected positive direction in the event of positive current in the torque maximum. The same motion threshold (defined via O2190.3) as in phase 1 is valid. The test is repeated several times.

A current course in ramp form is specified (target: minimum motion). The break between the tests varies with he current rise time O2191.1.

Illustration of the third phase

1): | Waiting for standstill
tp | Waiting for standstill


Other

  • During the sequence (time according to parameterization>>1s) the automatic commutation is externally visualized by a LED blinking code (green permanent and red blinking).
  • Device errors will lead to an abort of the automatic commutation.
  • During automatic commutation, no motion commands are accepted.
  • The controller cascade entirely deactivated during automatic commutation, with the exception of the current loop.
  • In multi-axis applications, the axes to be automatically commutated must be awaited!
  • The automatic commutation is only started if the drive is at standstill.
  • After the occurring and acknowledgement of a feedback error or a configuration change of the feedback system, the automatic commutation must be performed again, as it might be that the position entrainment in the servo controller is interrupted (commutation information is lost).


Appendix: Accessories PSD

In this chapter you can read about:

SMH Servo Motors with HIPERFACE DSL® - Feedback

EMC measures

Line choke

External braking resistors

Interface Cables


SMH Servo Motors with HIPERFACE DSL® - Feedback


Order code of motor cable

 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
Ordering example | CBM | 015 | H | D | M23 | PSX | 0150 | 00

1 | Cables
 | CBM | Motor cable
2 | Cross-section
 | 007 | 0.75 mm2
 | 015 | 1.5 mm2
 | 025 | 2.5 mm2
 | 040, 060 | 4 mm2, 6 mm2
3 | Cable Type
 | H | HIPERFACE DSL® highly flexible
4 | Brake wire
 | D | With brake wire and HIPERFACE DSL®
5 | Assembly of motor side
 | M15 | SpeedTec M15 (for motor connector - Order code YZ)
 | M23 | SpeedTec M23 (for motor connector - order code IZ)
 | M40 | SpeedTec M40 (for motor connector - Order code IZ1))
 | XXX | Terminal Box
6 | Assembly of drive side
 | PSX | PSD1-S & PSD1MW1800
 | PMX | PSD1-M (not PSD1MW1800)
7 | Length [10 cm steps]
 | 0100 | Length in 10 cm (max. 50 m) Example: 0025 = 2.5 m, 0205 = 20.5 m, 1020 = 102.0 m Standard length [m]: 3 / 5 / 7 / 10 / 12 / 15 / 20 /25 / 30 / 35 / 40 / 45 / 50
8 | Special design
 | 00 | Standard

1)

is required for Mx 205 series motors and Smx 170 60 Nm motors


EMC measures

In this chapter you can read about:

Mains filter

Motor output chokes


Mains filter

In this chapter you can read about:

Mains filters for PSD1-S single-phase ECP-0001-01

Mains filters for PSD1-S 3-phases operation ECP-0002-01

Mains filters for PSD1-M_P010 and PSD1-M_P020

For radio disturbance suppression and for complying with the emission limit values for CE conform operationwe offer mains filters:

Observe the maximum permitted length of the connection between the mains filter and the device:

  • unshielded <0.5m;
  • shielded: <5m (fully shielded on ground e.g. ground of control cabinet)


Mains filters for PSD1-S single-phase ECP-0001-01

Mains filters with UL certification for PSD1-S_1200 (2 A) and PSD1-S_1300 (5 A)
Necessary for limit value class C3 (in accordance with EN 61800-3) in single phase operation with motor cable length > 10 m

Scale drawing:

O | B | C | D | E | F | L | M | A | P
156 | 57.5 | 45.4 | 130.5 | 56 | 143 | 6 | 1 | 8.4 | 18

Stated in mm

Color code:

BN | Brown
BU | blue
GNYE | green-yellow

Weight: 0.67 kg


Mains filters for PSD1-S 3-phases operation ECP-0002-01

Mains filters with UL certification for PSD1-S_1200 (2 A) and PSD1-S_1300 (5 A) for 3-phases operation
Required for limit value class C3 (In accordance with EN 61800-3) in 3-phase operation with motor cable length > 10m

Scale drawing:

O | B | C | D | E | F | G | H | I | PE | K | L
250 | 45 | 70 | 220 | 235 | 25 | 5.4 | 1 | 22 | M5 | 22.5 | 29.5

Stated in mm

Weight: 0.8 kg

Port Connections: AWG8 (10 mm2 rigid, 6 mm2 flexible)

tightening torque: 1.5 ... 1.8 Nm


Mains filters for PSD1-M_P010 and PSD1-M_P020

Mains filters with UL certification
  • Mains filters ECP-0003-01 for PSD1-M_P010: Axis combination with motor cable up to 6 x 10 m
    (max. 60 m cable length in total)
  • Mains filter ECP-0003-02 for PSD1-M_P010: Axis combination with motor cable up to 6 x 50 m
    (max. 300 m cable length in total)
  • Mains filters ECP-0003-03 for PSD1-M_P020: Axis combination with motor cable up to 6 x 50 m
    (max. 300 m cable length in total)

Scale drawing:

Filter type | A | B | C | D | E | F | G | H | Weight | GND(I) | Connection clamp
 | mm |  |  |  |  |  |  |  | kg |  |
ECP-0003-01 | 240 | 50 | 85 | 270 | 0.8 | 30 | 255 | 5.4 | 1.5 | M5 | 10mm2
ECP-0003-02 | 305 | 60 | 150 | 335 | 1.0 | 35 | 320 | 6.4 | 3.05 | M5 | 10mm2
ECP-0003-03 | 220 | 85 | 90 | 250 | 1.0 | 60 | 235 | 5.4 | 2.4 | M6 | 16 mm2


Motor output chokes

In this chapter you can read about:

Motor output chokes ECM-0005-01 for PSD1-S (up to 7 A/ 1 mH)

Output motor chokes ECM-0004-01 for PSD1-M (up to 6.3 A/ 3.6 mH)

Motor output chokes ECM-0001-01 for PSD1-M (up to 16 A 2 mH)

Motor output chokes ECM-0002-01 for PSD1-M (up to 30 A/ 1.1 mH)

Wiring of the motor output filter

We offer motor output chokes for disturbance suppression when the motor connecting cables are long:


Motor output chokes ECM-0005-01 for PSD1-S (up to 7 A/ 1 mH)

For motor cable length > 50m

Inductance | 1 mH
Rated current | 7 A
Protection class | Not defined
Ambient temperature | 0 - 40 °C
Max. Elevation of operating site | 1000 m above sea level
Weight | 2.5 kg

Up to 7 A nominal motor current (1 mH)

Scale drawing:

Stated in mm


Output motor chokes ECM-0004-01 for PSD1-M (up to 6.3 A/ 3.6 mH)

For motor cable length > 20m

Inductance | 3.6 mH
Rated current | 6.3 A
Protection | IP00
Ambient temperature | 0 -40 °C
Max. Elevation of operating site | 1000 m above sea level
Weight | 3.2 kg

Scale drawing:

Stated in mm


Motor output chokes ECM-0001-01 for PSD1-M (up to 16 A 2 mH)

For motor cable length > 20m

Inductance | 2 mH
Rated current | 16 A
Protection class | IP00
Ambient temperature | 0 -40 °C
Max. Elevation of operating site | 1000 m above sea level
Weight | 4 kg

Scale drawing:

Stated in mm


Motor output chokes ECM-0002-01 for PSD1-M (up to 30 A/ 1.1 mH)

For motor cable length > 20m

Inductance | 1.1 mH
Rated current | 30 A
Protection | IP00
Ambient temperature | 0 -40 °C
Max. Elevation of operating site | 1000 m above sea level
Weight | 7 kg

Scale drawing:

Stated in mm


Wiring of the motor output filter

Wiring using a standard motor-cable:

Motordrossel verdrahten PSD

Wiring using HIPERFACE DSL® Feedback:

Motordrossel verdrahten PSD DSL

Please note the following instructions if you are using the hybrid cable with DSL lines with a motor choke:

  • The DSL cable must not be cut (also or especially the DSL cable shield must remain intact).
    In case of a motor with brake, the same applies to the brake control line in the hybrid cable.
  • A shield connection of the complete outer shield and DSL shield must be ensured at the input and the output side of the motor choke (e.g. braiding the cable, soldering or connecting by using self-adhesive EMC copper tape).
  • The motor cable shield must not be interrupted at the motor choke. This is ensured by using the ground cable shield clamps of the motor choke at the input and the output side.
  • Make sure that the shielding is carried out over a large area!
  • The overall connection between choke & motor has to be done by a modified DSL motor cable (CBMxxxH...).

Example of a possible wiring of a hybrid cable using a motor choke:

ECM-0005-001 verdrahtet PSD


Line choke

In this chapter you can read about:

Line choke für PSD1-M_P010: 0.86 mH / 30 A

Line choke for PSD1_M_P020: 0.45 mH / 55 A


Line choke für PSD1-M_P010: 0.86 mH / 30 A

By means of the line choke IND-0001-02 (with UL certification) the output performance of PSD1-M_P010 can be increased by 50 %. Line chokes for reducing the low-frequency interferences on the mains side.

0.86 mH / 30 A

Scale drawing: IND-0001-02

Weight: 8 kg


Line choke for PSD1_M_P020: 0.45 mH / 55 A

By means of the line choke IND-0002-01 (with UL certification) resp. IND-0002-02 (mit UL certification), the output performance of PSD1-M_P020 can be increased by 50 %. Line chokes for reducing the low-frequency interferences on the mains side.

We offer the following line chokes:

  • IND-0002-01: 0.45 mH / 55 A / 10 kg
  • IND-0002-02: 0.45 mH / 55 A / 9 kg / UL

Scale drawing: IND-0002-01

Scale drawing: IND-0002-02 (UL-Version)


External braking resistors

In this chapter you can read about:

Overview Braking Resistors PSD1

Braking resistor ACB-0004-01

Braking resistor ACB-0005-01 & ACB-0005-02

Braking resistor ACB-0001-1 and ACB-0002-1

Braking resistor ACB-0003-01 for PSD1-M_P020

Hazards when handling ballast resistors!

Housing temperature up to 200°C!

Dangerous voltage!

The device may be operated only in the mounted state!

The external braking resistors must be installed such that protection against contact is ensured (IP20).

Install the connecting leads at the bottom.

The braking resistors must be grounded.
We recommend to use a thrust washer for the ACB-0001-01 and ACB-0002-01.

Observe the instructions on the resistors (warning plate).

Note that a length of the cable >2 m is not permitted!

When mounting the brake resistor, please observe the expansion of the housing of max. 0.85 mm / 100 mm due to heating (mounting with fixed and floating bearings).

Mount the resistors in such a way that supply and extract air access is possible in order to avoid heat accumulation. Resistors need to be protected by respective protective measures.

The resistors with the thermal contact surface are to be mounted continuously to a flat clamping area.


Overview Braking Resistors PSD1

Category | Specifications
Braking resistor | Device | Nominal power | UL certification
ACB-0004-01 (51 W) | PSD1-S_1200 / 1300 | 100 W | With UL
ACB-0005-01 (56 W) | PSD1-S_1200 / 1300 | 120 W | With UL
ACB-0005-02 (56 W) | PSD1-S_1200 / 1300 | 190 W | With UL
ACB-0001-01 (30 W ) | PSD1-M_P010 PSD1-M_P020 with 2x30 W parallel | 400 W 2*400 W | With UL
ACB-0002-01 (15 W ) | PSD1-M_P010 with 2x15 W in series PSD1-M_P020 | 2*400 W 400 W | With UL
ACB-0003-01 (15 W ) | PSD1-M_P020 | 1500 W | Without UL


Braking resistor ACB-0004-01

Pulse power (W) Tu ~ 40 °C *referring to a cycle time of120 s (reference value) | ED 6 %* | 900
 | ED 15 %* | 500
 | ED 25 %* | 300
 | ED 40 %* | 200
Nominal continuous output (W) Ta ~ 40°C |  | 100
Nominal resistance value at 20°C |  | 51 W
Nominal tolerance at 20°C |  | ±10%
Type of protection (EN 60529) (in the corresponding bolted state) |  | IP 65
Max. permitted operation voltage |  | UL 1000 V
Cooling |  | Natural convection
Housing temperature at a continuous nominal output Tu ~ 40 °C |  | approx. 180 °C
Electrical connection |  | 2x AWG 14 / l=25 cm
Operating temperature range |  | -25 ... +40 °C
Test voltage |  | 2.7 kV AC 1 s
Certification / Marking |  | UL; CSA
Weight |  | 0.43 kg
Mounting positions |  |

Scale drawing:

Stated in mm


Braking resistor ACB-0005-01 & ACB-0005-02

 | Type: | ACB-0005-01 | ACB-0005-02
Pulse power (W) Tu ~ 40 °C *referring to a cycle time of120 s (reference value) | ED 6 %* | 984 | 1558
 | ED 15 %* | 504 | 798
 | ED 25 %* | 360 | 570
 | ED 40 %* | 264 | 418
Nominal continuous output (W) Ta ~ 40°C |  | 120 | 190
Nominal resistance value at 20°C |  | 56 W
Nominal tolerance at 20°C |  | ±10%
Type of protection (EN 60529) (in the corresponding bolted state) |  | IP 54
Max. permitted operation voltage |  | UL 800 V
Cooling |  | Natural convection
Housing temperature at a continuous nominal output Tu ~ 40 °C |  | approx. 200 °C
Electrical connection |  | 2x AWG 18/19 / l=50 cm
Operating temperature range |  | -30 ... +40 °C > 40 °C 4% reduction per 10 K
Test voltage |  | 4.2 kV DC
Certification / Marking |  | UL; CSA
Weight |  | 0.34 kg | 0.515 kg
Mounting positions |  |

Scale drawing:

Dimensions | O | B | C | D | E | F | G | H | J
ACB-0005-01 | 240 | 45 | 40 | 20 | 6.2 | 18.2 | 2 | 222 | 4.3
ACB-0005-02 | 360 | 45 | 40 | 20 | 6.2 | 18.2 | 2 | 342 | 4.3

Stated in mm


Braking resistor ACB-0001-1 and ACB-0002-1

Pulse power (W) Tu ~ 40 °C *referring to a cycle time of120 s (reference value) | ED 6 %* | 3600
 | ED 15 %* | 2000
 | ED 25 %* | 1200
 | ED 40 %* | 800
Nominal continuous output (W) Ta ~ 40°C |  | 400
Nominal resistance value at 20°C |  | ACB-0001-01: 30 W ACB-0002-01: 15 W
Nominal tolerance at 20°C |  | ±10%
Type of protection (EN 60529) (in the corresponding bolted state) |  | IP 54
Max. permitted operation voltage |  | UL 600 / 1000 V
Cooling |  | Natural convection
Housing temperature at a continuous nominal output Tu ~ 40 °C |  | approx. 340 °C
Electrical connection |  | 2x AWG 16 / l=25 cm
Operating temperature range |  | -25 ... +40 °C
Test voltage |  | 2.7 kV AC 1 s
Certification / Marking |  | UL; CSA
Weight |  | 1.1kg
Mounting positions |  |

Scale drawing:

Stated in mm


Braking resistor ACB-0003-01 for PSD1-M_P020

Pulse power (W) Tu ~ 40 °C *referring to a cycle time of120 s (reference value) | ED 1%* | 30.0
 | ED 6%* | 12.0
 | ED 15%* | 6.8
 | ED 25%* | 4.5
 | ED 40%* | 3.2
 | ED 60%* | 2.3
Nominal continuous output (W) Ta ~ 40°C |  | 1.5
Nominal resistance value at 20°C |  | 15 W
Nominal tolerance at 20°C |  | ±10%
Type of protection (EN 60529) (in the corresponding bolted state) |  | IP 20
Max. permitted operation voltage |  | 600 VAC or 800 V DC
Cooling |  | Natural convection
Electrical connection |  | on the thermal current overload cut-off 2.5 mm2
Operating temperature range |  | +5 ... +40 °C
Test voltage |  | 2.5 kV AC
Certification / Marking |  | CE
Weight |  | 4.4 kg
Mounting positions |  |

Scale drawing:

1: thermal overcurrent relay

 |  | ACB-0003-01
O | mm | 540
B | mm | 620
C | mm | 64


Interface Cables

In this chapter you can read about:

Ethernet Cables: CBD000C0-T00-T00-xxxx-00


Ethernet Cables: CBD000C0-T00-T00-xxxx-00

Ethernet - Crossover - cable Cat5e

Length code des Ethernet - Crossover - cables: CBD000D0-T00-T00-xxxx-00

xxxx = Length code (Active part length in dm)

0.25 m | CBD000D0-T00-T00-0002-00
0.5 m | CBD000D0-T00-T00-0005-00
1 m = | CBD000D0-T00-T00-0010-00